NetWorker: Azure VM Snapshot відновлення не вдається "вихідний BLOB не належить до тієї ж області, що й диск"

Summary: Snapshot відновлення NetWorker Azure Virtual Machine (VM) не вдається, повідомляючи, що вихідний BLOB не належить до тієї ж області, що й диск.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Віртуальні машини Azure захищені за допомогою захисту
знімків віртуальних машин NetWorker Azure.Не вдається відновити знімок віртуальної машини Azure із такою помилкою в журналі відновлення Debug 7 (D7):

208119:nsrazure_recover: Error from url 'https://management.azure.com/subscriptions/SUBSRIPTION_ID/resourceGroups/RESOURCE_GROUP_NAME/providers/Microsoft.Compute/disks/VM-NAME_OsDisk_JOB-NAME_JOBID_TIME-STAMP?api-version=2021-12-01': Response Code: 400 Response Data: {
  "error": {
    "code": "BadRequest",
    "message": "The source blob https://STORAGE-ACCOUNT-NAME.blob.core.windows.net/CONTAINER-NAME/VM-NAME_OsDisk_JOB-NAME_JOBID_TIME-STAMP does not belong to the same region as the disk."
  }
}
..
MM/DD/YY HH:mm:SS nsrazure_recover-D7 restoreDiskFromBlob failed for payload '{
  "location": "REGION-NAME",
  "properties": {
    ...
    },
    "creationData": {
      "createOption": "Import",
      "sourceUri": https://STORAGE-ACCOUNT-NAME.blob.core.windows.net/CONTAINER-NAME/VM-NAME_OsDisk_JOB-NAME_JOBID_TIME-STAMP,
      "storageAccountId": "/subscriptions/SUBSCRIPTION-ID/resourceGroups/RESOURCE-GROUP-NAME/providers/Microsoft.Storage/storageAccounts/STORAGE-ACCOUNT-NAME"
    },
    "diskSizeGB": SIZE
  }
}'
MM/DD/YY HH:mm:SS nsrazure_recover-D6 restoreDiskFromBlob: end
207541:nsrazure_recover: Unable to start recover session for subscription 'SUBSCRIPTION-NAME', resource group 'RESOURCE-GROUP-NAME', storage account 'STORAGE-ACCOUNT-NAME'

Cause

Розташування цільового диска, вибране під час відновлення, знаходиться в іншому регіоні Azure, ніж обліковий запис сховища BLOB-об'єктів Azure. Наприклад, використовується ціль відновлення southcentralus; однак обліковий запис сховища Azure, зазначений у відновленні, знаходиться в eastus2.

Вихідний BLOB і цільовий керований диск мають належати до одного регіону.

Resolution

  1. Увійдіть на портал Azure.
  2. Перейдіть до облікового запису сховища , який використовувався під час відновлення. https://portal.azure.com/#browse/Microsoft.Storage%2FStorageAccounts Це гіперпосилання веде вас на веб-сайт за межами Dell Technologies.
  3. На вкладці «Огляд» облікового запису сховища перевірте місцезнаходження. Якщо розташування облікового запису сховища не збігається з розташуванням цільового диска, визначте або створіть обліковий запис сховища в тому ж регіоні Azure. Наприклад:

Обліковий запис сховища Azure

ПРИМІТКА. Обліковий запис сховища має належати до групи ресурсів, до якої відновлюється віртуальна машина.
  1. Знову виконайте відновлення Azure, використовуючи розташування облікового запису сховища Azure, яке збігається з цільовим розташуванням диска:

Відновлення імені облікового запису сховища

Additional Information

Це обмеження в Azure. Під час імпорту через портал Azure потрібно вибрати регіон призначення Azure , доступний для облікового запису сховища. Не можна вибрати регіони, не пов'язані з обліковим записом сховища.
Бачити: Підручник: Імпортуйте дані до сховища BLOB-об'єктів за допомогою служби імпорту/експорту Azure Це гіперпосилання веде вас на веб-сайт за межами Dell Technologies.

 

У посібнику з інтеграції знімків NetWorker Azure VM зазначено наступне для параметрів командного рядка відновлення:

-Л  Вказує область створеної віртуальної машини. Цей параметр отримується на основі інформації, яка збирається під час резервного копіювання.

Оскільки в інтерфейсі відновлення немає опції, цільова область походить від резервної копії.

Всі посібники NetWorker доступні за посиланням: https://www.dell.com/support/product-details/product/networker/docs

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000339191
Article Type: Solution
Last Modified: 02 Jul 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.