SourceOne Email Management: Microsoft IIS server does not log User Name for users logging out and then logging back in to SourceOne Search

Summary: Microsoft IIS server does not log User Name for users logging out and then logging back in to SourceOne Search

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Microsoft IIS server does not log username when a user logs out of SourceOne  Search and then logs back in without closing browser.

Cause

Microsoft IIS server does not properly log user name when using 'Classic' pipeline mode for the site application pool.

Resolution

To resolve the issue follow this procedure.

1) Open Internet Information Services Manager on SourceOne servers that have the 'EMC SourceOne Search' software installed

2) Select  Application Pools 
3) Right-click on the  Search  application pool
4) Select  Basic Settings 
5) Use the  Managed pipeline mode  drop-down to change to  Integrated  mode.
Username will be logged as expected in the IIS server logs.

The SourceOne Email Management installation kit will be updated to set 'Integrated' mode in the next service pack that follows 7.2.8 SP9

Additional Information

This observation was made when using forms authentication.

Affected Products

SourceOne

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000055715
Article Type: Solution
Last Modified: 26 May 2025
Version:  5
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