XtremIO: Secure Connect Gateway: ConnectEMC-HTTPS port 443-Certificate Expiration on March 21, 2025
Summary: XtremIO legacy ConnectEMC software configured to call home with HTTPS to a Secure Connect Gateway (SCG) stops calling home on March 21, 2025 due to ConnectEMC certificates expiring. This issue affects the ConnectEMC HTTPS transport only. ConnectEMC configurations using other protocols (for example, SMTP) are not impacted. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Affected products stop calling home with ConnectEMC logs showing:
http failed SSL certificate problem: Certificate has expired, error:60 SSL certificate problem: certificate has expired
Cause
The ConnectEMC server (SCG gateway on port 443) and ConnectEMC root certificate (products) expire on March 21, 2025 20:06:17 UTC and March 22, 2025 20:16:13 UTC respectively.
Resolution
These upgrades can be performed anytime prior to the SCG gateway certificate expiry on March 21, 2025 20:06:17 GMT, and in any order.
- Update the SCG gateway to version 5.24 or later, which has a new ConnectEMC server certificate for port 443.
- Upgrade the XtremIO XMS code to 6.4 or later.
Affected Products
XtremIO Family, XtremIO HW X2-R, XtremIO HW X2-S, XtremIO HW X2-T, XtremIO X1, XtremIO X2Article Properties
Article Number: 000225921
Article Type: Solution
Last Modified: 11 Apr 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.