PowerStore: L'utilizzo del file system ottenuto tramite i comandi pstcli o API REST non si aggiorna

Summary: I clienti che eseguono script di comandi pstcli o script di comando API REST per ottenere l'utilizzo delle dimensioni del file system non otterranno i valori aggiornati a meno che non aggiornino manualmente l'utilizzo emettendo il comando refresh_usage o accedendo alla GUI e visualizzando l'utilizzo per quel file system specifico. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

I comandi pstcli e API REST restituiscono lo stesso valore di utilizzo del file system, anche se vengono scritti nuovi dati nel file system, quando un appliance esegue PowerStore OS inferiore a 4.0.0.x

Esempio di comando Pstcli: 

- before adding files:
cli> file_system -name test show -select name,size_used
name      = test
size_used = 1621098496 (1.50G)


- after adding files

cli> file_system -name test show -select name,size_used
name      = test
size_used = 1621098496 (1.50G)  <----- notice the size didn't change. 

cli> file_system -name test refresh_usage
Success



cli> file_system -name test show -select name,size_used
name      = test
size_used = 3948937216 (3.67G)    <------ notice the newly updated used space.

 

 

 


 

Cause

Si verifica un problema nella versione di PowerStoreOS inferiore alla 4.0.0.x che richiede l'aggiornamento manuale dell'utilizzo del file system. 

Resolution

Soluzione alternativa: 
Eseguire un refresh_usage esempio command:

PstCLI:

cli> file_system -name <filesystem name> refresh_usage


Opzione del comando Curl:

curl -k --user Username:Password -X POST https://<Management IP>:443/api/rest/file_system<filesystem ID>/refresh_usage -H "dell-visibility:internal"


Opzione GUI:
Andare al file system che si desidera aggiornare manualmente utilizzando la GUI.  Una volta cliccato sul file system, viene eseguito il comando refresh_usage. 

Correzione:
questo problema è stato risolto in PowerStoreOS 4.0.0.x e versioni successive.

Affected Products

PowerStore, PowerStore 1000T, PowerStore 3000T, PowerStore 3200T, PowerStore 5000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000T, PowerStore 9000T, PowerStoreOS
Article Properties
Article Number: 000227830
Article Type: Solution
Last Modified: 26 Sept 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.