PowerStore: Node fails to join back to the cluster
Summary: PowerStore node fails to join back to the cluster following an unexpected reboot due to a hardware issue, software issue, or a node replacement.
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Not all product versions are identified in this article.
Symptoms
Possible alerts:
- The frontend ports report link state down and small form-factor pluggable (SFP) health disconnected state.
0x0030A105- Alert generated for SFP module not inserted or seated correctly.0x00304404- Node was physically removed or shut down.0x0030CB01- I/O is not ready on the node.0x00307701- XENV is not active.- The node life cycle state changed (disconnected).
- The node's I/O service level changed (
not_ready). DataPath (DP) fails to start on the node. - No hardware faults on the nodes.
Cause
This is due to a rare condition that can occur on systems running PowerStoreOS 3.x versions. An internal system process fails to trigger a node failover after an unexpected node reboot. Once the node comes back up, it fails to join back to the cluster.
Resolution
This issue is addressed in PowerStoreOS 3.6.1.0 and later.
If the issue reported in this article occurs, Contact Technical Support | Dell US or your Authorized Service Representative for assistance, and quote this Dell article ID.
Affected Products
PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 1200T, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore 5000X, PowerStore 5000T, PowerStore 500TProducts
PowerStore Expansion Enclosure, PowerStore Rack, PowerStore 5200T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T, PowerStore 9200T, PowerStore Employee and PartnerArticle Properties
Article Number: 000206302
Article Type: Solution
Last Modified: 07 Nov 2025
Version: 10
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