PowerProtect Data Manager (PPDM):由于 VM Direct 保护引擎无法升级

Summary: VM Direct 保护引擎无法升级,导致其余组件也无法升级。 PowerProtect Data Manager (PPDM):VM Direct 保护引擎由于错误消息“VM found to no ExtensionKey, but expected 'com.emc.vproxy.visd'”而无法升级

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Symptoms

在将 PowerProtect Data Manager 从版本 19.14 升级到 19.15 时,核心服务升级后,下一步是升级 VM Direct Protection Engines。

负责 VM Direct 保护引擎升级的作业可能会失败,并显示类似于以下内容的错误消息:
Failed to complete the software update.
UPG0037 -
VM Direct Protection Engines update failed, Unable to update protection engine 'HostName/IPAddress' - AutoUpgrade request unsuccessful. Unable to AutoUpgrade vProxy. Unable to deploy vProxy HostName/IPAddress. Unable to deploy VM. Unable to delete the vProxy 'Hostname/IPAddress' from the vCenter server. Found VM with Moref 'VirtualMachine:MorefNumber' but it is not managed by our component. This can be due to a misconfiguration. VM found to have no ExtensionKey, but expected 'com.emc.vproxy.visd'.
Remediation: Contact Dell Customer Support.
 

Cause

当虚拟机在某个时间点从 VMware vCenter 中注销,然后再次注册时,就会发生这种情况。因此,分配给虚拟机的 ExtensionKey 不再适用。

Resolution

要解决此问题,请从 VMware vCenter 中删除虚拟机 (VM Direct Protection Engine) 并使用 PowerProtect Data Manager 用户界面重新部署。

有关部署和或重新部署 VM Direct Protection Engine 的更多信息,请参阅 PowerProtect Data Manager Virtual Machine User Guide (PowerProtect Data Manager 虚拟机用户指南) 。

重新部署 VM Direct 保护引擎后,重新启动 PowerProtect Data Manager 升级过程。 

Affected Products

PowerProtect Data Manager Appliance, PowerProtect Data Manager, PowerProtect Data Manager Essentials, PowerProtect Data Manager Software
Article Properties
Article Number: 000220104
Article Type: Solution
Last Modified: 02 Sept 2025
Version:  3
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