Secure Connect Gateway version 5.26.00.18 Alert Delivery Call Home Issue with .cec Ext
Summary: Secure Connect Gateway (SCG) updated from previous versions to 5.26.00.18 are having issues with products (ECS, Brocade Switches, and XtremIO) failing to send alerts (Call Homes) with file extension .cec. ...
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The connecthomerest.log at path /var/log/esrs is showing the below errors:
As a result of this error, the call home fails to deliver.
Note: This issue affects the device models ECS, Brocade Switches, and XtremIO.
Unrecognized field \"time\"
Note: This issue affects the device models ECS, Brocade Switches, and XtremIO.
Cause
The cause of the failure is a change in the spring boot jackson-core and jackson-bind libraries between 5.24 or earlier versions and 5.26.00.18. Prior to version 5.26, unknown attributes were ignored by default.
Resolution
To address this issue, perform one of the following actions:
Note: This hotfix can be safely applied to any SCG 5.26.00.18 system regardless of deployed device types.
- Update the Secure Connect Gateway to version 5.26.00.20
- Log in to the Secure Connect Gateway Web UI (version 5.26.00.18), and click About in the upper right section. Open the Hotfix Deployment screen, and apply the relevant hotfix.
This hotfix does NOT require a reboot once applied.
Note: This hotfix can be safely applied to any SCG 5.26.00.18 system regardless of deployed device types.
Note: There is no difference between an SCG version 5.26.00.18 with the hotfix applied and version 5.26.00.20.
Affected Products
Brocade, ECS, XtremIOArticle Properties
Article Number: 000243317
Article Type: Solution
Last Modified: 04 Dec 2024
Version: 5
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