NetWorker: Getting XDR error when a specific user accesses NetWorker resources from NetWorker Management Console

Summary: Getting XDR error when a specific user accesses NetWorker resources from NetWorker Management Console (NMC).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The customer sees an XDR error when a specific user accesses NetWorker resources from NMC.

nsrmmdbd RPC critical Unable to decode XDR stream from client xxxxx
In this log extract, xxxxx is the NMC Server.

Cause

The NMC Server client instance is not created in NetWorker.

Resolution

Follow these steps:
  1. Create a Client Instance of NMC in NetWorker Server.
  2. In the NMC UI, right-click the Client Properties of NW Server. In the Remote access field, input the NMC hostname xxxxx.
  3. In the NMC UI, right-click the Client Properties of NMC. In the Remote access field, input the NW Server hostname.

Affected Products

NetWorker Family, NetWorker Series, NetWorker Management Console
Article Properties
Article Number: 000056622
Article Type: Solution
Last Modified: 11 Dec 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.