Serie VNX1: Il failover di VNX Data Mover non si è verificato dopo un guasto hardware di CS

Summary: Serie VNX1: Il failover di VNX Data Mover non si è verificato dopo un guasto hardware di CS (correggibile dall'utente)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Guasto hardware nell'array di una singola control station

Si è verificato un guasto della control station VNX e, prima di sostituire l'hardware, si è verificato un guasto che normalmente avrebbe dovuto attivare un failover del data mover, ma non si è verificato alcun failover del data mover.

 

Cause

Array con una singola control station, quando si verifica un guasto hardware sulla control station che ne determina il mancato avvio o l'impossibilità di eseguire correttamente i servizi della NAS Control Station per la gestione dell'array, qualsiasi evento successivo che normalmente attiverebbe un failover del data mover non lo farà. La stazione di controllo NAS e i relativi servizi di gestione sono necessari per eseguire un failover del data mover. Una control station non funzionante o con i servizi NAS in stato arrestato non può attivare un failover del data mover.

In una configurazione a doppia control station, un guasto dei servizi o dell hardware della control station primaria comporterà l'assunzione forzata del ruolo di control station primaria da parte della control station peer in standby, che viene attivata quando la control station peer non riesce a ricevere risposte agli heartbeat di gestione o le risposte heartbeat superano un valore di timeout.

 

Resolution

Per una control station online, eseguire il comando "nas_checkup" per confermare se sono stati segnalati guasti hardware o software. In caso di guasti hardware, è necessario contattare il supporto VNX per la loro risoluzione. Potrebbe essere possibile risolvere un avviso per un problema software utilizzando il https://support.emc.com/ della Knowledge Base di Dell

Se possibile, eseguire sempre una raccolta del materiale di supporto sulla control station per acquisire i registri e lo stato corrente prima di modificarli, in modo da poterli analizzare se necessario.

Per verificare in modo specifico la presenza di un guasto hardware è possibile utilizzare solo i comandi riportati di seguito. Per lo stato dell'enclosure, il numero di enclosure del data mover viene specificato dopo (-e)

$ nas_inventory -tree
$ /nas/sbin/enclosure_status -e 0 -v

 

Additional Information

Altri riferimenti:
La procedura per generare questo file ZIP di diagnostica sulla control station VNX è la seguente:

[Raccolta dei materiali di supporto]

  1. Per generare una raccolta dei materiali di supporto (pacchetto diagnostico) dal NAS VNX, eseguire il seguente script sulla control station quando si è connessi tramite SSH e si è effettuato l'accesso come nasadmin.

    $ /nas/tools/collect_support_materials
  2. Al termine dello script, viene generato un file Zip con il nome e la posizione di questo file visualizzati sullo schermo

  3. È necessario un client SCP come Winscp per scaricare il file dalla control station alla workstation. Il percorso predefinito sulla control station in cui generare i materiali di supporto raccolti è /nas/var/emcsupport.

    Nota: I materiali di supporto per la raccolta più vecchi verranno eliminati automaticamente per liberare spazio, se richiesto in /nas/var/emcsupport.

Celerra: Come aumentare il valore di timeout del failover della Control Station.
https://support.emc.com/kb/331802 (per visualizzare questo articolo è necessario un account del supporto Dell)
La procedura di failover di Celerra e VNX File Data Mover (per visualizzare questo articolo è necessario un account del supporto Dell)

 

Affected Products

VNX1 Series

Products

VNX1 Series, VNX2 Series, VNX5200, VNX5300, VNX5400, VNX5500, VNX5600, VNX5700, VNX5800, VNX7500, VNX7600, VNX8000
Article Properties
Article Number: 000061849
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.