NVP vProxy: nsrvproxy_mgmt redeploy fails with "cannot get desired visd status for redeploy request"

Summary: The NetWorker VMware Protection (NVP) vProxy appliance is redeployed or upgraded using the nsrvproxy_mgmt command. The process fails, stating "Vproxy upgrade: cannot get desired visd status for redeploy request. Either an error occurred or visd was unable to process request in expected time." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The vProxy appliance is redeployed or upgraded using the nsrvproxy_mgmt command or from the NetWorker Web User Interface (NWUI); however, the process is failing with the following errors:

[root@nsr nsr]# nsrvproxy_mgmt redeploy -h nsr-vproxy01.amer.lan -z '!Password1' -f
160859:nsrvproxy_mgmt: vProxy management job started with CLI: 'nsrvproxy_mgmt redeploy -h nsr-vproxy01.amer.lan -z **** -f '
161335:nsrvproxy_mgmt: Starting 'nsr-vproxy01.amer.lan' vProxy redeployment on 'vcsa.amer.lan' vCenter.
200749:nsrvproxy_mgmt: Hostname override. Using alias 'nsr-vproxy01.amer.lan' instead.
04/29/25 09:24:41.124777 nsrvproxy_mgmt-D0 libCURL SSL support is Enabled.
204227:nsrvproxy_mgmt: Vproxy upgrade: cannot get desired visd status for redeploy request. Either an error occurred or visd was unable to process request in expected time.
 Refer the latest logs at the path nsr\logs\adhoc\nsrvproxy_mgmt directory.

186879:nsrvproxy_mgmt: Downloaded logs for VISD upgrade session.186882:nsrvproxy_mgmt: Deleted VISD upgrade session.
204227:nsrvproxy_mgmt: Vproxy upgrade: cannot get desired visd status for redeploy request. Either an error occurred or visd was unable to process request in expected time.
 Refer the latest logs at the path nsr\logs\adhoc\nsrvproxy_mgmt directory.

161329:nsrvproxy_mgmt: Failed to redeploy vProxy 'nsr-vproxy01.amer.lan': vProxy Redeployment failed with error(s) : Vproxy upgrade: cannot get desired visd status for redeploy request. Either an error occurred or visd was unable to process request in expected time.
 Refer the latest logs at the path nsr\logs\adhoc\nsrvproxy_mgmt directory.
.
161319:nsrvproxy_mgmt: vProxy management job completed with errors.

The /nsr/logs/adhoc/nsrvproxy_mgmt/vproxy_upgrade_session_nsr-vproxy01.amer.lan_JOBID log on the NetWorker server reports:

YYYY-MM-DDTHH:mm:SS-TZ ERROR:  [@(#) Build number: 90] Unable to access the OVA file '': open : no such file or directory
YYYY-MM-DDTHH:mm:SS-TZ ERROR:  [@(#) Build number: 90] Unable to locate the vProxy OVA file for deployment.

Cause

The vProxy OVA was placed in an incorrect directory; for example: /nsr/vproxy_ova_ovas

The required directory is:
Linux: /nsr/vproxy_ova/ovas
Windows: <install drive>:\Program Files\EMC NetWorker\nsr\vproxy_ova\ovas

The NetWorker Web User Interface redeploy option provides the following statement:
NWUI vProxy redeploy option 

Resolution

Move the vProxy OVA to the correct directory.

See: NVP vProxy: How To Upgrade the NVP vProxy Appliance Using nsrvproxy_mgmt

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000314581
Article Type: Solution
Last Modified: 29 Apr 2025
Version:  1
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