Support für das Dell iDRAC Service Module

Summary: Das iDRAC Service Module (iSM) ist ein einfacher Softwareservice, der Funktionen des Betriebssystems (BS) besser in iDRAC integriert und auf Dell PowerEdge-Servern installiert werden kann. iSM stellt betriebssystembezogene Informationen für den iDRAC bereit und fügt Funktionen hinzu, wie z. B. die Replikation von LC-Protokollereignissen (Life Cycle), iDRAC-SNMP-Warnungen über das Betriebssystem, Remote-iDRAC-Hard-Reset und vollständiges Aus- und Einschalten. Dieser Leitfaden bietet eine Übersicht über die Funktionen, den Download und die Installation sowie zusätzliche Ressourcen. ...

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Symptoms

Dell EMC iDRAC Service-Modul

Integrated Dell Remote Access Controller Service Module (iSM)

  • Erweitert die iDRAC-Verwaltung für unterstützte Host-Betriebssysteme
  • iSM stellt dem iDRAC Informationen zum Betriebssystem bereit.
  • Ressourcenschonender Software-Service mit minimalen Auswirkungen auf den Host

Das Integrated Dell Remote Access Controller (iDRAC)-Service-Modul (iSM) ist eine einfache optionale Softwareanwendung, die auf PowerEdge-Servern installiert werden kann. Das iDRAC Service Module ergänzt iDRAC-Schnittstellen: Benutzeroberfläche (UI), RACADM-CLI, Redfish mit zusätzlichen Überwachungsdaten Die iDRAC-Servicemodul-Architektur nutzt die IP-Socket-Kommunikation und stellt dem iDRAC zusätzliche Systemverwaltungsdaten (BS/Gerätetreiber) zur Verfügung und stellt 1:n-Konsolen mit Zugriff auf Systemverwaltungsdaten über Standardschnittstellen des Betriebssystems bereit.


 

Funktionen des iDRAC-Service-Moduls

 

Korrelation von Softwareereignissen zu Hardwarefehlern für Microsoft S2D (16G und früher)

Die Ereignisprotokolle für Hardware-Storage-Pool-Warnmeldungen oder -Ereignisse werden vom iSM mit der Server-Storage-Korrelationsfunktion überwacht. Das Server-Storage-Subsystem wird überwacht, wenn Dell Storage-Controller im RAID-Modus verwendet werden. In Storage Spaces (SS) oder Storage Space Direct (S2D) wird das Server-Storage-Subsystem jedoch im Passthrough-Modus überwacht oder der SATA-Chipsatz wird verwendet, um den Storage-Pool zu erstellen. Mit dieser Funktion werden die vom Lifecycle-Protokoll abgedeckten hardwaredefinierten Warnmeldungen und die von den Betriebssystemprotokollen abgedeckten softwaredefinierten Warnmeldungen zusammengeführt und die Warnmeldungen in den iDRAC-Lifecycle-Protokollen registriert. Diese Funktion wird mit dem iDRAC Service Module-Paket installiert und ist standardmäßig aktiviert. Benutzer können die Einstellungen in den iDRAC-Einstellungen ändern. Im Rahmen der Überwachung prüft iSM die Protokolle auf potenzielle Fehler und Warnungen. Das iSM bettet die SS-Korrelationsereignisse auf dem Host in ein entsprechendes LC-Ereignis ein.

Betriebssysteminformationen

Server Administrator teilt Betriebssysteminformationen und Hostnamen mit dem iDRAC. Der iSM stellt ähnliche Informationen wie den Namen des Host-Betriebssystems, die IP-Adresse des Server-Hosts, die Betriebssystemversion und den vollqualifizierten Domänennamen (FQDN) für den iDRAC bereit. Die Netzwerkschnittstellen auf dem Host-Betriebssystem werden ebenfalls angezeigt. Diese Überwachungsfunktion ist standardmäßig aktiviert. Diese Funktion ist auch dann verfügbar, wenn Server Administrator auf dem Host-Betriebssystem installiert ist.

Automatische Systemwiederherstellungsfunktion

Die Funktion zur automatischen Systemwiederherstellung ist ein hardwarebasierter Timer, mit dem der Server im Falle eines Hardwarefehlers zurückgesetzt wird. Die Funktion kann automatische Systemwiederherstellungsvorgänge wie Neustart, Aus- und Einschalten oder Ausschalten nach einem bestimmten Zeitintervall ausführen. Diese Funktion ist nur aktiviert, wenn der Watchdog-Timer des Betriebssystems deaktiviert ist. Wenn Server Administrator installiert ist, ist die Überwachungsfunktion deaktiviert, um doppelte Watchdog-Zeitgeber zu vermeiden.

Lifecycle Controller-Protokollreplikation in das Betriebssystem

iSM repliziert die LC-Protokolle (Lifecycle Controller) in die Betriebssystemprotokolle. Alle Ereignisse mit der Option „OS Log“ als Ziel (auf der Seite „Alerts“ oder in den entsprechenden RACADM- oder WSMAN-Schnittstellen) werden mit iSM im Betriebssystemprotokoll repliziert. Dieser Vorgang ähnelt der von Server Administrator durchgeführten SEL-Replikation (System Event Log).

Die Standardprotokolle, die in die Betriebssystemprotokolle aufgenommen werden sollen, entsprechen den Protokollen, die für SNMP-Traps/Warnmeldungen konfiguriert wurden. Nur die Ereignisse, die nach der Installation von iSM im LC-Protokoll protokolliert wurden, werden in das Betriebssystemprotokoll repliziert. Wenn Server Administrator installiert ist, ist die Überwachungsfunktion deaktiviert, um doppelte SEL-Einträge im Betriebssystemprotokoll zu vermeiden.

iDRAC-Zugriff über Host-BS

Verwalten Sie mit den PowerEdge-Servern von Dell die Hardware oder Firmware eines Geräts über iDRAC, indem Sie ein dediziertes iDRAC-Netzwerk konfigurieren. Greifen Sie über den dedizierten Netzwerkport auf die iDRAC-Schnittstellen wie UI, RACADM und Redfish-Client zu.

Voraussetzung für die Verwaltung der Hardware oder Firmware ist eine dedizierte Verbindung zwischen einem Gerät und der unterstützten iDRAC-Schnittstelle. Stellen Sie mit der Funktion „iDRAC-Zugriff über Host-BS“ unabhängig von der Verbindung zwischen einem Gerät und einem dedizierten iDRAC-Netzwerk eine Verbindung zu einer iDRAC-Schnittstelle von einer Betriebssystem-IP oder einem -Host her. Mit dieser Funktion wird die Hardware oder Firmware überwacht, auch wenn der iDRAC nicht mit den Servern verbunden ist.

FullPowerCycle

Die FullPowerCycle-Funktion bietet eine Möglichkeit zum Zurücksetzen der Server-Hilfsstromversorgung. Immer mehr Serverhardware wird mit der Server-Hilfsstromversorgung betrieben, und das Troubleshooting bei einigen Server-Problemen erfordert, dass das Stromkabel des Servers physisch aus der Steckdose gezogen wird, um die mit der Hilfsstromversorgung betriebene Hardware zurückzusetzen. Dies führt dazu, dass jemand die Stromkabel physisch abziehen/anschließen muss, was zu erheblichen Kosten und Aufwand für KundInnen und SupportmitarbeiterInnen führt. Die FullPowerCycle-Funktion ermöglicht es dem Administrator, die Hilfsstromversorgung aus der Ferne zu verbinden oder zu trennen, ohne sich im Rechenzentrum befinden zu müssen. Diese Funktion wird auf iDRAC9 unterstützt.

In-Band-Unterstützung für iDRAC-SNMP-Warnungen

Mit iDRAC, einem Out-of-Band-Server-Verwaltungs- und Überwachungstool, können die SNMP-Traps/-Warnungen im Protokoll aufgezeichnet werden. Aus Sicht der Verwaltung von Host-Betriebssystemsystemen unter Berücksichtigung der In-Band-Agent-Perspektive wird jedoch die vom Host-Betriebssystem empfangene SNMP-Warnung stärker bevorzugt als die vom iDRAC empfangenen Traps. Wenn eine SNMP-Warnung vom iDRAC empfangen wird, ist es schwierig, die Quelle der Warnung zu ermitteln, da diese von einer iDRAC-IP und nicht von der System-IP stammt.

Ab iSM 2.3 können Sie SNMP-Warnmeldungen vom Host-Betriebssystem empfangen, die den von iDRAC erzeugten Warnmeldungen ähneln.

Verbesserte Sicherheit zwischen iSM- und iDRAC-Kommunikation mithilfe des TLS-Protokolls (16G und früher)

Ab iSM 3.4 erfolgt die Datenkommunikation zwischen iSM und iDRAC über TLS-geschützte USBNIC-INET-Sockel. Dadurch wird der Schutz aller Daten gewährleistet, die vom iDRAC über USBNIC zum iSM übertragen werden. iSM und iDRAC verwenden selbstsignierte Zertifikate zur Kontrolle der Authentifizierung. Die selbstsignierten Zertifikate haben 10 Jahre Gültigkeit. Bei der Installation von iSM werden jedes Mal neue selbst signierte Zertifikate generiert.

S.M.A.R.T.-Monitoring (16G und darunter)

Die S.M.A.R.T-Überwachungsfunktion unterstützt Festplatten, die mit SATA im AHCI-Modus aktiviert sind. Sie verfügt über integrierte Funktionen zum Überwachen von S.M.A.R.T-Warnmeldungen über vom iDRAC unterstützte Prüfmethoden für Festplatten auf einem SATA-Chipsatz-Controller. Bisher hat ein Open-Source-Dienstprogramm die Warnmeldungen für die Festplatten überwacht, die im RAID-Modus festgelegt waren.

Single Sign-On (SSO) auf der iDRAC-Benutzeroberfläche vom Host-BS-Administrator-Desktop (16G und niedriger)

Die SSO-Funktion (Single Sign-On) ermöglicht es einem authentifizierten Betriebssystemadministrator, direkt auf die iDRAC-Webschnittstelle zuzugreifen, ohne sich mit separaten iDRAC-Administratoranmeldedaten anmelden zu müssen.

iDRAC UI Launcher

Starten Sie die iDRAC-Benutzeroberfläche vom lokalen System aus, indem Sie auf das Symbol des iDRAC UI Launcher doppelklicken. Die iDRAC-UI-Anmeldeseite wird im Standardbrowser geöffnet und die iDRAC-Zugangsdaten können für die Anmeldung auf der iDRAC-Startseite verwendet werden. Dies wird nur auf Microsoft Windows-Betriebssystemen unterstützt.

 

  
  
  


iDRAC9-Dashboard

Verbesserungen beim Dell iDRAC Service Module

Dell verbessert das Dell iDRAC Service Module kontinuierlich.


iDRAC Service Module (17. Generation)

iDRAC Service Module 6.x.x unterstützt PowerEdge-Server der 17. Generation.

Funktionen, DUPs, Betriebssysteme und Hypervisoren, die von der iSM 6.x.x-Serie unterstützt werden 
 

Unterstützte Betriebssysteme und Hypervisoren

Betriebssystem/Hypervisor iSM 6.0.1.0 iSM 6.0.3.0 iSM 6.0.5.0
Microsoft Windows Server 2022 Ja Ja Ja
Microsoft Windows Server 2025 Ja Ja Ja
Red Hat Enterprise Linux 9.4 Ja Ja Nein
Red Hat Enterprise Linux 9.6 Nein Nein Ja
Red Hat Enterprise Linux 10 Nein Nein Ja
SUSE Linux Enterprise Server 15 SP6 Nein Ja Nein
SUSE Linux Enterprise Server 15 SP7 Nein Nein Ja
Ubuntu Server 24.04.2 Nein Ja Ja
VMware vSphere ESXi 8.0 U3 Ja Ja Ja
VMware vSphere ESXi 9.0 Nein Ja Ja

 

iDRAC-Servicemodul (15. Generation, 16. Generation)

Funktionen, DUPs, Betriebssysteme und Hypervisoren, die von der iSM 5.x.x-Serie unterstützt werden 

Das iDRAC Service Module 5.4.2 unterstützt PowerEdge-Server der 15. und 16. Generation auf allen unterstützten Betriebssystemen.

Unterstützte Betriebssysteme und Hypervisors (iSM 5.4.2) 15G 16G
Microsoft Windows Server 2022 Unterstützt Unterstützt
Microsoft Windows Server 2025 Unterstützt Unterstützt
Red Hat Enterprise Linux 9.6 Unterstützt Unterstützt
Red Hat Enterprise Linux 10 Unterstützt Unterstützt
SUSE Linux Enterprise Server 15 SP7 Unterstützt Unterstützt
Ubuntu Server 24.04.2 Unterstützt Unterstützt
VMware vSphere 8.0 U3 Unterstützt Unterstützt
VMware vSphere 9.0 Unterstützt Unterstützt

 

Eine vollständige Liste der Verbesserungen sowie Einschränkungen, behobenen Probleme und bekannten Probleme finden Sie in den Versionshinweisen zum Dell iDRAC Service Module.

Eine vollständige Liste aller Versionen des iSM finden Sie unter Dell Technologies iDRAC Service Module.

Cause


iDRAC9 Settings

Dell iDRAC Service Module herunterladen und installieren

Das Dell iDRAC Service Module wird auf den meisten Versionen von Microsoft Windows-, Linux- und ESXi-Betriebssystemen für PowerEdge-Server mit iDRAC7, iDRAC8 und iDRAC9 unterstützt. Weitere Informationen zu den unterstützten Plattformen und Betriebssystemen finden Sie unter Unterstützte Plattformen.

Die spezifische Version von iSM für Ihr System variiert je nach Servermodell und installiertem Betriebssystem. So laden Sie die neueste Version von iSM herunter:

  • Rufen Sie Dell.com/support auf und wählen Sie Ihr Modell aus oder geben Sie das Service-Tag ein.
  • Wählen Sie Treiber und Downloads aus.
  • Wählen Sie das Betriebssystem für Ihr System aus.
  • Stichwort iSM
  • Laden Sie die neueste Version herunter, die für das Dell iDRAC Service Module bereitgestellt wurde.

Weitere Informationen zu den Software- und Systemanforderungen sowie die Schritte zum Installieren, Aktualisieren und Deinstallieren des iSM finden Sie im versionsspezifischen Benutzerhandbuch für das Dell Technologies iDRAC Service Module unter dem Thema „Installieren des iDRAC Service Module“.

Resolution

Ressourcen zum Dell iDRAC-Service-Modul

Community-Diskussion

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Dokumentation

Die aktuelle Dokumentation finden Sie unter Dokumentation zum Dell iDRAC Service Module.


Whitepaper

Software-RAID-Funktionen im iDRAC Service Module

Dezember 2024
20-seitiges Whitepaper
Dieses technische Whitepaper enthält Informationen zur Software-RAID-Funktion im iDRAC Service Module (iSM) und führt Sie durch die Schritte zur Aufzählung, Konfiguration und Überwachung der Controller, physischen Festplatten und virtuellen Laufwerke, die mit Dell PowerEdge-Servern verbunden sind. 

Lesen Sie das Whitepaper
iDRAC-Servicemodul – betriebssystembasierte Funktionen für die bandexterne Verwaltung mit iDRAC9

Mai 2021
, 12-seitiges Whitepaper
Zusammenfassung der neuesten Verbesserungen, die das iDRAC Service Module (iSM) für die bandexterne Verwaltung mit iDRAC9 für Kunden in Dell PowerEdge-Servern der 14. und 15. Generation bereitstellt.

Lesen Sie das Whitepaper

Dell iDRAC Service Module-Sicherheitskonfigurationshandbuch


Januar 2022
: 29-seitiger Leitfaden zur Sicherheitskonfiguration
In diesem Dokument werden die Sicherheitskonfigurationen im Zusammenhang mit dem Dell iDRAC Service Module (iSM) sowie dessen Installation, Konfiguration und Funktionalität auf dem Hostbetriebssystem beschrieben.

Lesen Sie den Sicherheitskonfigurationsleitfaden.

iDRAC Service Module – iDRAC-Zugriff über das Host-Betriebssystem


Januar 2017
17-seitiges Whitepaper
Dieses Whitepaper enthält Informationen zur Verwendung und Fehlerbehebung von iDRAC Access unter Verwendung von Hostbetriebssystemfunktionen in iDRAC Service Module v2.3 oder höher.

Lesen Sie das Whitepaper

iDRAC-Service-Modul – In-Band-iDRAC-SNMP-Warnungen aktivieren


Januar 2017
13-seitiges Whitepaper
Dieses Whitepaper enthält Informationen zur Verwendung, Konfiguration und Fehlerbehebung von bandinternen iDRAC-SNMP-Warnungen in iDRAC-Servicemodul v2.3 oder höher.

Lesen Sie das Whitepaper

iDRAC-Service-Modul – Durchführen eines iDRAC-CPU-Kaltstarts


Juli 2016
8-seitiges Whitepaper
Dieses Whitepaper enthält Informationen zur Verwendung und Fehlerbehebung der iDRAC-CPU-Hard-Reset-Funktion in iDRAC Service Module v2.3 oder höher.

Lesen Sie das Whitepaper

iDRAC-Service-Modul 2.1 (oder höher) auf Ubuntu und Debian Linux-Betriebssystemen


September 2015
19-seitiges Whitepaper
Dieses Whitepaper enthält Informationen über die Verwendung und Fehlerbehebung von iDRAC Service Module Version 2.1 oder höher auf Ubuntu- und Debian-Linux-Betriebssystemen.

Lesen Sie das Whitepaper

iDRAC-Servicemodul – Windows Management Instrumentation


April 2015
17-seitiges Whitepaper
In diesem Whitepaper wird die Verwendung des iDRAC-Service-Moduls zum Überwachen der verschiedenen Hardwareprofile über die Windows Management Instrumentation (WMI)-Client-Schnittstellen beschrieben, wie z. B. Windows PowerShell, die Windows Management Instrumentation-Befehlszeile, den Windows Remote Management-Client (WINRM), WBEMTEST.

Lesen Sie das Whitepaper
 


Videos

 

Erstinstallation – iDRAC Service Module

 

Erfahren Sie, wie Sie das iDRAC Service Module über die iDRAC-UI installieren.

November 2017

SupportAssist-Erfassung im iDRAC Service Module 3.0.1

 

Erfahren Sie, wie Sie eine SupportAssist-Erfassung über das iDRAC Service Module 3.0.1 durchführen.

November 2017

Aktivieren der Funktion „iDRAC-Zugriff über Host-BS“ in Microsoft Windows im iDRAC Service Module 2.4

 

Erfahren Sie, wie Sie die Funktion „iDRAC-Zugriff über Host-BS“ in Microsoft Windows aktivieren und konfigurieren.

Juli 2017

Installieren des iDRAC-Service-Moduls auf dem Betriebssystem Microsoft Windows Nano

Erfahren Sie, wie Sie das iDRAC Service Module in Microsoft Windows-Nano-Betriebssystemen installieren.

Juli 2017

Aktivieren der Funktion „iDRAC-Zugriff über Host-BS“ in Linux im iSM 2.4

 

Erfahren Sie, wie Sie den In-Band-iDRAC-Zugriff für Linux Systeme aktivieren.

Juli 2017

Anzeigen von iDRAC-SNMP-Traps, die vom Host-Betriebssystem empfangen wurden, unter Linux in iSM 2.4

 

Erfahren Sie, wie Sie auf Linux Betriebssystemen iDRAC-SNMP-Traps anzeigen, die vom Host-Betriebssystem empfangen wurden.

Juli 2017

Überwachen von Dell Servern über das iDRAC-Service-Modul mithilfe von WMI

 

Behandelt den Überwachungsvorgang von Dell Servern über das iDRAC-Service-Modul (iSM) unter Verwendung von Windows Management Instrumentation (WMI) für Dell Server Management Pack Suite-Version 6.3 in einer Microsoft System Center Operations Manager-(SCOM-)Umgebung.

Oktober 2024
   

Affected Products

iDRAC Service Module

Products

iDRAC7, iDRAC8, iDRAC9, Lifecycle Controllers
Article Properties
Article Number: 000178050
Article Type: Solution
Last Modified: 18 Nov 2025
Version:  29
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