Ethernet Connection Lost on Type-C Docks Connected to Dell Laptops Resuming from Hibernate

Summary: The following article provides information about an Ethernet connection issue on Dell Laptops resuming from hibernation. The wired connection is through the Local Area Network (LAN) port on a Type-C Dell Dock and nothing is marked in Device Manager. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Wired network drops when resuming from S4 on a Dell Laptop and Dock

 

You may experience an Ethernet issue when you resume from Windows hibernation (S4) on a Dell laptop that connects to a Dell Type-C docking station:

This affects the following Dell laptop families:

  • Precision Mobile Workstation
  • Dell Latitude Laptops
  • Dell XPS Laptop Family
  • Dell Pro Laptop Family

This affects the following Dell docking peripherals:

  • Dell Dock (WD19 and WD19S)
  • Dell Performance Dock (WD19DC and WD19DCS)
  • Dell Thunderbolt Dock (WD19TB and WD19TBS)
  • Dell Dual Charge Dock (HD22Q)

Your docks LAN port behavior and the ports link and activity Light Emitting Diodes (LEDs) are OK. The Ethernet controller driver in the Device manager does not have any Yellow or Red Bangs or marks. However, there is no network connection detected.

Cause

The engineering team identifies from LAN driver logs that this happens due to a change in v11.16.20. (This is a side effect of changes to improve the connection in low power and add a wait queue.)

Resolution

Note: You must have administrator rights on your connected laptop to make any operating system changes or update any software.

You can resolve this by restarting your laptop and updating the Ethernet driver to Realtek USB Gigabit Ethernet (GBE) Controller Driver, version 1156.17.20.1030, A31 or later. Use the instructions in the following link to download and install the Realtek-USB-GBE-Ethernet-Controller-Driver_4JK0H_WIN64_1156.17.20.1030_A31.exe update file:


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Affected Products

Dell Pro Max, Dell Pro Plus, Dell Pro Premium, Latitude, Dell Pro Rugged, XPS, Latitude Tablets, Mobile Workstations
Article Properties
Article Number: 000289617
Article Type: Solution
Last Modified: 08 May 2025
Version:  4
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