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Article Number: 000065100


VIPR SRM | Watch4Net: Unable to acknowledge alerts using the Frontend GUI - "java.net.ConnectException: Connection refused"

Summary: Cannot acknowledge alerts via the Frontend GUI as the correct Primary Backend IP address was not present in the Frontend event management configuration.

Article Content


Symptoms



When acknowledging alerts from the reports under the  "All>>Operations>>Alerts" tree and from "All>>Report Library>>EMC M&R Health>>Stress" for components with errors by right clicking on the alert and selecting "Acknowledge", the following error message is displayed on the top right corner and the alert is not acknowledged:


   kA2j0000000R9WLCA0_3_0

 

Cause

The event management configuration used by the Frontend to connect to the Primary Backend to acknowledge the alert was not correctly configured with the Primary Backend's IP address.

Resolution

Windows Procedure:
  1. Navigate to the <INSTALL_BASE>/APG/Custom/WebApps-Resources/Default/actions/event-mgmt/windows/ directory on the Frontend host.
  2. Right click on conf.cmd and click "Edit file".
  3. At the end of the file, set the following parameter to the correct Primary Backend IP address: PRIMARYBACKEND=<PRIMARY_BACKEND_IP>
  4. Save the file. 
  5. Restart Tomcat service on the Frontend host: open the command prompt and navigate to <INSTALL_BASE>/APG/bin directory and run the following script: manage-modules.cmd service restart tomcat Default
Linux Procedure:
  1. Navigate to <INSTALL_BASE/APG/Custom/WebApps-Resources/Default/actions/event-mgmt/linux/ directory on the Frontend host.
  2. Edit the conf file.
  3. At the end of the file, set the following parameter to the correct Primary Backend IP address: PRIMARYBACKEND=<PRIMARY_BACKEND_IP>
  4. Save the file.
  5. Restart Tomcat service on the Frontend host: <INSTALL_BASE>/APG/bin/manage-modules.sh service restart tomcat Default
 

Following the procedure, login to the Frontend GUI (http://<FRONTEND_IP_ADDRESS>:58080/APG/) and attempt to acknowledge the alert. If successful, a message as below will be appear instead of any errors:

kA2j0000000R9WLCA0_2_0

Article Properties


Affected Product

SRM

Product

SRM

Last Published Date

20 Nov 2020

Version

2

Article Type

Solution