Symptoms
When acknowledging alerts from the reports under the "
All>>Operations>>Alerts" tree and from "
All>>Report Library>>EMC M&R Health>>Stress" for components with errors by right clicking on the alert and selecting "
Acknowledge", the following error message is displayed on the top right corner and the alert is not acknowledged:
Cause
The event management configuration used by the Frontend to connect to the Primary Backend to acknowledge the alert was not correctly configured with the Primary Backend's IP address.
Resolution
Windows Procedure:
- Navigate to the <INSTALL_BASE>/APG/Custom/WebApps-Resources/Default/actions/event-mgmt/windows/ directory on the Frontend host.
- Right click on conf.cmd and click "Edit file".
- At the end of the file, set the following parameter to the correct Primary Backend IP address: PRIMARYBACKEND=<PRIMARY_BACKEND_IP>
- Save the file.
- Restart Tomcat service on the Frontend host: open the command prompt and navigate to <INSTALL_BASE>/APG/bin directory and run the following script: manage-modules.cmd service restart tomcat Default
Linux Procedure:
- Navigate to <INSTALL_BASE/APG/Custom/WebApps-Resources/Default/actions/event-mgmt/linux/ directory on the Frontend host.
- Edit the conf file.
- At the end of the file, set the following parameter to the correct Primary Backend IP address: PRIMARYBACKEND=<PRIMARY_BACKEND_IP>
- Save the file.
- Restart Tomcat service on the Frontend host: <INSTALL_BASE>/APG/bin/manage-modules.sh service restart tomcat Default
Following the procedure, login to the Frontend GUI (http://<FRONTEND_IP_ADDRESS>:58080/APG/) and attempt to acknowledge the alert. If successful, a message as below will be appear instead of any errors: