PowerStore: Appliance Licensing Checklist

Summary: This article explains how to obtain, activate, and troubleshoot licensing issues on PowerStore products.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Upon installation, all appliances come with a 30-day trial license to allow the configuration to proceed until licensing can be completed.

The PowerStore attempts to connect to Dell every 24 hours to activate the license. If external Internet access is disallowed, a manual procedure to obtain the license is detailed below.

Cause

PowerStore licenses are:
  • All inclusive.
  • Do not expire.
  • Issued per appliance.
Note: Adding new appliances to an existing PowerStore cluster may cause the entire cluster to revert to trial licensing until the newly added appliance is permanently licensed.

Resolution

Topics:


Checking the license status in PowerStore Manager

In the PowerStore Manager user interface, select Settings > Licensing.
 
Example: Licensing completed successfully.
 
PowerStore Licensing GUI - Check

 
Example: License not activated, still on trial license.
 
PowerStore GUI License install

Cluster Licensingimageimage

    Each appliance is licensed individually. Once all members in the cluster are licensed, the licensing UI displays as Active.

    Use the svc_license_status list command to identify if the individual appliance licensing status.
    Example below highlights one appliance is not licensed.
    [SVC:service@ABC1234-B user]$ svc_license_status list
     appliance_sn | days_remain | is_licensed
    --------------+-------------+-------------
     ABC1234      |     2048998 | t
     ZYX1234      |     2048998 | t
     CBA1234      |     2048998 | t
     XYZ1234      |          59 | f
    (4 rows)
    

      Automatic Licensing

      The appliance automatically attempts to reach the online e-License servers every 24 hours to retrieve and install licenses, if an active Internet connection is available.
       
      If the system displays it is in Trial mode:
      Click the Refresh link to trigger an attempt to retrieve the licenses using online e-License servers. If this fails after multiple attempts, review the Manual Licensing section below
       

      Troubleshooting Automatic Licensing Failures on PowerStore

      Note: Automatic licensing does not support Transformational License Agreement (TLA) type licenses. This license type must be manually activated.

      1. Confirm you can resolve the DNS name of the license server ssgosge.emc.com and connect to port 443 from any Windows or Linux system in the environment.
      • ncat is available for many operating systems as open source, https://nmap.org/ncat/.
      • ncat is not available for the service user on PowerStore.
      • The license server does not respond to ping.
      nc -vz ssgosge.emc.com 443
      Ncat: Version 7.50 ( https://nmap.org/ncat )
      Ncat: Connected to 168.159.208.38:443  <<Successful Connection
      Ncat: 0 bytes sent, 0 bytes received in 0.07 seconds.
      
      nc -vz ssgosge123.emc.com 443
      Ncat: Version 7.50 ( https://nmap.org/ncat )
      Ncat: Could not resolve hostname "ssgosge123.emc.com": Name or service not known. QUITTING.  <<Cannot resolve DNS name
      
      nc -vz ssgosge.emc.com 440
      Ncat: Version 7.50 ( https://nmap.org/ncat )
      Ncat: Connection timed out.  <<Failed connection to port

      If the above fails to provide insight to a problem, contact a technical support representative referencing this article.
       

      Manual Licensing

      Manual licensing is required if the appliance is installed at a location without Internet connectivity available or TLA licensing is used.
      1. Go to the Software Licensing Central Portal
      2. Log in with account credentials.
      3. Select Software and Licenses > View and Manage Licenses
      4. In the search bar enter the Service Tag of the PowerStore Appliance and hit Search by LAC.
        Note: For systems using Transformational License Agreement (TLA), the activation code goes in the TLA ID field.
        1. Confirm the PowerStore Base SW item is selected, then Actions > View Entitlement details.
        2. License Activation process may be viewed by Product Line or viewed by LAC.
        3. Confirm the Sales Order #, SKU/offer ID, and Entitlement ID. 
        4. If changes must be made, click View under Actions.
        5. Confirm Locking ID's / Service Tag, click Regenerate Keys under Actions.
        6. Review all information. Confirm the email address where the license key file is to be sent and Additional email addresses to send license keys.  Add note to this transaction.
        7. Click Complete.
        8. Check your email for the activation file. The file is attached.
        9. Click Download License to download license key.  
        If the above fails to provide a solution, contact a technical support representative referencing this article.
         

        Troubleshooting Manual Licensing Failures on PowerStore

        1. Confirm the license file extension (*.xml) is uploaded.
        2. Open the *.xml file and inspect the contents.
        • Confirm BOTH the <LockingID> and <MachineName> values contain ONLY the Service tag of the PowerStore Appliance. (Must be in all CAPS.)
        • If these do not match, correct the values on the Software Licensing Central Portal and capture the corrected license file.

        If the above fails to provide insight to the problem, contact a technical support representative referencing this article.

         

          Obtaining License Files if Previously Activated

          If the product was activated previously, these steps can be followed to download the original license file:
          1. Go to the Software Licensing Central Portal 
          2. Log in with account credentials.
          3. Select Certificates > View and Manage Certificates
          4. In the search bar enter the Service Tag of the PowerStore Appliance and hit Search by LAC.
          5. In the Certificate field, click view to View Existing Certificate.
          6. To download a local copy of the license click Download License.
          7. Upload the license file in PowerStore Manager.
            1. Settings menu.
            2. Select Licensing.
            3. Click Install License.
            4. On Step 3, click the Choose File button.
            5. Upload the .xml file provided in the email earlier.
            6. Confirm the status changes to Active.
          If the above fails to provide a solution, contact a technical support representative referencing this article.

           
           

          Affected Products

          PowerStore
          Article Properties
          Article Number: 000123660
          Article Type: Solution
          Last Modified: 20 Jun 2025
          Version:  22
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