PowerProtect:VM 備份失敗,表示 DPD 同步正在進行中

Summary: 一些虛擬機器 (VM) 資產備份在成功完成後開始失敗。 失敗詳細資料指出 vCenter 工作失敗,並出現 TSDM 錯誤,指出「DPD 同步進行中」。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerProtect Data Manager 用於透過 Transparent Snapshot Data Mover (TSDM) 解決方案保護 vSphere 環境。一些 VM 資產備份在過去成功完成時卻開始失敗。失敗詳細資料指出 vCenter 工作失敗,並出現 TSDM 錯誤,指出「DPD Sync in progress." ABV0016和ABV0006詳細資料顯示:

主機備份失敗錯誤的詳細資料對話方塊
ABV0016: VM Direct engine 'localhost' is unable to back up the virtual machine 'my-vm-name' on vCenter 'my-vcernter-name' because of a vCenter API issue.

The VM Direct engine cannot complete the backup of this virtual machine because of a vCenter API operation did not complete successfully.

To troubleshoot this issue: 1) Verify that the vCenter can be reached. 2) If the vCenter is busy, wait for some activities to complete and then retry the operation. 3) Verify that the virtual machine exists on the vCenter.

Read Less

Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'my-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress.
ABV0006: VM Direct engine 'localhost' is unable to back up the virtual machine 'my-vm-name' on vCenter 'my-vcernter-name' because of a vCenter API issue.

The VM Direct engine cannot complete the backup of this virtual machine because of a vCenter API operation did not complete successfully.

To troubleshoot this issue: 1) Verify that the vCenter can be reached. 2) If the vCenter is busy, wait for some activities to complete and then retry the operation. 3) Verify that the virtual machine exists on the vCenter.

Read Less

vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress
備份工作階段可能會顯示下列狀態輸出:
...
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]   },
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]   "Status": {
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "State": "Failure",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Description": "Backup is unsuccessful:  Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'vm-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Progress": 0,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Error": {
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Text": "Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'vm-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Code": 0,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Classifications": [],
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Retryable": false,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Remedy": null
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     },
...
...
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]   },
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]   "Status": {
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "State": "Failure",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Description": "Backup is unsuccessful:  vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress, TSDM snapshot UUID = '52031978-18dd-444a-37fd-9c070de84cc5'",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Progress": 0,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Error": {
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Text": "vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress, TSDM snapshot UUID = '52031978-18dd-444a-37fd-9c070de84cc5'",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Code": 0,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Classifications": [],
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Retryable": false,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Remedy": null
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     },
...

Cause

受影響的虛擬機器有孤立的 vSphere 快照資料移動者 (SDM) 工作,由於 dpd 精靈中的不一致,TSDM 備份工作流程無法取消。孤立任務或 dpd 不一致的原因仍無法識別。

Resolution

應在 ESXi 主機上重新啟動 dpd 精靈,並在受影響的 VM 上停用和啟用 SDM 功能。請確定沒有虛擬機器備份,再重新啟動 dpd 精靈:

  • 開啟 SSH 工作階段至 ESXi 主機。
  • 重新啟動 dpd 精靈: /etc/init.d/dpd restart
[root@my-server ~]# ssh root@my-esx
The authenticity of host 'my-esx (192.168.9.111)' can't be established.
ECDSA key fingerprint is SHA256:LHQVSVzDSw7ezlDVG59nyGD+C/Ugcx/jaSLMbzsY18U.
This key is not known by any other names
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added 'my-esx' (ECDSA) to the list of known hosts.
(root@my-esx) Password:
The time and date of this login have been sent to the system logs.

WARNING:
   All commands run on the ESXi shell are logged and may be included in
   support bundles. Do not provide passwords directly on the command line.
   Most tools can prompt for secrets or accept them from standard input.

VMware offers powerful and supported automation tools. Please
see https://developer.vmware.com for details.

The ESXi Shell can be disabled by an administrative user. See the
vSphere Security documentation for more information.
[root@my-esx:~] /etc/init.d/dpd restart
Restarting dpd: dpd stopped.
Setting the memory limit for dpd resource pool on this host to 320 MB
Setting max number of file descriptors to 32768
Setting MALLOC_ARENA_MAX to 20
success
[root@my-esx:~]

 

下面是在受影響的 VM 上禁用和啟用 SDM 的一些可用方法。

方法 1

變更受影響的 VM 資產保護機制。

  1. 開啟瀏覽器工作階段至 PowerProtect Data Manager,並使用管理員帳戶進行驗證。
  2. 瀏覽至 基礎架構>資產 >虛擬機器
  3. 選取受影響的虛擬機器。
  4. 選取下拉式清單 更多動作>保護機制>遷移到 VADP
  5. vSphere Web Client 會顯示一項工作,讓虛擬機器停用輕量型 Delta (LWD) 篩選器。
  6. 選取下拉式清單中 「更多動作>保護機制>」遷移至 Transparent Snapshot
  7. vSphere Web Client 會顯示虛擬機器的工作,以啟用 LWD 篩選器。
  8. 執行備份或監控排定的備份執行。

方法 2

從保護原則中移除並新增受影響的 VM。

  1. 開啟瀏覽器工作階段至 PowerProtect Data Manager,並使用管理員帳戶進行驗證。
  2. 瀏覽至 基礎架構>資產 >虛擬機器
  3. 選取受影響的虛擬機器。
  4. 選取拉式清單中移除更多動作>。
  5. vSphere Web Client 會顯示一項工作,讓虛擬機器停用輕量型 Delta (LWD) 篩選器。
  6. 選取下拉式清單中新增更多動作>至原則,然後依照精靈新增至保護原則。
  7. vSphere Web Client 會顯示虛擬機器的工作,以啟用 LWD 篩選器。
  8. 執行備份或監控排定的備份執行。

方法 3

The PowerProtect Data Manager vmconfig 命令列公用程式可用於變更受影響 VM 的 SDM 功能設定。

  • 使用 SSH,以管理員帳戶登入 PowerProtect Data Manager 應用裝置:
     ssh admin@my-ppdm-name
  • 變更為根使用者:
    sudo su 
  • 載入環境變數:
    source /opt/emc/vproxy/unit/vproxy.env
  • 變更至 vProxy bin 目錄:
    cd /opt/emc/vproxy/bin/
  • 建構 vmconfig 命令,以取代括弧內的資訊:
    • 檢查 VM 狀態:
./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c info
  • 在虛擬機器上停用 SDM:
./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c disable-sdm
  • 在虛擬機器上啟用 SDM:
./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c enable-sdm
  • 執行 PowerProtect Data Manager TSDM 備份以確認問題已解決。

Additional Information

dpd 精靈中有 VMware 強化功能,可協助解決與同步作業不一致的問題。請確定環境執行 ESXi 7.0 U3o (22348816)、ESXi 8.0 Ub (21203435) 或更新版本。
Article Properties
Article Number: 000210949
Article Type: Solution
Last Modified: 14 Mar 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.