PowerStore: Oppretting av klynge mislykkes med feil under oppretting av ICM-nettverk

Resumen: Oppretting av klyngen mislykkes for PowerStore 1000, 3000, 5000, 7000, 9000 hvis mezzanine-kortet med fire porter ikke finnes. Bare PowerStore 500T støtter initialisering uten mezzanine-kortet med fire porter, som blokkoptimert. Hvis Mezzanine-kortet ikke finnes på 500T, er initialisering fordi enhetlig ikke er tilgjengelig og nedtonet. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Når Mezzanine-kortet mangler, kan den første konfigurasjonsveiviseren (ICW) startes uten feil.
Det mislykkes imidlertid senere med en generisk feilmelding i PowerStore Manager-brukergrensesnittet.

Tjenesteskriptet svc_diag liste – icw_hardware viser ingen defekte komponenter.

Kjør kommandoen svc_cluster_diag for å identifisere problemet:
svc_cluster_diag
...
----scanning for current hardware failures--------

Running svc_diag list --icw_hardware from svc_cluster_diag
hw_type Warnado-EX
Running on Node A

Local Node - no Expansion Enclosures detected
Local Node - no Expansion Enclosures detected
Lab Mode Flags: unsupported_drives (False), unsupported_exp_enclosures (False), unsupported_node_hw_configs (False)
Node A FRU Status
        OK | Peer Node        | 0x0f80
        OK | Local Node       | 0x1480
        OK | Embedded Module  | 0x8b81
     Empty | 4-Port Card      | 0x0080     

Status for nodens feilstatusregistrering viser vellykket , og det rapporteres ingen feil. Kortsporet med fire porter rapporteres som tomt for både node A og B.

Meldinger som indikerer problemet:
======Scanning for clustering error messages======
Mar 14 11:46:11 xxxx-A control-path[11375]: 2022-03-14 11:46:11.896 [CC] [ERROR] [com.emc.cyclone.contexts.clustering.services.ClusterConfigurationAS|vert.x-eventloop-thread-3] [xxxx|configureTemporaryNetwork_execute] Failed to configure temporary network
                                       General error in networking validation service.

...

Mar 14 11:55:05 xxxx-A control-path[11375]: 2022-03-14 11:55:05.337 [CC] [ERROR] [com.emc.cyclone.contexts.clustering.services.ClusterConfigurationAS|vert.x-eventloop-thread-3]  Clustering internal error, Reason: Platform failure: Node A: Failed to create ICM network
Mar 14 11:55:05 xxxx-A control-path[11375]: 2022-03-14 11:55:05.577 [CC] [ERROR] [com.emc.cyclone.contexts.clustering.services.JoinClusterAS|vert.x-eventloop-thread-3]  Error from Join Cluster: 
                                      Clustering internal error, Reason: Platform failure: Node A: Failed to create ICM network


Og:
Mar 14 11:54:57.342515 xxxx-A cyc_config[17710]: A: # Creating ICM network
Mar 14 11:54:58.494138 xxxx-A cyc_config[17710]: A: # ICM VLAN:         '0'
Mar 14 11:54:58.494207 xxxx-A cyc_config[17710]: A: # ICM prefix:       '64'
Mar 14 11:54:58.494247 xxxx-A cyc_config[17710]: A: # ICM appliance IP: 'xxxx:xxxx:xxxx::xxx:xxxx:xxxx:xxxxx'
Mar 14 11:54:58.494277 xxxx-A cyc_config[17710]: A: # ICM node A IP:    'xxxx:xxxx:xxxx::xxx:xxxx:xxxx:xxxxx'
Mar 14 11:54:58.494302 xxxx-A cyc_config[17710]: A: # ICM node B IP:    'xxxx:xxxx:xxxx::xxx:xxxx:xxxx:xxxxx'
Mar 14 11:54:58.495112 xxxx-A cyc_config[17710]: A: Parameters: network_type=NWType.ICM, vlan=0, appliance_ip=xxxx:xxxx:xxxx::xxx:xxxx:xxxx:xxxxx, ip_a=xxxx:xxxx:xxxx::xxx:xxxx:xxxx:xxxxx, ip_b=xxxx:xxxx:xxxx::xxx:xxxx:xxxx:xxxxx, prefix=64, gateway=, debug=False
Mar 14 11:54:58.501819 xxxx-A cyc_config[17710]: A: Base net device was not found to create network (capability = ICM): list index out of range
Mar 14 11:54:58.501994 xxxx-A cyc_config[17710]: A: Could not get base net device: list index out of range
Mar 14 11:54:58.569967 xxxx-A cyc_config[17710]: A: Error: # failed to create ICM network:
Mar 14 11:54:58.586940 xxxx-A cyc_config[17710]: A: Debug: # Task Time: 365 seconds to execute 16_create_base_stack_cluster
Mar 14 11:54:58.586994 xxxx-A cyc_config[17710]: A: Error: # [16/23]: Create Base Stack Cluster -- FAILED
Mar 14 11:54:58.870177 xxxx-A cyc_config[17710]: A: Error: reinit_install: ICM network creation failed:
Mar 14 11:54:58.870243 xxxx-A cyc_config[17710]: A: Error: EC:293
Mar 14 11:54:58.908290 xxxx-A cyc_config[16976]: Error: # Configuration sync: reinit_install failed															 

Causa

Mezzanine-kortet for PowerStore 1000, 3000, 5000, 7000 og 9000 T og X er alltid nødvendig, selv om systemet skal implementeres blokkoptimert og Ethernet-portene ikke skal kobles til.

PowerStore kan ikke opprette det interne ICM-nettverket hvis mezzanine-kortet ikke finnes.
Slik kontrollerer du om mezzanine-kortet er til stede:
[SVC:service@xxxx-A user]$ svc_diag list --hardware --sub_options inventory | grep -i mezzanine0 -A 2
FRU Device Description : SLIC1 (ID 14)
 Device not present (Timeout)
Når Mezzanine-kortet er til stede, er dette forventet utdata:
[SVC:service@xxxx-A user]$ svc_diag list --hardware --sub_options inventory | grep -i mezzanine0 -A 2
FRU Device Description : Mezzanine0 (ID 27)
 Chassis Type          : Rack Mount Chassis
 Chassis Part Number   :                     

Resolución

Disse PowerStore-systemene kan ikke bestilles og implementeres uten Mezzanine-kort. 

Slå av PowerStore-verktøyet for å sette inn Mezzanine-kortet på nytt, og tilbakestill deretter PowerStore til fabrikkinnstillingene for en ny initialisering: PowerStore: Slik initialiserer du et PowerStore-system på nytt til fabrikkinnstillingene ved hjelp av kommandoen svc_factory_reset

Kontroller med kommandoen ovenfor på begge nodene at Mezzanine-kortet er riktig oppdaget før klyngen opprettes.

Productos afectados

PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T
Propiedades del artículo
Número del artículo: 000198276
Tipo de artículo: Solution
Última modificación: 11 abr 2022
Versión:  1
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.