NetWorker: Fehler beim Abrufen von vCenter-Informationen für ESXi vCenter Hostname: Grund für Timeout der Dispatcher-Anfrage
Resumen: Fehler beim Abrufen von vCenter-Informationen für den ESXi vCenter-Hostnamen: Grund, warum für dispatcher request ein Timeout für NetWorker 19.7.0.3 ausgegeben wurde.
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Beim Aktualisieren der VMware-Ansicht in NetWorker Management Console (NMC) tritt eine Zeitüberschreitung mit dem folgenden Fehler auf.
Abbildung 1: NetWorker Management Console Timeout-Fehlermeldung
Der NetWorker-Server wurde auf 19.7.0.x aktualisiert.
Dies betrifft sowohl die ESXi- als auch die vCenter NSR-Hypervisors.
Die Daemon.raw-Berichte des NetWorker-Servers:
Abbildung 1: NetWorker Management Console Timeout-Fehlermeldung
Der NetWorker-Server wurde auf 19.7.0.x aktualisiert.
Dies betrifft sowohl die ESXi- als auch die vCenter NSR-Hypervisors.
Die Daemon.raw-Berichte des NetWorker-Servers:
Inventory session returned err: Inventory session status returned with a failure.
Error: 'Failed to load inventory from 'ESX-FQDN'. Failed to load Category/Tagging metadata.
- Linux: /nsr/logs/daemon.raw
- Windows: C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw
- Wissensdatenbank-Artikel 22793: NetWorker: Verwenden von nsr_render_log
- Wissensdatenbankartikel 23670: NetWorker: Anleitung zum automatischen Rendern von daemon.raw in daemon.log in Echtzeit
Causa
NetWorker Version 19.7 führt eine neue Aktualisierung ein, die sie langsamer macht, wenn die VISD-Verbindung erneut versucht wird.
Resolución
Lösung:
NetWorker 19.8 enthält eine Lösung für dieses Problem. NetWorker 19.8 kann vom Dell Support heruntergeladen werden unter: https://www.dell.com/support/home/product-support/product/networker/.Problemumgehung:
Fügen Sie die folgenden zwei Systemvariablen auf dem NetWorker-Server hinzu:GST_VBA_TIMEOUT=7200 NSR_HYPERVISOR_QUERY_REQUEST_TIMEOUT=3600
Unter Windows:
- Wählen Sie im Dashboard Server Manager > Local Server aus.
- Klicken Sie auf den Hyperlink für den Computernamen.
- Wählen SieSystem Properties > Advanced > Environment Variables > New aus.
Abbildung 2: Server Manager-Dashboard für Windows
- Starten Sie das NetWorker-Serverbetriebssystem neu.
Unter Linux:
- Erstellen oder bearbeiten Sie die Datei /nsr/nsrrc mithilfe eines Texteditors:
vi /nsr/nsrrc
HINWEIS: Die Datei /nsrrc ist eine variable Datei, die von NetWorker-Prozessen verwendet wird. Diese Datei wird geladen und Variablen werden während des Startvorgangs des NetWorker-Daemon angewendet.
- Fügen Sie die folgenden Zeilen hinzu:
GST_VBA_TIMEOUT=7200 export GST_VBA_TIMEOUT NSR_HYPERVISOR_QUERY_REQUEST_TIMEOUT=3600 export NSR_HYPERVISOR_QUERY_REQUEST_TIMEOUT
- Die abgeschlossenen Änderungen sollten ähnlich aussehen wie:
[root@networker-mc]:~# cat /nsr/nsrrc JAVA_HOME=/opt/nre/java/latest/ export JAVA_HOME GST_VBA_TIMEOUT=7200 export GST_VBA_TIMEOUT NSR_HYPERVISOR_QUERY_REQUEST_TIMEOUT=3600 export NSR_HYPERVISOR_QUERY_REQUEST_TIMEOUT
- Starten Sie die NetWorker-Services neu:
systemctl restart networker systemctl restart gst
Productos afectados
NetWorkerProductos
NetWorker Family, NetWorker SeriesPropiedades del artículo
Número del artículo: 000211688
Tipo de artículo: Solution
Última modificación: 22 ene. 2025
Versión: 10
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.