Dell Unity: Päivitystä ei voi yrittää uudelleen tai jatkaa (käyttäjän korjattavissa)
Yhteenveto: Dell Unity: Päivitystä ei voi yrittää uudelleen tai jatkaa (käyttäjän korjattavissa)
Oireet
Unity OE -päivitys on käynnissä ja keskeytetty, koska Automatically Reboot Storage Processors -kohdan valinta on poistettu.
Kun käyttäjä yrittää jatkaa, Unisphere näyttää epäonnistuvan, ja näyttöön tulee Reload-ilmoitus, eikä sitä edetä Resume of upgrade -ilmoituksella.
Myös yritykset jatkaa uemcli:stä epäonnistuvat:
service@(none) spa:~$ uemcli -u admin -p xxxxx /sys/soft/upgrade resume Operation failed. Error code: 0x6000cb9 The system encountered an unexpected error while upgrading the software. Reboot your Primary storage processor and try upgrading again. Check System > Logs for related messages. (Error Code:0x6000cb9)
Syy
Latausbinaarit ovat väärässä SP:ssä. Hallintapalvelut siirtyivät siitä hetkestä lähtien, kun päivitysnäköistiedosto on ladattu ja jatkamistoimintoa on yritetty.
Tarkkuus
Tarkista seuraavat tiedot tiedostosta /EMC/CEM/log/cemtracer.log:
service@(none) spa:/EMC/CEM/log$ grep "papi_get.sh tasks_info" *log cemtracer.log:02 Aug 2017 23:03:36 - [UpdateProvider] FATAL - {0:x:x}[x|x|x][createJob @ ../../../components/providers/osls/UpdateProvider/src/C4CB_SoftwareInstallationService.cpp:1123] createJob exception: Failed to get tasks info: caused by the error in P-API backend (error running 'papi_get.sh tasks_info Unity-4.2.0.9392909.tgz.bin' meta (nil): request error code: 9, command error code: 0x100)
Edellä oleva tarkoittaa, että päivitystä ei voi jatkaa, koska päivitystehtävän tietoja koskeva kysely epäonnistuu. Tämä tarkoittaa, että SPB:llä on päivitystiedostot, mutta SPA hoitaa hallintapalvelut nyt. Se voi olla käyttäjän ongelma, kuten SPB: n uudelleenkäynnistys, joka tekee SPA: sta ensisijaisen, tai mikä tahansa muu ongelma.
Ratkaisu:
Käynnistä SPA uudelleen (tässä esimerkissä) niin, että SPB:stä tulee jälleen ensisijainen. Tämän jälkeen Resume- tai Retry-toiminto onnistuu.
Jos tietokone ei vieläkään toimi, ota yhteys Dellin tekniseen tukeen tai valtuutettuun huoltoedustajaan ja mainitse tämän tietämyskannan artikkelin numero.