nsrck SYSTEM warning Cannot lock file index for client '<Client Name>' (Too many open files)
Résumé: Bei NetWorker-Servern, auf denen die Versionen 19.4.0.2 und 19.5.0.0 ausgeführt werden, kann es zu einem Problem kommen, bei dem sowohl automatisierte als auch manuelle NSRCK-Befehle mit dem Fehler „zu viele offene Dateien“ fehlschlagen. ...
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Symptômes
Bei NetWorker-Servern, auf denen die Versionen 19.4.0.2 und 19.5.0.0 ausgeführt werden, kann es zu einem Problem kommen, bei dem sowohl automatisierte als auch manuelle NSRCK-Befehle mit dem Fehler „zu viele offene Dateien“ fehlschlagen.
- Die NSRCK-Ausführung als Teil der Server-Schutz-Policy schlägt fehl, ohne dass in der Benutzeroberfläche ein Fehler angezeigt wird. Fehler werden im Policy-Protokoll und in daemon.raw-Dateien protokolliert:
- Policy-Protokoll
- 96467 1624042989 2 1 24 15160 10448 0 Server.Domain.com nsrck SYSTEM warning 43 Cannot lock file index for client '%s' (%s) 2 12 20 Client.Domain.com 24 19 Too many open files
- Daemon.raw
- 71193 1622838475 0 0 0 5876 5980 0 Server.Domain.com nsrd NSR info 9 %s %s: %s 3 11 10 2935:Index 11 12 19362:Notice 49 70 195146 32 Checking index for client '%s'. 1 0 20 Client.Domain.com
- 96467 1622838492 2 1 24 6444 7952 0 Server.Domain.com nsrck SYSTEM warning 43 Cannot lock file index for client '%s' (%s) 2 12 20 Client.Domain.com 24 19 Too many open files
- Policy-Protokoll
- Das Ausführen von NSRCK über die Befehlszeile gibt den folgenden Fehler zurück:
- nsrck SYSTEM warning Cannot lock file index for client '' (Too many open files)
- NetWorker Client File Indexes (CFI) werden immer größer und verbrauchen immer mehr Speicher, was dazu führen kann, dass das System instabil wird, wenn der gesamte Speicher auf dem Hostlaufwerk verbraucht ist.
- Datensicherungs- und Wiederherstellungsjobs können gelegentlich fehlschlagen, wenn sie gleichzeitig mit NSRCK ausgeführt werden.
Cause
Dieses Problem wird durch einen Codefehler verursacht, der in der ersten Version des kumulativen Hotfix 19.4.0.2 (CHF) und der Erstveröffentlichung 19.5.0.0 eingeführt wurde.
Résolution
| Produkt (Betriebssystem oder Betriebsumgebung) |
NetWorker Server 19.4.0.3 NetWorker Server 19.5.0.1 |
| Maßnahmentyp |
Hotfix anwenden |
| Erforderliche Maßnahmen |
Wenden Sie den entsprechenden Hotfix basierend auf der betroffenen Version an, die derzeit installiert ist. |
| Wer kann die Maßnahme durchführen? |
NetWorker-Administrator |
| Problem wurde in diesem BS, dieser OE oder dieser Software behoben |
|
| Auflösungsdetails | Lösung: NetWorker-Server, auf denen 19.4.0.2 ausgeführt wird, müssen den kumulativen Hotfix (CHF) 19.4.0.3 anwenden, um dieses Problem zu beheben. NetWorker-Server, auf denen 19.5.0.0 ausgeführt wird, müssen den kumulativen Hotfix 19.5.0.1 anwenden, um dieses Problem zu beheben. Problemumgehung: Um dieses Problem zu umgehen, erhöhen Sie die Anzahl der verfügbaren Dateideskriptoren auf Betriebssystemebene. Für Linux-Systeme:
# vi /etc/sysctl.conf
fs.file-max = wobei eine Dezimalzahl ist, die die maximale Anzahl geöffneter Dateien definiert. 32768 ist die empfohlene Einstellung für große NetWorker-Bereitstellungen und ein guter Ausgangspunkt.
# sysctl -p (Empfohlen wird jedoch der Neustart.) Hinweis: Um das Problem zu umgehen, müssen Administratoren möglicherweise Werte definieren, die höher als oben empfohlen sind. Jedes System ist anders. Informationen zu Beschränkungen für einen sicheren Betrieb bei der Erhöhung dieser Werte finden Sie in der Dokumentation zum Betriebssystem. |
| Überlegungen zur Lösung | Es wird dringend empfohlen, den Hotifx so bald wie möglich anzuwenden. Es ist wichtig, dass die Dateideskriptorenwerte des Betriebssystems auf Werte innerhalb des im Leistungs- und Optimierungsleitfaden definierten Bereichs zurückgesetzt werden, nachdem der Hotfix angewendet wurde. |
Produits
NetWorkerPropriétés de l’article
Numéro d’article: 000188258
Type d’article: Solution
Dernière modification: 23 août 2022
Version: 6
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