AppSync: Unable to create a service plan completion report using AppSync GUI
Summary: Unable to export a service plan completion report using AppSync GUI.
Ez a cikk a következő(k)re vonatkozik:
Ez a cikk nem vonatkozik a következő(k)re:
Ez a cikk nem kapcsolódik egyetlen konkrét termékhez sem.
Ez a cikk nem azonosítja az összes termékverziót.
Symptoms
Unable to export a service plan completion report using AppSync 4.5 GUI.
If "Include table headers" is selected and "Export only selected rows" is NOT selected, downloading would not happen. Actually, nothing happened.
If both "Include table headers" and "Export only selected rows" are selected, downloading started and CSV file was downloaded. However, all data was missing.


Cause
This is an AppSync UI bug.
Resolution
Workaround:
The following AppSync CLI command can be used to export a service plan completion report.
Sample command output:
Service_Plan_Completion_Report_2022_12_26_18_24_38.csv
Permanent fix:
This issue is expected to be resolved in the version following 4.5.
The following AppSync CLI command can be used to export a service plan completion report.
appsync-cli.bat -report report_type=spc detailed=true
Sample command output:
C:\EMC\AppSync\appsync-cli>appsync-cli.bat -report report_type=spc detailed=true Picked up JAVA_TOOL_OPTIONS: "-Dos.name=Windows Server 2019" Exporting SPC Details to: "C:\EMC\AppSync\Service_Plan_Completion_Report_2022_12_26_18_24_38.csv"
Service_Plan_Completion_Report_2022_12_26_18_24_38.csv
Permanent fix:
This issue is expected to be resolved in the version following 4.5.
Additional Information
Refer to the release notes of the version following 4.5 to determine if the fix has been included.
Érintett termékek
AppSyncTermék tulajdonságai
Article Number: 000206985
Article Type: Solution
Utoljára módosítva: 16 máj. 2026
Version: 4
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