PowerProtect: Cloud Snapshot Manager Copy Job Fails with Error while processing request
Summary: PowerProtect: Cloud Snapshot Manager Copy Job is failing with Error: {"errors":[{"code":1004,"message":"Error encountered while processing the request.","details":"Error encountered while processing the request."}]} ...
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Symptoms
Copy jobs to copy snapshots from Amazon Web Services (AWS) to Data Domain Virtual Edition (DDVE) are failing with an error message similar to the following:
AWS CloudFormation logs shows error messages similar to the following:
"Error occured fetching session from csm proxy : Error: {"errors":[{"code":1004,"message":"Error encountered while processing the request.","details":"Error encountered while processing the request."}]} Error code: 3041" There are no AWS ECS Clusters, and task definitions are created in the AWS account.
AWS CloudFormation logs shows error messages similar to the following:
# TaskDefinition CREATE_FAILED Resource handler returned message: "Invalid request provided: Create TaskDefinition: User: arn:aws:sts::sideID:assumed-role/CSMRole/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx is not authorized to perform: ecs:TagResource on resource: arn:aws:ecs:ZONE:sideID:task-definition/csm-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx_proxyTaskDefinition:* because no identity-based policy allows the ecs:TagResource action (Service: AmazonECS; Status Code: 400; Error Code: AccessDeniedException; Request ID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx; Proxy: null)" (RequestToken: 0d5dea1c-e158-e5e2-0080-1e2c521679dc, HandlerErrorCode: InvalidRequest)The message similar to the following is seen:
# Cluster CREATE_FAILED Resource handler returned message: "Error occurred during operation 'CreateCluster SDK error: User: arn:aws:sts::sideID:assumed-role/CSMRole/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx is not authorized to perform: ecs:TagResource on resource: arn:aws:ecs:ZONE:sideID:cluster/csm-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx_proxyCluster because no identity-based policy allows the ecs:TagResource action (Service: AmazonECS; Status Code: 400; Error Code: AccessDeniedException; Request ID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx; Proxy: null)'." (RequestToken: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx, HandlerErrorCode: GeneralServiceException)
Cause
AWS permission
ecs:TagResource is missing from the IAM policy assigned to the role used by Cloud Snapshot Manager.Resolution
Update the IAM policy assigned to the role used by Cloud Snapshot Manager.
The following documentation link can be used to find steps on how to create or update IAM policies: PowerProtect Cloud Snapshot Manager Online Help | Dell US
Under the JSON tab, make changes as shown in the image below:
Érintett termékek
Cloud Snapshot Manager, PowerProtect Cloud SnapshotTermék tulajdonságai
Article Number: 000223744
Article Type: Solution
Utoljára módosítva: 29 aug. 2025
Version: 2
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