ECS: Dial Home – EKMServerConnectionStatus – Symptomkode: 1369 og 1370

Riepilogo: Dette er et opkaldshjem, der blev introduceret for at registrere advarslen EKMServerConnectionStatus.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

ECS har ringet hjem med følgende advarsel:
Symptomkode Alvorsgrad
1369 WARNING
1370 FEJL
<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
    xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <TransType>10</TransType>
    <TransTypeDesc>EventXML</TransTypeDesc>
    <TransID>0</TransID>
    <Node Status="Unknown" State="Unknown" ID="ECSQE00079">
        <Identifier>
            <DeviceState>1</DeviceState>
            <DeviceStatus>1</DeviceStatus>
            <ClarifyID>ECSQE00079</ClarifyID>
            <SiteName>UNKNOWN</SiteName>
            <Vendor>EMC</Vendor>
            <DeviceType>ElasticCloudStorageApp</DeviceType>
            <Model>ElasticCloudStorage</Model>
            <SerialNumber>ECSQE00079</SerialNumber>
            <WWN>ECSQE00079</WWN>
            <Platform>platform</Platform>
            <OS>SLES</OS>
            <OS_VER>12.3</OS_VER>
            <UcodeVer>3.3.0.0-4349.d0de882</UcodeVer>
            <EmbedLevel>2</EmbedLevel>
            <InternalMaxSize>512800</InternalMaxSize>
            <Comment>Object Alert</Comment>
        </Identifier>
        <Connection>
            <ConnectType>ESRS</ConnectType>
            <IPName>xxxxx-yyyyyy.ecs.lab.fqdn.com</IPName>
            <ConnectNum>xx.xxx.xxx.xx</ConnectNum>
            <Port>22</Port>
        </Connection>
        <HeartBeat>
            <HBStatus></HBStatus>
            <HBState></HBState>
        </HeartBeat>
        <InternalData>
            <FileList/>
            <EventList>
                <Event>
                    <SymptomCode>1370</SymptomCode>
                    <Category>Configuration</Category>
                    <Severity>Error</Severity>
                    <Status>Unknown</Status>
                    <Component>Object</Component>
                    <ComponentID></ComponentID>
                    <SubComponent>EKM Server Connection Status</SubComponent>
                    <SubComponentID></SubComponentID>
                    <CallHome>true</CallHome>
                    <FirstTime>2022-01-29T07:32:09.718Z</FirstTime>
                    <LastTime>2022-01-29T07:32:09.718Z</LastTime>
                    <Count>0</Count>
                    <EventData><![CDATA[]]></EventData>
                    <Description><![CDATA[The EKM Server: ecs-test-keysecure-xx.xxx.xxx.xxx is not responding. Please ensure that the server is connected.  [Ref_ID : EKMServerConnectionStatus]]]></Description>
                </Event>
            </EventList>
        </InternalData>
        <ExternalFiles/>
    </Node>
</ConnectHome>

Causa

EKM-serveren (Extensible Key Management) svarer ikke. Sørg for, at serveren er tilsluttet.

Risoluzione

Bekræft status

Kommando: 
svc_rest_cmd -i `hostname -i` /vdc/sensor/status/EKMServerConnectionStatus
Eksempel:
# svc_rest_cmd -i `hostname -i` /vdc/sensor/status/EKMServerConnectionStatus
svc_rest_cmd 1.0.10

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
  <SensorId>KMServerConnectionStatus</SensorId>
  <ListSensorStatus>
    <SensorStatusRestRep>
      <ContextId>EKMServerConnectionStatus</ContextId>
      <CurrentState>OK</CurrentState>
      <NodeId>1f4368c3-37cd-467f-9efc-289264806ea0</NodeId>
      <PreviousState>OK</PreviousState>
      <Time>1551118064264</Time>
    </SensorStatusRestRep>
  </ListSensorStatus>
Se efter CurrentState som ovenfor, hvis den er indstillet til OK, kan fejlen ignoreres. Hvis det ikke er OK (advarsel eller fejl), skal du fortsætte med fejlfindingstrinnene nedenfor.

Fejlfinding

Find den server, der er angivet i den modtagne advarselsmeddelelse, og prøv at pinge den:
Description><![CDATA[The EKM Server: ecs-dev-keysecure-xx.xxx.xx.xxx is not responding. Please ensure that the server is connected. [Ref_ID : EKMServerConnectionStatus]]]></Description>
Tjek resourcesvc.log for meddelelser om problemet EKM server:
Kommando:
grep /opt/emc/caspian/fabric/agent/services/object/main/log/<EKM Server Name> resourcesvc.log
Eksempel:
The command will return output in the following format:
There was some error verifying connection to EKMServer {will have failed server name} in cluster. {will have failure detail}
Fejlene indikerer et muligt netværksproblem i miljøet. Kommunikation mellem ECS og EKM-serveren kan være blokeret, eller selve EKM-serveren kan være utilgængelig. Kontroller, at ECS kan pinge EKM-serveren og råde brugeren til at kontrollere, at EKM-serveren fungerer.

Hvis du ikke kan løse problemet, skal du åbne en serviceanmodning hos ECS-support for at hjælpe med de oplysninger, der er indsamlet ovenfor.

Prodotti interessati

ECS, ECS Appliance, ECS Software, Elastic Cloud Storage

Prodotti

ECS, ECS Appliance, ECS Software, Elastic Cloud Storage
Proprietà dell'articolo
Numero articolo: 000038620
Tipo di articolo: Solution
Ultima modifica: 17 dic 2025
Versione:  7
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.