NetWorker: Windows backup fails with "VSS OTHER: sow_create_sysset_snapshot: VSS failed to process snapshot, error=0x0"
Riepilogo: A windows NetWorker client fails during backup indicating that it failed to create a VSS snapshot.
Questo articolo si applica a
Questo articolo non si applica a
Questo articolo non è legato a un prodotto specifico.
Non tutte le versioni del prodotto sono identificate in questo articolo.
Sintomi
During a NetWorker backup of a Microsoft Windows client, critical drives that requires the use of the Volume Shadow Copy Service (VSS) the backup fails with the following message:
174424:save: Step (3 of 5) for PID-8568: Creating the snapshot for the selected save sets.
03/11/19 15:40:02.614837 UTF8 string for BCDPath is C:\Program Files\EMC NetWorker\nsr\tmp\xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxx\backcomp.xml
VSS OTHER: ERROR: VSS failed to process snapshot:
03/11/19 15:40:02.630861 VSS OTHER: sow_create_sysset_snapshot: VSS failed to process snapshot, error=0x0
90108:save: Unable to save the SYSTEM STATE save sets: cannot create the snapshot.
03/11/19 15:40:02.630861 WriteTracker: nsrwriter_stop(8568:5204) -->.
03/11/19 15:40:02.630861 WriteTracker: nsrwriter_stop(8568:5204) error: NULL hProcess detected..
03/11/19 15:40:02.630861 WriteTracker: nsrwriter_stop(8568:5204) releasing hWriterMutex ....
03/11/19 15:40:02.630861 save workflow released nsrwriter lock.
03/11/19 15:40:02.630861 WriteTracker: nsrwriter_stop(8568:5204) <-- FALSE.
03/11/19 15:40:02.646091 WINDOWS ROLES AND FEATURES: sow_free_save called
03/11/19 15:40:02.646091 VSS USER DATA: sow_free_save called
03/11/19 15:40:02.646091 VSS OTHER: sow_free_save called
174918:save: Step (3 of 5) for PID-8568: Unable to complete the backup. See the savegrp log to track the closure steps of the backup.
175023:save: Unable to back up the save set 'pseudo_saveset'.
Causa
This is an operating system issue that prevents the snapshot creation.
Risoluzione
Check the status of the operating system writes:
1. Open a command prompt (cmd) as administrator.
2. Start the diskshadow tool by running the command:
3. The disk shadow tool initializes and the command prompt shows DISKSHADOW>.
4. List the system writers by running the following command:
5. This output is long, so you may need to increase the command prompt line buffer to capture it all.
6. To keep things recorded, the user should copy the output to a text file. Run the following command to log everything ran in the diskshadow tool, in this case we only need the list writers detailed output:
7. Search the file for the string '[Does not exist]'
Example: This is not a NetWorker issue but an operating system issue. This is typically caused by an application installed in the system or a failed install.
If the NetWorker backup worked previously, then stopped, a deeper analysis needs to be performed on the operating system side. The Windows event log in the event viewer should provide more details if filtered to that date when the error first occurred. Microsoft support is recommended for any persistent VSS issues.
1. Open a command prompt (cmd) as administrator.
2. Start the diskshadow tool by running the command:
diskshadow
3. The disk shadow tool initializes and the command prompt shows DISKSHADOW>.
4. List the system writers by running the following command:
list writers detailed
5. This output is long, so you may need to increase the command prompt line buffer to capture it all.
6. To keep things recorded, the user should copy the output to a text file. Run the following command to log everything ran in the diskshadow tool, in this case we only need the list writers detailed output:
diskshadow /l "PATH_TO_OUTPUT_FILE"
Example:
diskshadow /l "C:\Windows\Temp\listoutput.txt"
diskshadow /l "C:\Windows\Temp\listoutput.txt"
7. Search the file for the string '[Does not exist]'
Example:
- Volumes affected by this component:
- \\?\Volume{9710a803-0000-0000-0000-501f00000000}\ [C:\]
- \\?\Volume{294e539b-7658-40d0-8751-e826e6d8813f}\ [D:\]
- \\HOSTNAME\SHARENAME\ [Does not exist]
NOTE: Any UNC path here (starting \\hostname\sharename - where this is a host on network) is not supported for by VSS snapshot. Look at the section above in the output, it should show the component affected and the binary responsible.
Example:
+ Component "System Writer:\Win32 Services Files"
<snip>
- File List: Path = \\hostname\sharename\path\bin, Filespec = scd.exe
- Paths affected by this component:
<snip>
- \\hostname\sharename\path\bin
If the NetWorker backup worked previously, then stopped, a deeper analysis needs to be performed on the operating system side. The Windows event log in the event viewer should provide more details if filtered to that date when the error first occurred. Microsoft support is recommended for any persistent VSS issues.
Informazioni aggiuntive
Prodotti interessati
NetWorkerProdotti
NetWorkerProprietà dell'articolo
Numero articolo: 000055493
Tipo di articolo: Solution
Ultima modifica: 27 set 2023
Versione: 3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.