PowerScale: Isilon: Användning av sudo-kontot efter uppgraderingen misslyckas med "ANVÄNDAREN finns inte i sudoers-filen. Denna händelse är rapporterad." (kan korrigeras av användaren)

Riepilogo: Sudo-konton i ett begränsat antal OneFS-versioner skapades med hjälp av en lösning. När klustret uppgraderas till en OneFS-kodversion där problemet åtgärdades fungerar inte dessa sudo-konton korrekt. ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Koden uppgraderades från en version av OneFS där isi_visudo fungerade inte mot en nyare version av OneFS där isi_visudo åtgärdades.

sudo konton som upprättats på en OneFS-version med en defekt isi_visudo upplevt fel med sudo efter uppgradering till en korrigerad kodversion (t.ex. v8.1.0.4). Trots sudo Kontoposter som bekräftas i /etc/mcp/override/sudoers och /usr/local/etc/sudoers—som kräver root Tillträde—sudo inte fungerade som den skulle.

Mer utdata från det icke-fungerande sudo-kontot kan se ut som följande utdata, förutom USERNAME is not in the sudoers file fel:

MYCLUSTER-13% sudo isi status
We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:
    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.
Password:
Sorry, user USERNAME is not allowed to execute '/usr/bin/isi status' as root on mycluster-13.

Causa

Problemet är relaterat till OneFS-koden.

Risoluzione

Logga in som root användare, och:

  1. Använd
    isi_visudo
    och ta bort ANVÄNDARKONTOT som har ställts in för sudo. Var noga med att bara ta bort sudo konto som inte fungerar. Spara filen. 
    :wq!
  2. Använd
    isi_visudo
    och återskapa ANVÄNDARKONTOT med rätt inställningar. Spara filen.

Koduppgraderingen bör inte påverka rollerna och andra auktoriseringar. Användarkontot och lösenordet förblir oförändrade. När du har utfört stegen ovan kommer kontot att fungera igen.

Prodotti interessati

Isilon

Prodotti

Isilon, PowerScale OneFS
Proprietà dell'articolo
Numero articolo: 000059475
Tipo di articolo: Solution
Ultima modifica: 01 apr 2025
Versione:  4
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.