AppSync: Podpora pro Oracle 18.x a 19.x

Riepilogo: Podpora AppSync Oracle.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Replikovaná verze systému Oracle byla: 18,5, 18,6, 18,7, 18,8, 18,9, 19,4, 19,5 nebo 19,6.

AppSync nedokáže ochránit systém Oracle verze 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 nebo 19.6.

Protokol událostí AppSync:
 
Název servisního plánu: PROD-ABCD,ApplicationType:oracle
Zdroje zapojené do fáze zjišťování jsou:
Název produkčního hostitele Verze PROD:Red Hat Enterprise Linux 7.7
OracleDatabase: ABCD , RAC : true , ASM : true
OracleInstance : ABCD2 , verze : 19.6.0.0.0
 
Zjišťování aplikací, během provádění servisního plánu PROD-ABCD
došlo k chybě, v servisním plánu PROD-ABCD nejsou žádné datové sady, které by bylo možné zkopírovat.
Zjišťování aplikací, fáze zjišťování aplikací pro ABCD dokončená s chybami
Zjišťování aplikací, Během zjišťování AppSync zjistil, že následující databáze jsou offline: ABCD. V důsledku toho nebudou k dispozici pro ochranu.

Protokol serveru AppSync:
 
02-20-2020 15:50:18.954 INFO ->>> Řetězcová odpověď: <ir_message ir_requestId="00000" ir_sessionId="00000" ir_status="0" ir_type="ArchwayRequest" master_id="0" phaseName="" pollMode="SYNC" taskId="0" timeToWait="0"<>operation><agent>Oracle</agent><příkaz>getDatabaseInstance</command<>parametry<>><parametru paramName>databaseId</paramName paramValue><>2673940419</paramValue<>/parametr>
<parametr<>paramName>databaseName</paramName<>paramValue>ABCD</paramValue<>/parametr<>parametr<>paramName>dbRole</paramName<>paramValue>PRIMARY</paramValue></parameter<>/parameters<>result return="0"/<>responses response><><![ CDATA[<instances><instance><oracleSid>ABCD2</oracleSid<>oracleHome>/opt/oracle/db/dbhome/19.3.0</oracleHome<>version>19.6.0.0.0</version<>databaseName>ABCD</databaseName<
>databaseId>ABCD:123456789:ABCD</databaseId<>online>true</online></instance<>/instance>]]></response></responses></operation><verze>1.0</version></ir_message>

Causa

Software AppSync 3.9.0.0 nepodporuje verze Oracle 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 nebo 19.6.
Software AppSync 4.0.0.0 nepodporuje verze Oracle 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 nebo 19.6.

Risoluzione

Software AppSync 3.9.0.0 vyžaduje opravu hotfix AppSync-patch-3.9.0.0_1278_R2 k podpoře verzí Oracle 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 nebo 19.6.

Software AppSync 4.0.0.0 vyžaduje opravu hotfix AppSync-patch-4.0.0.0_1553_R1 pro podporu verzí Oracle 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 nebo 19.6.

Poznamenejte si tento článek při volání žádosti o službu za účelem získání opravy hotfix. Nainstalujte opravu na server AppSync a odešlete agenta všem dotčeným klientům.

Oprava hotfix AppSync se vztahuje na následující komponenty:
  • AppSync Server
  •  Hostitelský modul plug-in AppSync (AppSync hostplugin_linux a AppSync hostplugin_aix)
Poznámka: První spuštění servisního plánu po instalaci opravy hotfix může selhat během zjišťování aplikací.

Pokud zjišťování AppSync 3.9 selže:
  1. Přejděte na obrazovku AppSync > Settings > Servers, vyberte server a spusťte Rediscover. 
  2. Přejděte na obrazovku AppSync > Copy Management > Oracle.
  3. Klikněte na rozevírací seznam vedle položky Discover Databases. 
  4. Vyberte možnost On Server a vyberte hostitele.
  5. Znovu spusťte servisní plán.
Pokud zjišťování AppSync 4.0 selže:
  1. Přejděte na obrazovku AppSync > Settings > Servers, vyberte server a spusťte Rediscover. 
  2. Přejděte na obrazovku AppSync > Copy Management > Copies Oracle > .
  3. Rozbalte možnost MORE a vyberte možnost Discover Databases. 
  4. Zvýrazněte server a vyberte "OK".
  5. Znovu spusťte servisní plán.

Informazioni aggiuntive

Oracle 19.4, 19.5 a 19.6 vyžadují opravu Oracle k vyřešení problému s obnovením:

 
Problém s obnovením je způsoben chybou Oracle, která byla opravena ve vydání 19.3.0.0.0, ale později se znovu objevila ve vydání 19.4.0.0.0 produktu.

Kontaktujte podporu Oracle ohledně následujícího čísla základní chyby, které by mělo být použito k získání oprav k nápravě problému na základě aktuálně používané platformy operačního systému:

Bug 30528704: PO POUŽITÍ OCT DATABASE RU 19C RMAN RECOVER DATABASE POUŽIJTE MÍSTO ARCHIVELOG PROTOKOL REDO

Další informace týkající se tohoto problému s obnovením souvisejícího s řešením Oracle naleznete v následujících článcích:
 
Odkazy: Konkrétní článek znalostní databáze AppSync (167093)
Článek znalostní databáze Dell EMC – 167419: Obnovení databáze Oracle 19.6 selhává s interní chybou ORA-600.

Prodotti interessati

AppSync

Prodotti

AppSync
Proprietà dell'articolo
Numero articolo: 000170879
Tipo di articolo: Solution
Ultima modifica: 05 mag 2026
Versione:  6
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.