Avvisi PowerStore: Avvisi di piena capacità del sistema
Riepilogo: In questo articolo vengono descritti gli avvisi relativi alla modalità WPM (Write Protect Mode) a piena capacità e gli avvisi risultanti.
Sintomi
Nota: non è possibile trovare le informazioni necessarie? Compilare il modulo di feedback alla fine di questo articolo.
Causa
Per una spiegazione di come viene calcolata la capacità fisica, consultare l'articolo 188491 della Knowledge Base: PowerStore: Come viene calcolata la capacità fisica di PowerStore.
Risoluzione
| ID dell'avviso | DATA_PATH_WRITE_PROTECT_MODE_ENTER DATA_PATH_APP_EXIT_WPM_WITH_ENOUGH_MD_NOTIFY DATA_PATH_APP_WPM_SHORT_OF_MD_NOTIFY |
| Testo dell'avviso | La < capacità dei dati dell'utente o del sistema > ha raggiunto la capacità completa. L'appliance è uscito dallo stato di protezione da scrittura con 16 GB di capacità libera. L'appliance non può uscire dalla modalità di protezione da scrittura a causa di una capacità insufficiente dei dati di sistema. |
| Codice errore | (0x00200701) (0x00201401) (0x00201501) |
| Risoluzione | Cosa succede in modalità WPM (Write Protect Mode) Quando un appliance raggiunge la capacità massima, entra in una condizione nota come modalità WPM (Write Protect Mode), in cui tutti i volumi passano allo stato read-only.
Per una spiegazione di come viene calcolata la capacità fisica, consultare l'articolo 188491 della Knowledge Base: PowerStore: Come viene calcolata la capacità fisica di PowerStore. La capacità fisica totale di PowerStore è costituita sia dai dati dell'utente sia dai dati di sistema. : Quando il sistema raggiunge il 70% della capacità, vengono generati avvisi per segnalare la mancanza di spazio. Consultare l'articolo 000123351 della Knowledge Base: Avvisi PowerStore: Utilizzo della capacità. Se l'utente non esegue alcuna azione e il sistema raggiunge il 100%, il sistema entra in modalità WPM (Write Protect Mode), che indica che tutti i volumi entrano in modalità read-only e viene generato il 0x00200701 di avviso. Il 0x00200701 di avviso indica un problema di spazio con i dati dell'utente o i dati di sistema. Come è possibile conoscere la causa principale del WPM: L'utente può determinare la root cause della condizione WPM in base al testo dell'avviso:
In base al tipo di condizione WPM (dati utente o dati di sistema) viene determinata la soluzione alternativa. Soluzione Il ripristino dalla condizione OOS dipende dal motivo dell'OOS. La causa della condizione WPM è contenuta nel testo dell'avviso:
A seconda del tipo di condizione WPM (dati utente o dati di sistema), viene determinata la soluzione alternativa. 1. Dati utenteUtilizzare una delle seguenti opzioni:
Informazioni aggiuntive
2. Dati di sistemaUtilizzare una delle seguenti opzioni:
In questo esempio, l'eliminazione del volume sottostante recupera 59,8 GB di spazio che può essere utilizzato per i dati dell'utente o per i dati di sistema. Si noti che i dati di sistema richiedono un minimo di circa 100 GB di spazio univoco per poter espandersi. A volte potrebbero essere necessari 200 GB di spazio per un'espansione corretta. |
Informazioni aggiuntive
- In genere, quando un appliance entra in WPM a causa dei dati di sistema, anche i dati utente esauriscono lo spazio.
Ciò è dovuto al fatto che non è rimasta alcuna capacità per l'espansione (dati di sistema o dati utente). - Per uscire da WPM, in genere l'utente deve aggiungere ulteriori unità ed eseguire lo scale-up dell'appliance.
- Quando il sistema genera il 0x00200701 di avviso (Testo dell'avviso: La capacità del sistema ha raggiunto la capacità massima. , indica che i dati di sistema hanno esaurito lo spazio e non possono essere espansi.
- Evitare di eliminare volumi in questa condizione ed eseguire l'escalation a Global Services per ricevere supporto.
Come usare svc_volume_space_metrics
- PowerStoreOS 1.0.3 ha introdotto uno script di servizio che consente agli utenti in WPM di visualizzare informazioni aggiuntive su ciascuna struttura ad albero del volume.
- Per eseguire lo script, SSH deve essere abilitato sull'appliance specificato e l'utente deve connettersi all'IP del cluster utilizzando l'account di servizio.
-
Quando si tenta di eseguire questo script di servizio quando non è in WPM, lo script di servizio ha esito negativo.
-
Quando lo spazio dell'appliance esaurisce, l'utente può eseguire lo script e visualizzare informazioni aggiuntive, ad esempio:
Family Unique Physical Used: rappresenta i dati univoci (compressi) di questo volume e tutti i dati della sua famiglia (snapshot e cloni) rilasciati se questo volume viene eliminato.
Esempio:[SVC:service@68R1BW2-A user]$ svc_volume_space_metrics 2020-10-29 12:28:33,997 - INFO - event_client init() address: localhost node: A 2020-10-29 12:28:34,248 - INFO - PyCycloneDp.init localhost 2020-10-29 12:28:34,318 - PyCycloneDp - INFO - logging in PyCycloneDp.__init__ Namespace state is ro-oos Retrieve family space stats from DP namespace. It will take some time... 2020-10-29 12:28:35,972 - INFO - event_client init() address: localhost node: A 2020-10-29 12:28:36,175 - INFO - PyCycloneDp.init localhost 2020-10-29 12:28:36,220 - PyCycloneDp - INFO - logging in PyCycloneDp.__init__ --------------------------------------+------------------------------------------------------+-------------+----------------+----------------+-----------+---------- Family ID | Primary Volume/FS/vVol Name | Type | Family Unique | Family Shared | No. of | No. of | | | Physical Used | Logical Used | Clones | Snapshots --------------------------------------+------------------------------------------------------+-------------+----------------+----------------+-----------+---------- d301959c-6eb9-4e23-967a-e0b3cdf06bea | labtea-vol-1 |Block | 97.91 GB| 486.36 GB| 0 | 1 6c97fdd8-5b01-44ef-adaf-047449f83c27 | labtea-vol-2 |Block | 99.47 GB| 492.30 GB| 0 | 1
| ID dell'avviso | DATA_PATH_WRITE_PROTECT_MODE_EXTREMELY_HIGH |
| Testo dell'avviso | L'utilizzo dello spazio di % (tier_name) è estremamente elevato. |
| Codice errore | 0x00200703 |
| Impatto | Diversi servizi interni (come NAS e UI) potrebbero non funzionare in modo ottimale. |
| Risoluzione | Causa: Parte della capacità dell'appliance è riservata ai servizi interni (come i servizi core NAS, le raccolte di dati, il DB interno e altro ancora). Quando l'appliance raggiunge la modalità di protezione da scrittura (0x00200701), l'utente non può più scrivere dati, tuttavia i servizi interni possono comunque accedere alle informazioni critiche (solo da PowerStoreOS 3.0). Una volta esaurita anche la capacità riservata interna, viene generato questo avviso, CP e SDNAS (e altri servizi) potrebbero non funzionare in modo ottimale. Soluzione: Contattare il supporto tecnico per ricevere assistenza immediata. |
Informazioni aggiuntive
- Se un nodo PowerStore rimane inattivo per più di 30 minuti, col tempo la capacità può aumentare più rapidamente. Per ulteriori informazioni, consultare PowerStore: è possibile eseguire l'appliance in WPM (Write Protect Mode) o OOS (Out of Space) dopo che un nodo è rimasto inattivo per più di 30 minuti (in inglese).
- Quando si elimina un volume, lo spazio dei volumi eliminati si riflette rapidamente nell'interfaccia utente di PowerStore Manager. Tuttavia, il recupero dello spazio viene eseguito in background e potrebbe richiedere del tempo per il completamento. Si consiglia di attendere qualche ora fino a quando i processi in background per recuperare lo spazio non sono stati completati.


