Avvisi PowerStore: Avvisi di piena capacità del sistema

Riepilogo: In questo articolo vengono descritti gli avvisi relativi alla modalità WPM (Write Protect Mode) a piena capacità e gli avvisi risultanti.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Quando un PowerStore rileva un problema, viene generato un avviso di errore per identificare il problema. Questo articolo spiega le possibili cause e le soluzioni per risolvere questi avvisi di errore. Se il problema non viene risolto anche dopo aver seguito la soluzione fornita, consultare le opzioni di contatto del supporto tecnico.
 

SLN317187_en_US__1icon Nota: non è possibile trovare le informazioni necessarie? Compilare il modulo di feedback alla fine di questo articolo.


Causa

Quando un appliance raggiunge la massima capacità, entra in una condizione nota come WPM (Write Protect Mode). In modalità WPM, tutti i volumi passano allo stato read-only ed è necessaria una riparazione del sistema.

Per una spiegazione di come viene calcolata la capacità fisica, consultare l'articolo 188491 della Knowledge Base: PowerStore: Come viene calcolata la capacità fisica di PowerStore.

Risoluzione

ID dell'avviso
DATA_PATH_WRITE_PROTECT_MODE_ENTER DATA_PATH_APP_EXIT_WPM_WITH_ENOUGH_MD_NOTIFY
DATA_PATH_APP_WPM_SHORT_OF_MD_NOTIFY
Testo dell'avviso La < capacità dei dati dell'utente o del sistema > ha raggiunto la capacità completa.
L'appliance è uscito dallo stato di protezione da scrittura con 16 GB di capacità libera.
L'appliance non può uscire dalla modalità di protezione da scrittura a causa di una capacità insufficiente dei dati di sistema.
Codice errore (0x00200701)
(0x00201401)
(0x00201501)
Risoluzione Cosa succede in modalità WPM (Write Protect Mode)
Quando un appliance raggiunge la capacità massima, entra in una condizione nota come modalità WPM (Write Protect Mode), in cui tutti i volumi passano allo stato read-only.
  • L'avviso 0x00B00702 (testo dell'avviso: Il livello di servizio è danneggiato, le funzioni di gestione sono limitate e l'I/O è interessato) viene sollevato.
  • Qualsiasi I/O di scrittura non riesce
  • Operazioni come istantanee e replica possono essere disabilitate.
  • Tutte le metriche (capacità e prestazioni) non sono disponibili. In PowerStore 3.0 e versioni successive, la tabella delle metriche viene aggiornata in WPM.
Raccomandazione: il sistema non deve superare la soglia dell'85%.
 

Per una spiegazione di come viene calcolata la capacità fisica, consultare l'articolo 188491 della Knowledge Base: PowerStore: Come viene calcolata la capacità fisica di PowerStore.


Causa

La capacità fisica totale di PowerStore è costituita sia dai dati dell'utente sia dai dati di sistema.

In PowerStoreOS 3.0 e versioni successive, in PowerStore Manager viene visualizzato quanto segue. L'utente viene sottoposto a una suddivisione più precisa dei dati dell'utente e dei dati di sistema:
image.png
Su PowerStoreOS inferiore alla versione 3.0, in PowerStore Manager viene visualizzato quanto segue. L'utente visualizza solo una suddivisione della capacità fisica utilizzata:

:
image.png

 

Quando il sistema raggiunge il 70% della capacità, vengono generati avvisi per segnalare la mancanza di spazio. Consultare l'articolo 000123351 della Knowledge Base: Avvisi PowerStore: Utilizzo della capacità.

Se l'utente non esegue alcuna azione e il sistema raggiunge il 100%, il sistema entra in modalità WPM (Write Protect Mode), che indica che tutti i volumi entrano in modalità read-only e viene generato il 0x00200701 di avviso.

Il 0x00200701 di avviso indica un problema di spazio con i dati dell'utente o i dati di sistema.

Nota: Se un nodo rimane inattivo per un periodo prolungato, la capacità fisica potrebbe aumentare.

Come è possibile conoscere la causa principale del WPM:

L'utente può determinare la root cause della condizione WPM in base al testo dell'avviso:

  • Dati utente - (0x00200701) i dati dell'utente hanno raggiunto la loro piena capacità.
  • Dati di sistema - (0x00200701) i dati di sistema hanno raggiunto la massima capacità.

In base al tipo di condizione WPM (dati utente o dati di sistema) viene determinata la soluzione alternativa.



Soluzione

Il ripristino dalla condizione OOS dipende dal motivo dell'OOS. La causa della condizione WPM è contenuta nel testo dell'avviso:

  • Dati utente - (0x00200701) i dati dell'utente hanno raggiunto la loro piena capacità.
  • Dati di sistema - (0x00200701) i dati di sistema hanno raggiunto la massima capacità.

A seconda del tipo di condizione WPM (dati utente o dati di sistema), viene determinata la soluzione alternativa.


 

1. Dati utente

Utilizzare una delle seguenti opzioni:

  • Add Drives (questa è l'opzione consigliata).
    • Consultare l'Account Team per analizzare i requisiti di capacità e aggiungere altre unità.
  • Eliminare volumi e/o istantanee.
    • Se l'utente ha bisogno di informazioni sui volumi o sulle snapshot da eliminare, rivolgersi a Global Services per ricevere indicazioni.

Informazioni aggiuntive

  1. Prima di eseguire qualsiasi azione, è necessario effettuare le seguenti operazioni:
    1. Arrestare tutti gli I/O nell'array (disabilitare le porte FC/iSCSI sullo switch) per evitare di incorrere nuovamente in WPM.
    2. Sospendere tutte le pianificazioni delle snapshot, la replica e qualsiasi automazione esterna correlata alla gestione dei volumi.
  2. Per uscire dalla condizione WPM, l'appliance deve recuperare almeno 16 GB di spazio. A tale scopo, l'utente deve eliminare un volume con almeno 16 GB di dati univoci.
    Se l'utente riesce a recuperare tale spazio ed è presente spazio sufficiente per i dati di sistema, l'avviso 0x00200701 (Testo dell'avviso: I dati dell'utente hanno raggiunto la massima capacità) si cancella e l'avviso 0x00201401(Testo dell'avviso: L'appliance è uscito dallo stato di protezione da scrittura con 16 GB di capacità libera) Viene visualizzato.
  3. Una volta in questo stato, i volumi passano all'accesso in lettura e scrittura e l'utente deve continuare a recuperare spazio fino a quando l'appliance non raggiunge l'85% di capacità fisica utilizzata.
    1. Si consiglia vivamente di eliminare volumi o istantanee uno alla volta.
    2. Consultare il manuale del sistema operativo specifico per istruzioni su come recuperare spazio dal lato host.
  4. Una volta raggiunto l'85% di capacità fisica utilizzata, l'utente deve cancellare manualmente il 0x00201401 degli avvisi.
  5. Nota: Il recupero dello spazio mediante l'eliminazione di snapshot o volumi richiede inizialmente spazio aggiuntivo per i dati di sistema e, di conseguenza, può causare la 0x00201501 di avviso (Testo dell'avviso: L'appliance non può uscire dalla modalità di protezione da scrittura a causa di una capacità insufficiente dei dati di sistema.
  6. PowerStoreOS 1.0.3 ha introdotto un nuovo script di servizio (svc_volume_space_metrics) che consente all'utente di visualizzare informazioni aggiuntive sulle statistiche dello spazio del volume quando l'appliance è in WPM.
    Per ulteriori informazioni, vedere la sezione "Come utilizzare svc_volume_space_metrics" più avanti in questo articolo della KB.
 

2. Dati di sistema

Utilizzare una delle seguenti opzioni:

  • Add Drives (questa è l'opzione consigliata).
    • Consultare l'Account Team per analizzare i requisiti di capacità e aggiungere altre unità.
  • Se l'utente non può aggiungere unità, rivolgersi al supporto tecnico per assistenza.
Queste informazioni possono essere visualizzate dal dashboard della capacità del volume.
In questo esempio, l'eliminazione del volume sottostante recupera 59,8 GB di spazio che può essere utilizzato per i dati dell'utente o per i dati di sistema.

Si noti che i dati di sistema richiedono un minimo di circa 100 GB di spazio univoco per poter espandersi. A volte potrebbero essere necessari 200 GB di spazio per un'espansione corretta.
image.png


Informazioni aggiuntive

  1. In genere, quando un appliance entra in WPM a causa dei dati di sistema, anche i dati utente esauriscono lo spazio. 
    Ciò è dovuto al fatto che non è rimasta alcuna capacità per l'espansione (dati di sistema o dati utente).
  2. Per uscire da WPM, in genere l'utente deve aggiungere ulteriori unità ed eseguire lo scale-up dell'appliance.
  3. Quando il sistema genera il 0x00200701 di avviso (Testo dell'avviso: La capacità del sistema ha raggiunto la capacità massima. , indica che i dati di sistema hanno esaurito lo spazio e non possono essere espansi.
  4. Evitare di eliminare volumi in questa condizione ed eseguire l'escalation a Global Services per ricevere supporto. 



Come usare svc_volume_space_metrics

  1. PowerStoreOS 1.0.3 ha introdotto uno script di servizio che consente agli utenti in WPM di visualizzare informazioni aggiuntive su ciascuna struttura ad albero del volume.
  2. Per eseguire lo script, SSH deve essere abilitato sull'appliance specificato e l'utente deve connettersi all'IP del cluster utilizzando l'account di servizio.
  3. Quando si tenta di eseguire questo script di servizio quando non è in WPM, lo script di servizio ha esito negativo.

  4. Quando lo spazio dell'appliance esaurisce, l'utente può eseguire lo script e visualizzare informazioni aggiuntive, ad esempio:
    Family Unique Physical Used: rappresenta i dati univoci (compressi) di questo volume e tutti i dati della sua famiglia (snapshot e cloni) rilasciati se questo volume viene eliminato.
    Esempio: 

    [SVC:service@68R1BW2-A user]$ svc_volume_space_metrics
    2020-10-29 12:28:33,997 - INFO - event_client init() address: localhost node: A
    2020-10-29 12:28:34,248 - INFO -  PyCycloneDp.init localhost
    2020-10-29 12:28:34,318 - PyCycloneDp - INFO - logging in PyCycloneDp.__init__
      
    Namespace state is ro-oos
    Retrieve family space stats from DP namespace. It will take some time...
    2020-10-29 12:28:35,972 - INFO - event_client init() address: localhost node: A
    2020-10-29 12:28:36,175 - INFO -  PyCycloneDp.init localhost
    2020-10-29 12:28:36,220 - PyCycloneDp - INFO - logging in PyCycloneDp.__init__
      
    --------------------------------------+------------------------------------------------------+-------------+----------------+----------------+-----------+----------
                  Family ID               |             Primary Volume/FS/vVol Name              |     Type    | Family Unique  | Family Shared  |   No. of  |  No. of
                                          |                                                      |             | Physical Used  |  Logical Used  |   Clones  | Snapshots
    --------------------------------------+------------------------------------------------------+-------------+----------------+----------------+-----------+----------
     d301959c-6eb9-4e23-967a-e0b3cdf06bea |                     labtea-vol-1                     |Block        |        97.91 GB|       486.36 GB|     0     |     1
     6c97fdd8-5b01-44ef-adaf-047449f83c27 |                     labtea-vol-2                     |Block        |        99.47 GB|       492.30 GB|     0     |     1

     


 
ID dell'avviso DATA_PATH_WRITE_PROTECT_MODE_EXTREMELY_HIGH 
Testo dell'avviso L'utilizzo dello spazio di % (tier_name) è estremamente elevato.
Codice errore 0x00200703
Impatto Diversi servizi interni (come NAS e UI) potrebbero non funzionare in modo ottimale.
Risoluzione  Causa:
Parte della capacità dell'appliance è riservata ai servizi interni (come i servizi core NAS, le raccolte di dati, il DB interno e altro ancora).
Quando l'appliance raggiunge la modalità di protezione da scrittura (0x00200701), l'utente non può più scrivere dati, tuttavia i servizi interni possono comunque accedere alle informazioni critiche (solo da PowerStoreOS 3.0). Una volta esaurita anche la capacità riservata interna, viene generato questo avviso, CP e SDNAS (e altri servizi) potrebbero non funzionare in modo ottimale.

Soluzione:
Contattare il supporto tecnico per ricevere assistenza immediata.

Informazioni aggiuntive

Problemi noti:

Prodotti interessati

PowerStore
Proprietà dell'articolo
Numero articolo: 000193645
Tipo di articolo: Solution
Ultima modifica: 13 giu 2025
Versione:  7
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