Dell Unity: Sprawdzanie liczby aktywnych otwartych plików dla NFS (tylko NFSv4) i aktywnego połączonego klienta NFS (zarówno NFSv3, jak i NFSv4) na serwerze Unity NAS (możliwość naprawienia przez użytkownika)
Riepilogo: Ta bazy wiedzy zawiera metodę sprawdzania liczby aktywnych otwartych plików dla NFS (tylko NFSv4) i aktywnego połączonego klienta NFS (zarówno NFSv3, jak i NFSv4) w systemie Live Unity. ...
Questo articolo si applica a
Questo articolo non si applica a
Questo articolo non è legato a un prodotto specifico.
Non tutte le versioni del prodotto sono identificate in questo articolo.
Sintomi
Gdy klienci otwierają zbyt wiele plików bez zamykania ich na serwerze Unity NAS, może to spowodować problem z dostępem.
Dell EMC Unity: Klienci Linux nie mogą otwierać plików/folderów w udziałach Unity NFS (z możliwością naprawienia przez Dell EMC) | Dell US
Identyfikacja aktywnej liczby otwartych plików dla NFS i aktywnych połączonych klientów NFS może pomóc w zidentyfikowaniu problematycznego klienta, aby klient mógł podjąć odpowiednie działania w celu zamknięcia otwartych plików z klienta i zbadania nieprawidłowego działania klienta.
Dell EMC Unity: Klienci Linux nie mogą otwierać plików/folderów w udziałach Unity NFS (z możliwością naprawienia przez Dell EMC) | Dell US
Identyfikacja aktywnej liczby otwartych plików dla NFS i aktywnych połączonych klientów NFS może pomóc w zidentyfikowaniu problematycznego klienta, aby klient mógł podjąć odpowiednie działania w celu zamknięcia otwartych plików z klienta i zbadania nieprawidłowego działania klienta.
Causa
Identyfikacja aktywnej liczby otwartych plików dla NFS i aktywnych połączonych klientów NFS może pomóc w zidentyfikowaniu problematycznego klienta, aby klient mógł podjąć odpowiednie działania.
Risoluzione
Aby uzyskać aktywny połączony klient NFS dla NFSv3 i NFSv4, polecenie svc_nfssupport -listClient może być używane w macierzach Unity z systemem operacyjnym 5.1 lub nowszym.
Należy pamiętać, że wynik showmount nie informuje, czy klienci montują udział NFS za pośrednictwem NFSv3 czy NFSv4.
Jeśli chcesz określić liczbę klientów NFSv4 i NFSv3 pokazanych w danych wyjściowych showmount, skontaktuj się z firmą Dell Technologies lub autoryzowanym dostawcą usług, aby uzyskać dodatkową pomoc i zapoznaj się z tym artykułem.
Nie ma metody określania liczby otwartych plików NFSv3. Metoda używana do określenia liczby otwartych plików NFSv4 wymaga dostępu root. Jeśli chcesz określić liczbę otwartych plików NFSv4, skontaktuj się z firmą Dell Technologies lub autoryzowanym usługodawcą, aby uzyskać dodatkową pomoc i zapoznaj się z tym artykułem.
01:27:16 root@VIRT2213Y2VF7N spa:/cores/service/user# svc_nfssupport NFS_test -listClient NFS v3 Clients: |--- 5.6.7.248 NFS v4 Clients: |--- 5.6.7.242 |--- 5.6.7.249
W przypadku macierzy Unity z systemem operacyjnym poniżej 5.1 alternatywnym sposobem uzyskania listy połączonych klientów NFS jest uruchomienie polecenia "showmount -a " na dowolnym kliencie NFS. Polecenie można również wykonać w unity SP, ale wymagane są uprawnienia główne.
00:54:57 root@VIRT2213RTVFNA spa:/cores/service/user# showmount -a 5.6.7.22 All mount points on 5.6.7.22: rhel8.peeps.lab:/NFS_export solaris11.peeps.labL/NFS_export rhel7.peeps.lab:/NFS_export
Należy pamiętać, że wynik showmount nie informuje, czy klienci montują udział NFS za pośrednictwem NFSv3 czy NFSv4.
Jeśli chcesz określić liczbę klientów NFSv4 i NFSv3 pokazanych w danych wyjściowych showmount, skontaktuj się z firmą Dell Technologies lub autoryzowanym dostawcą usług, aby uzyskać dodatkową pomoc i zapoznaj się z tym artykułem.
Nie ma metody określania liczby otwartych plików NFSv3. Metoda używana do określenia liczby otwartych plików NFSv4 wymaga dostępu root. Jeśli chcesz określić liczbę otwartych plików NFSv4, skontaktuj się z firmą Dell Technologies lub autoryzowanym usługodawcą, aby uzyskać dodatkową pomoc i zapoznaj się z tym artykułem.
Prodotti interessati
Dell EMC UnityProprietà dell'articolo
Numero articolo: 000204821
Tipo di articolo: Solution
Ultima modifica: 12 giu 2023
Versione: 3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.