Data Domain: Montaż NFS: ls powoduje błąd: odczyt katalogu ".": Nieaktualne dojścia do plików łącznie 0
Riepilogo: Edit NFS mount: ls results in error: reading directory '.' (Edytuj montowanie NFS: ls powoduje błąd: odczyt katalogu ".": Nieaktualne dojścia do plików łącznie 0 Jedną z przyczyn tego błędu jest przerwane łącze symboliczne z katalogiem. ...
Questo articolo si applica a
Questo articolo non si applica a
Questo articolo non è legato a un prodotto specifico.
Non tutte le versioni del prodotto sono identificate in questo articolo.
Sintomi
Klienty mogą pomyślnie zamontować do eksportu NFS (przykład: /ddvar)
Uruchamianie polecenia: Wynik "ls" powoduje wyświetlenie komunikatu:
stare klienty dojścia
plików mogą przesyłać pliki do katalogów w katalogu /ddvar/, takich jak wersje lub dzienniki, a następnie ls zwraca wyniki.
"cd releases" lub "cd log", a następnie "ls" odnosi sukces.
Uruchamianie polecenia: Wynik "ls" powoduje wyświetlenie komunikatu:
stare klienty dojścia
plików mogą przesyłać pliki do katalogów w katalogu /ddvar/, takich jak wersje lub dzienniki, a następnie ls zwraca wyniki.
"cd releases" lub "cd log", a następnie "ls" odnosi sukces.
Causa
Jedną z potencjalnych przyczyn tego zachowania jest przerwane łącze symboliczne.
Risoluzione
Poniższe kroki pomagają potwierdzić, czy przyczyną tego zachowania jest uszkodzone łącze symboliczne w eksporcie NFS (przykład: /ddvar)
1) Przejdź do trybu SE i uruchom polecenie ls do ścieżki eksportu. Przykład:
UWAGA: ddvar to ścieżka specjalna. /ddvar jest wewnętrznie przetłumaczony na /ddr/var i należy go używać jako /ddr/var podczas korzystania z poleceń wewnętrznych.
2) Poszukaj łączy symbolicznych: (Na przykład poniżej zanotuj literę "l" w lewej większości znaków, a także znak "->". Oznacza to, że masz łącze symboliczne).
3) Jeśli znajdziesz podejrzane łącze, sprawdź, czy oryginalny plik istnieje.
4) Jeśli pojawi się błąd informujący, że plik nie istnieje, oznacza to, że łącze symboliczne zostało przerwane. Musi zostać poprawiona lub łącze musi zostać usunięte.
5) Aby naprawić przerwane łącze, otwórz zgłoszenie do działu pomocy technicznej firmy Dell. Dostarczenie zebranych dowodów i wspomnieć o tym artykule bazy wiedzy.
1) Przejdź do trybu SE i uruchom polecenie ls do ścieżki eksportu. Przykład:
ddvar #se ls -al /ddr/var/
UWAGA: ddvar to ścieżka specjalna. /ddvar jest wewnętrznie przetłumaczony na /ddr/var i należy go używać jako /ddr/var podczas korzystania z poleceń wewnętrznych.
2) Poszukaj łączy symbolicznych: (Na przykład poniżej zanotuj literę "l" w lewej większości znaków, a także znak "->". Oznacza to, że masz łącze symboliczne).
lrwxrwxrwx 1 root root 36 Nov 27 2020 link_to_new_rpmfile.rpm -> /ddr/var/ext/link_to_new_rpmfile.rpm
3) Jeśli znajdziesz podejrzane łącze, sprawdź, czy oryginalny plik istnieje.
#se ls -al /ddr/var/ext/link_to_new_rpmfile.rpm
ls: cannot access /ddr/var/ext/link_to_new_rpmfile.rpm
4) Jeśli pojawi się błąd informujący, że plik nie istnieje, oznacza to, że łącze symboliczne zostało przerwane. Musi zostać poprawiona lub łącze musi zostać usunięte.
5) Aby naprawić przerwane łącze, otwórz zgłoszenie do działu pomocy technicznej firmy Dell. Dostarczenie zebranych dowodów i wspomnieć o tym artykule bazy wiedzy.
Prodotti interessati
Data DomainProprietà dell'articolo
Numero articolo: 000214782
Tipo di articolo: Solution
Ultima modifica: 02 ott 2023
Versione: 3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.