PowerScale: Impossibile eseguire il provisioning di Dell SupportAssist OneFS codice 9.5x e versioni successive
Riepilogo: Questo articolo illustra come eseguire il provisioning di Dell SupportAssist sui cluster PowerScale.
Sintomi
Quando si tenta di eseguire il provisioning di Dell SupportAssist sui cluster PowerScale, viene visualizzato il seguente errore.
"An error occurred when trying to activate SupportAssist"
Dalla CLI WebUI
:From:
Provision Status: Current State: COMPLETED
Sub-state: completed
Success or Fail: Fail
Percent Complete: 100%
Error: Exceeded API retries in provision_post_get_universal_key.
Causa
Questo potrebbe accadere a causa di due possibili scenari:
1. Utilizzo di un numero di serie del nodo o di un'altra forma di identificazione sul cluster durante la generazione della chiave di accesso dal sito Web di supporto. In questo modo viene invece utilizzato l'ID licenza OneFS del cluster.
2. Creazione di un PIN per la chiave di accesso di più di quattro cifre.
Risoluzione
Per evitare di riscontrare questo errore durante il provisioning di Dell SupportAssist, attenersi alla seguente procedura:
Creazione della chiave di accesso:
- Accedere al sito web di supporto con le credenziali Dell
- Utilizzare la casella di ricerca e individuare l'ID licenza OneFS del cluster. Si trova nell'interfaccia utente web di OneFS nell'angolo in alto a destra.
- Generare la chiave di accesso seguendo i relativi requisiti . Consultare la Guida all'amministrazione di OneFS
Da WebUI:
- Aprire OneFS WebUI, accedere con le credenziali utente root, in Impostazioni generali cliccare su SupportAssist
- Clicca sull'opzione Riprova nella scheda SupportAssist
- Copiare i dettagli della chiave di accesso fornita nell'e-mail inviata da ServicesConnectivity_Noreply@dell.com
- Attendere il provisioning di SupportAssist sul sistema

Dalla CLI:
2. Utilizzando la chiave di accesso e il pin ricevuti nell'e-mail, eseguire il comando di provisioning:
isilon-1# isi supportassist provision start --access-key <Access Key> --pin <4-digit PIN>
3. Attendere che lo stato del provisioning indichi "Success".
4. Confermare lo stato eseguendo i comandi riportati di seguito:
isilon-1# isi supportassist provision view
isilon-1# isi supportassist view
Nota: Se la procedura descritta in precedenza non ha risolto il problema, raccogliere un set completo di registri e contattare il supporto PowerScale.