NetWorker: Windows-klientsystemets buggkontrollhändelse orsakar omstart av systemet under säkerhetskopieringen

Riepilogo: Windows-klientdatorn startas om när säkerhetskopiering av filsystemet initieras. Custer-miljö. Båda noderna har samma problem.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

En säkerhetskopiering av NetWorker-filsystemet för en Windows-värd misslyckas. 
Det finns inga uppenbara fel som anger orsaken i NetWorker-loggarna:

181407:save: Step (1 of 5) for PID-10948: Save has been started on the client '<client-name>'.
174412:save: Step (2 of 5) for PID-10948: Running the backup on the client '<client-name>' for the save set 'pseudo_saveset'.
174424:save: Step (3 of 5) for PID-10948: Creating the snapshot for the selected save sets.
--- Job Indications ---
<client-name>:pseudo_saveset: retried 1 times.
184008 08/16/2023 02:30:58 AM  1 5 0 999192384 50244 0 <NetWorker-Server> savegrp NSR notice Client '<client-name>' is being skipped because no savesets of this client have been backed up as part of the backup action.
148758 08/16/2023 02:31:03 AM  1 5 0 999192384 50244 0 <NetWorker-Server> savegrp NSR notice Action backup traditional 'Backup' with job id 33079478 is exiting with status 'failed', exit code 1

På Windows-klienten visar systemhändelseloggarna att en BugCheck-händelse inträffade samtidigt när en säkerhetskopiering är schemalagd. Den händelsen gjorde att klientdatorn startades om.
BugCheck-händelse i loggboken 

Detta visas endast under VSS-aktiverade säkerhetskopieringar (Volume Shadow Copy Service) (standard). Om Windows-klienten är konfigurerad i NetWorker med åtgärder för att spara VSS:*=offlyckas säkerhetskopieringen.

Obs! Vi rekommenderar inte att du utför en säkerhetskopiering av Windows-klienten utan VSS. Värdens filsystem är fortfarande skyddat. Det skulle dock vara omöjligt att utföra en BMR (Bare Metal Recovery) av värden.

Causa

När VSS-ögonblicksbilder skapas kan filterdrivrutiner för filsystem i kernelläge från flera säkerhetsprodukter staplas tillsammans (till exempel antivirus (AV), HIPS, DLP, diskkryptering, EDR). Samtidiga realtidsfilter från två AV-produkter ökar användningen av kärnstacken under komplexa I/O-sökvägar. Detta kan uttömma stacken och utlösa en BugCheck.

Obs! Kärnstackens storlek är fast. den enda praktiska lösningen är att minska samtidig drivrutinsdjup eller komplexitet under I/O-åtgärder med högt filter (t.ex. skapande av VSS-ögonblicksbilder). Detta uppstår vanligtvis när VSS berör stora eller komplexa volymer, många skrivare eller tunga genomsökningskrokar i realtid. 

Risoluzione

Diagnostikchecklista (samla in innan du väljer en lösningsväg)

  1. Fånga BugCheck-information:

Loggboken → systemet → händelse-ID 1001 (BugCheck). Anteckna STOP-koden och fel på drivrutinen (t.ex. xxx.sys) om sådan finns.
Samla minidumps (%SystemRoot%\Minidump).

Obs! Kontakta Microsoft Support för analys av BuckCheck och minidump. Du kan referera till den här artikeln när du interagerar med Microsofts support.

 

  1. VSS-hälsa:

vssadmin list writers (leta efter Stabil utan fel)
vssadmin list providers
Kontrollera Loggboken → program för VSS (ID:n 8193, 12293), VolSnap (till exempel 25) och defender/mcafee driftloggar vid incidenttiden.

Mer information finns i: NetWorker: Felsöka säkerhetskopieringsfel på grund av VSS-problem

 

  1. Filtrera drivrutinsstackinventering:

fltmc (lista filsystemfilterdrivrutiner och ordning)

Obs! Identifiera eventuella ytterligare filter (DLP, HIPS, kryptering, slutpunktsagenter).

 

  1. Reprokontroll: Bekräfta att säkerhetskopieringen slutförs konsekvent med VSS:*=Off (fastställer att kraschen är VSS-sökvägsspecifik).

Exempel på VSS AV-inställningar

Obs! Detta bör endast användas som ett diagnostiskt steg. NetWorker rekommenderar inte Windows-säkerhetskopieringar utan VSS. Använd endast detta när det inte finns något alternativ eller när du enbart skyddar värdfildata. Utan VSS, DISASTER_RECOVERY:\ Spara uppsättningen säkerhetskopieras inte. En säkerhetskopiering utan VSS skulle inte vara BMR-konsekvent.

Lösning (nivåindelad – föredra minimala störningar)

Obs! Lösningarna som beskrivs i den här artikeln finns inte i NetWorker-produkten. De omfattar potentiella åtgärder i klientvärdens operativsystem och säkerhetsverktyg. Alla ändringar som krävs måste diskuteras med värdens systemadministratör och säkerhetsteam. Man måste komma överens om det lämpligaste tillvägagångssättet. Alla ändringar som krävs måste utföras av platsens system- eller administrationsteam.

A. Gör VSS och NetWorker "AV-vänliga" (rekommenderas först)

  • Undantag för realtidsskanning (båda AV-produkterna ):
    • Processer:
      nsrexecd.exe, save.exe, savefs.exe, nsrsvc.exe (om sådan finns) och alla NetWorker-binärfiler för hjälp under
      C:\Program Files\EMC NetWorker\nsr\bin\ (eller din installationssökväg).
    • Mappar:
      C:\Program Files\EMC NetWorker\ (hela nsr trädet), tillfälliga NetWorker-sökvägar och cachesökvägar, om de är anpassade.
    • VSS-artefakter:
      Exkludera åtkomst till \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy* och VSS-mellanlagringsplatser för att undvika djup inspektion av ögonblicksbildsvolymer när de skapas.
  • Försvarare: Föredra passivt läge när en AV från tredje part hanterar realtidsskydd (med hjälp av princip eller Defender-konfiguration). Detta gör att EDR förblir synlig samtidigt som man undviker konkurrens om dubbla realtidsfilter.
  • McAfee: Tillämpa rekommenderade undantag för NetWorker/ VSS. se till att HIPS- eller DLP-principer inte inspekterar skuggkopior eller blockerar volsnap/vssvc.

Resultat: Minskar filteraktiviteten under VSS-åtgärder och sänker trycket på kärnstacken utan att ta bort AV.

B. Minska drivrutins- och filterdjupet under VSS.

  • Inaktivera tillfälligt icke-nödvändiga slutpunktsmoduler (HIPS, DLP, enhetskontroll) under säkerhetskopieringsfönster enligt princip om ditt säkerhetsteam godkänner det.
  • Uppdatera AV-drivrutiner eller -definitioner och kumulativa Windows VSS/VolSnap-uppdateringar – inaktuella drivrutiner bidrar till ineffektiv stackanvändning.
  • Om det finns en VSS-provider från tredje part tvingar du Microsoft Software Shadow Copy-providern (testpåverkan):
    • Kontroll av tjänsten: Säkerställa Volume Shadow Copy tjänsten är problemfri.
    • Inaktivera eller reda ut leverantörer som inte kommer från Microsoft om de är kända för konflikter (i samordning med plattformen eller säkerhetsteamet).

C. Schemaläggning och lastreducering

  • Kör säkerhetskopieringar utanför hög aktivitet (tung I/O, genomsökningar eller slutpunktsuppgifter).
  • Sprid ut jobb så att färre klienter utlöser VSS-ögonblicksbild samtidigt om centrala principer orsakar synkroniserade genomsökningar.

D. Sista utväg (undvik om det inte är påbjudet)

  • Välj en AV-produkt i realtid . Om principen tillåter det ställer du in Defender på passivt/EDR-läge eller inaktiverar helt i realtid när McAfee är den primära AV:n.
    Avinstallation av en AV bör vara ett sista steg, inte standardrekommendationen.

E. Driftslösning (om affärsbehoven åsidosätts)

  • Fortsätt säkerhetskopieringen med VSS:*=Off tillfälligt om konsekvensrisken är acceptabel för den berörda arbetsbelastningen. Dokumentera att programkonsekvensen på VSS-nivå (skrivare) kan minskas (till exempel öppna filer). Använd endast för icke-kritiska datauppsättningar medan reparationen pågår.

Verifiering

  • När du har tillämpat undantag och drivrutinsoptimeringar kör du:
    • vssadmin list writers → bekräfta Stable
    • Testa en manuell ögonblicksbild: wmic shadowcopy call create Volume='C:\' (övervaka händelser för felkontroller)
    • Kör en säkerhetskopia av NetWorker-filsystemet på en enda volym; Skala sedan upp.
    • Bekräfta att det inte finns någon felkontroll så slutförs jobbet med VSS aktiverat.

Prodotti interessati

NetWorker
Proprietà dell'articolo
Numero articolo: 000218472
Tipo di articolo: Solution
Ultima modifica: 07 gen 2026
Versione:  1
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.