NetWorker: Windows istemci sistemi hata kontrolü olayı yedekleme sırasında sistemin yeniden başlatılmasına neden oluyor

Riepilogo: Dosya sistemi yedeklemesi her başlatıldığında Windows istemci makinesi yeniden başlatılır. Custer ortamı. Her iki düğümde de aynı sorun var.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Windows ana bilgisayarının NetWorker dosya sistemi yedeklemesi başarısız olur. 
NetWorker günlüklerinde nedeni belirten belirgin bir hata yoktur:

181407:save: Step (1 of 5) for PID-10948: Save has been started on the client '<client-name>'.
174412:save: Step (2 of 5) for PID-10948: Running the backup on the client '<client-name>' for the save set 'pseudo_saveset'.
174424:save: Step (3 of 5) for PID-10948: Creating the snapshot for the selected save sets.
--- Job Indications ---
<client-name>:pseudo_saveset: retried 1 times.
184008 08/16/2023 02:30:58 AM  1 5 0 999192384 50244 0 <NetWorker-Server> savegrp NSR notice Client '<client-name>' is being skipped because no savesets of this client have been backed up as part of the backup action.
148758 08/16/2023 02:31:03 AM  1 5 0 999192384 50244 0 <NetWorker-Server> savegrp NSR notice Action backup traditional 'Backup' with job id 33079478 is exiting with status 'failed', exit code 1

Windows istemcisinde, Sistem Olay Günlükleri, bir yedekleme zamanlandığında aynı anda bir BugCheck olayı meydana geldiğini gösterir. Bu olay istemci makinenin yeniden başlatılmasına neden oldu.
Olay görüntüleyicisinde BugCheck olayı 

Bu yalnızca Birim Gölge Kopyası Hizmeti (VSS) etkin yedeklemeler sırasında görüntülenir (varsayılan). Windows istemcisi NetWorker'da kaydetme işlemleriyle yapılandırılmışsa VSS:*=off, yedekleme başarılı olur.

NOT: VSS olmadan Windows istemci yedeklemesi gerçekleştirilmesi önerilmez. Ana bilgisayarın dosya sistemi korunmaya devam eder; ancak ana bilgisayarda Yeni Sisteme Kurtarma (BMR) gerçekleştirmek imkansız olur.

Causa

VSS anlık görüntü oluşturma işlemi sırasında, birden çok güvenlik ürününün (örneğin Antivirus (AV), HIPS, DLP, disk şifreleme, EDR) çekirdek modu dosya sistemi filtre sürücüleri bir araya gelebilir. İki AV ürününden gelen eş zamanlı gerçek zamanlı filtreler, karmaşık G/Ç yolları sırasında çekirdek yığını kullanımını artırır. Bu, yığını tüketebilir ve bir BugCheck'i tetikleyebilir.

NOT: Çekirdek yığını boyutu sabittir; tek pratik azaltma, yüksek filtreli G/Ç işlemleri (VSS anlık görüntü oluşturma gibi) sırasında eşzamanlı sürücü derinliğini veya karmaşıklığını azaltmaktır. Bu durum genellikle VSS büyük veya karmaşık birimlere, çok sayıda yazıcıya veya ağır gerçek zamanlı tarama kancalarına dokunduğunda ortaya çıkar. 

Risoluzione

Tanılama Kontrol Listesi (Bir çözüm yolu seçmeden önce toplayın)

  1. BugCheck ayrıntılarını yakalayın:

Olay Görüntüleyicisi → Sistem → Olay Kimliği 1001 (BugCheck). Varsa STOP kodunu ve sürücüde hata oluşmasını (örneğin, xxx.sys) kaydedin.
Toplamak minidumps (%SystemRoot%\Minidump).

NOT: BuckCheck ve mini dökümün analizi için Microsoft Desteği ile iletişime geçin. Microsoft desteği ile iletişim kurarken bu makaleye başvurulabilir.

 

  1. VSS durumu:

vssadmin list writers (Hata olmadan Kararlı arayın)
vssadmin list providers
VSS (ID 8193, 12293), VolSnap (örneğin, 25) ve olay anındaki defender/mcafee işlem günlükleri için Olay Görüntüleyicisi → Uygulamasını denetleyin.

Daha fazla ayrıntı için bkz.: NetWorker: VSS sorunları nedeniyle oluşan yedekleme hatalarını giderme

 

  1. Sürücü yığın envanterini filtreleyin:

fltmc (dosya sistemi filtre sürücülerini ve sırasını listeleyin)

NOT: Ek filtreleri (DLP, HIPS, şifreleme, uç nokta aracıları) tanımlayın.

 

  1. Yeniden üretim kontrolü: Yedeklemenin ile tutarlı bir şekilde tamamlandığını onaylayın VSS:*=Off (kilitlenmenin VSS yoluna özgü olduğunu belirler).

VSS KAPALI ayarları örneği

NOT: Bu yalnızca bir tanılama adımı olarak kullanılmalıdır. NetWorker, VSS olmadan Windows yedeklemesi yapılmasını önermez. Bunu yalnızca alternatif olmadığında veya ana bilgisayar dosyası verilerini özel olarak korurken kullanın. VSS olmadan, DISASTER_RECOVERY:\ Kaydetme kümesi yedeklenmez. VSS olmayan bir yedekleme BMR tutarlı olmaz.

Çözüm (Katmanlı—en az kesintiyi tercih edin)

NOT: Bu makalede özetlenen çözümler NetWorker ürününde yer almaz. İstemci ana bilgisayarının işletim sistemi ve güvenlik araçları içindeki olası eylemleri içerirler. Gereken herhangi bir değişiklik, ana bilgisayarın sistem yöneticisi ve güvenlik ekibiyle görüşülmelidir. En uygun hareket tarzı üzerinde bir anlaşma yapılmalıdır. Gereken tüm değişiklikler sitenin sistem veya yönetim ekipleri tarafından gerçekleştirilmelidir.

A. VSS ve NetWorker'ı "AV dostu" hale getirin (önce önerilir)

  • Gerçek zamanlı tarama istisnaları (her iki AV ürünü):
    • Süreçler:
      nsrexecd.exe, save.exe, savefs.exe, nsrsvc.exe (varsa) ve altındaki NetWorker yardımcı ikili dosyaları
      C:\Program Files\EMC NetWorker\nsr\bin\ (veya yükleme yolunuz).
    • Klasörler:
      C:\Program Files\EMC NetWorker\ (tüm nsr ağaç), NetWorker geçici ve özelleştirilmişse önbellek yolları.
    • VSS yapıtları:
      Erişimi hariç tutma \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy* ve oluşturma sırasında anlık görüntü birimlerinin derinlemesine incelenmesini önlemek için VSS hazırlama konumları.
  • Defans oyuncusu: Üçüncü taraf bir AV gerçek zamanlı korumayı yönettiğinde (politika veya Defender yapılandırmasını kullanarak) Pasif modu tercih edin. Bu, ikili gerçek zamanlı filtre çekişmesini önlerken EDR görünürlüğünü korur.
  • McAfee: NetWorker/VSS tarafından önerilen istisnaları uygulama; HIPS veya DLP politikalarının gölge kopyaları incelemediğinden veya engellemediğinden emin olun volsnap/vssvc.

Sonuç: VSS işlemleri sırasında filtre etkinliğini azaltır ve AV'yi kaldırmadan çekirdek yığını basıncını düşürür.

B. VSS sırasında sürücü ve filtre derinliğini azaltın.

  • Güvenlik ekibiniz onaylarsa ilkeye göre yedekleme aralıkları sırasındagerekli olmayan uç nokta modüllerini (HIPS, DLP, aygıt denetimi) geçici olarak devre dışı bırakın.
  • AV sürücülerini veya tanımlarını ve Windows VSS/VolSnap toplu güncellemelerini güncelleyin - eski sürücüler yığın kullanım verimsizliklerine katkıda bulunur.
  • Üçüncü taraf bir VSS sağlayıcısı varsa Microsoft Yazılım Gölge Kopyası sağlayıcısını zorlayın (test etkisi):
    • Servis kontrolleri: Sağlamak Volume Shadow Copy hizmet sağlıklıdır.
    • Çakıştığı biliniyorsa Microsoft dışı sağlayıcıları devre dışı bırakın veya çözün (platform veya güvenlik ekibiyle koordinasyon içinde).

C. Zamanlama ve yük azaltma

  • Yedeklemeleri etkinliğin en yoğun olduğu noktalar dışında çalıştırın (yoğun G/Ç, taramalar veya uç nokta görevleri).
  • Merkezi politikalar senkronize taramalara neden olursa daha az sayıda istemcinin VSS anlık görüntüsünü aynı anda tetiklemesi için işleri kademelendirin.

D. Son çare (zorunlu olmadıkça kaçının)

  • Bir gerçek zamanlı AV ürünü seçin . Politika izin veriyorsa Defender ı yalnızca pasif/EDR moduna ayarlayın veya McAfee birincil AV olduğunda gerçek zamanlı modu tamamen devre dışı bırakın.
    Bir AV'yi kaldırmak, varsayılan öneri değil, son adım olmalıdır.

E. Operasyonel geçici çözüm (işin geçersiz kılınması gerekiyorsa)

  • Yedeklemelere şununla devam et VSS:*=Off Etkilenen iş yükü için tutarlılık riski kabul edilebilir ise geçici olarak. VSS düzeyinde uygulama tutarlılığının (yazıcılar) azaltılabileceğini belgeleyin (örneğin, açık dosyalar). Kritik olmayan veri kümeleri için yalnızca düzeltme devam ederken kullanın.

Doğrulama

  • İstisnaları ve sürücü iyileştirmelerini uyguladıktan sonra şu komutu çalıştırın:
    • vssadmin list writers → onaylayın Stable
    • Manuel anlık görüntüyü test etme: wmic shadowcopy call create Volume='C:\' (hata kontrolleri için olayları izleyin)
    • Tek bir disk bölümünde NetWorker dosya sistemi yedeklemesi çalıştırma; Ardından ölçeği büyütün.
    • BugCheck olmadığını onaylayın ve iş, VSS etkinleştirilmiş olarak tamamlanır.

Prodotti interessati

NetWorker
Proprietà dell'articolo
Numero articolo: 000218472
Tipo di articolo: Solution
Ultima modifica: 07 gen 2026
Versione:  1
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.