NetWorker: De map REST API-logboek ontbreekt

Riepilogo: Dit KB-artikel bevat instructies voor het opnieuw configureren van REST API-logboekregistratie als de map met restapi-logboeken niet bestaat.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

De map restapi-logboeken van de NetWorker-server ontbreekt:
  • Linux: /nsr/logs/restapi
  • Windows: C:\Program Files\EMC NetWorker\nsr\logs\restapi
Bij het opnieuw starten van services wordt de REST API-logboekdirectory niet opnieuw gemaakt.

Causa

De naam van de restapi-logboeken is gewijzigd of verwijderd, per ongeluk door een gebruiker of als onderdeel van een poging tot probleemoplossing.

Risoluzione

Op Windows-servers zou het probleem eenvoudigweg opnieuw moeten worden gemaakt door de map C:\Program Files\EMC NetWorker\nsr\logs\restapi opnieuw te maken. Zodra de map is gemaakt, zou de restapi.log moeten verschijnen; Het is echter mogelijk dat de NetWorker-service opnieuw moet worden opgestart. Dit pad gaat ervan uit dat het standaard NetWorker-installatiepad is gebruikt. Als een andere schijf of een ander installatiepad is gebruikt, moet de map restapi worden gemaakt onder het .. \nsr\logs location. 

Op Linux-servers moet u het volgende doen:

OPMERKING: Zie het veld Aanvullende informatie als de NetWorker-server is geïmplementeerd op een pacemakercluster (pc's).

1. Maak de map REST API-logboeken opnieuw:
sudo mkdir /nsr/logs/restapi

2. Machtigingen instellen voor de map:
sudo chmod 755 /nsr/logs/restapi

3. Change ownership of the folder into nsrtomcat:
sudo chown -R nsrtomcat:nsrtomcat /nsr/logs/restapi
 
4. Start NetWorker opnieuw:
Systemctl Restart Networker
 

5. Het REST API-logboek moet opnieuw worden gemaakt en het opstarten van een nwrestapi-service weergeven.

image

Informazioni aggiuntive

Prodotti interessati

NetWorker

Prodotti

NetWorker Family, NetWorker Series
Proprietà dell'articolo
Numero articolo: 000221945
Tipo di articolo: Solution
Ultima modifica: 30 apr 2025
Versione:  3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.