NetWorker:REST API 記錄資料夾遺失

Riepilogo: 本知識文章說明如何在 restapi 記錄目錄不存在時重新設定 REST API 記錄。

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

NetWorker 伺服器的 restapi 記錄目錄遺失:
  • Linux:/nsr/logs/restapi
  • Windows:C:\Program Files\EMC NetWorker\nsr\logs\restapi
重新啟動服務不會重新建立 REST API 記錄目錄。

Causa

重新命名或刪除 restapi 記錄可能是由使用者意外刪除,或是故障診斷嘗試的一部分。

Risoluzione

在 Windows 伺服器上,只需重新建立 C:\Program Files\EMC NetWorker\nsr\logs\restapi 目錄即可解決問題。創建資料夾后,應出現restapi.log;但是,可能需要重新啟動 NetWorker 服務。此路徑假定已使用預設的 NetWorker 安裝路徑。如果使用了另一個磁碟機或安裝路徑,則應在 . 下建立 restapi 資料夾。\nsr\日誌位置。

在 Linux 伺服器上,您必須執行下列步驟:

注意:如果 NetWorker 伺服器部署在 Pacemaker (pcs) 叢集上,請參閱 「其他資訊 」欄位。

1.重新建立 REST API 記錄資料夾:
sudo mkdir /nsr/logs/restapi

2.設定資料夾的權限:
sudo chmod 755 /nsr/logs/restapi

3.將資料夾的擁有權變更為 nsrtomcat:
sudo chown -R nsrtomcat:nsrtomcat /nsr/logs/restapi
 
4.重新啟動 NetWorker:
Systemctl restart NetWorker
 

5.應重新建立 REST API 記錄,並顯示 nwrestapi 服務啟動。

影像

Informazioni aggiuntive

Prodotti interessati

NetWorker

Prodotti

NetWorker Family, NetWorker Series
Proprietà dell'articolo
Numero articolo: 000221945
Tipo di articolo: Solution
Ultima modifica: 30 apr 2025
Versione:  3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.