NetWorker: Папка журналу REST API відсутня

Riepilogo: Ця база даних містить інструкції щодо того, як переналаштувати журналювання REST API, якщо каталог журналів restapi не існує.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Каталог журналів restapi сервера NetWorker відсутній:
  • Linux: /nsr/logs/restapi
  • Вікна: C:\Program Files\EMC NetWorker\nsr\logs\restapi
Перезапуск служб не призводить до повторного створення каталогу журналу REST API.

Causa

Журнали restapi були перейменовані або видалені або випадково користувачем, або в рамках спроби усунення несправностей.

Risoluzione

На серверах Windows просте повторне створення каталогу C:\Program Files\EMC NetWorker\nsr\logs\restapi має вирішити проблему. Після створення папки має з'явитися restapi.log; однак може знадобитися перезапуск служби NetWorker. Цей шлях передбачає, що було використано шлях встановлення NetWorker за замовчуванням. Якщо використовувався інший диск або шлях встановлення, папку restapi слід створити під доменом .. \nsr\logs розташування. 

На серверах Linux ви повинні виконати такі дії:

ПРИМІТКА: Дивіться поле «Додаткова інформація », якщо сервер NetWorker розгорнутий на кластері кардіостимулятора (pcs).

1. Повторно створіть папку журналів REST API:
sudo mkdir /nsr/logs/restapi

2. Встановіть дозволи для папки:
sudo chmod 755 /nsr/logs/restapi

3. Змініть власника папки на nsrtomcat:
sudo chown -R nsrtomcat:nsrtomcat /nsr/logs/restapi
 
4. Перезапустіть NetWorker:
systemctl restart networker
 

5. Журнал REST API повинен бути створений заново і показати запуск сервісу nwrestapi.

образ

Informazioni aggiuntive

Prodotti interessati

NetWorker

Prodotti

NetWorker Family, NetWorker Series
Proprietà dell'articolo
Numero articolo: 000221945
Tipo di articolo: Solution
Ultima modifica: 30 apr 2025
Versione:  3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.