NetWorker: Cartella di registro API REST mancante

Riepilogo: Questo articolo della Knowledge Base fornisce istruzioni su come riconfigurare la registrazione dell'API REST se la directory dei log restapi non esiste.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Manca la directory dei log restapi del server NetWorker:
  • Linux: /nsr/logs/restapi
  • Windows: C:\Program Files\EMC NetWorker\nsr\logs\restapi
Il riavvio dei servizi non ricrea la directory di registro dell'API REST.

Causa

I registri restapi sono stati rinominati o eliminati, accidentalmente da un utente o come parte di un tentativo di risoluzione dei problemi.

Risoluzione

Sui Windows Server, il problema dovrebbe essere risolto semplicemente ricreando la directory C:\Program Files\EMC NetWorker\nsr\logs\restapi. Una volta creata la cartella, dovrebbe apparire il restapi.log; tuttavia, potrebbe essere necessario riavviare il servizio NetWorker. Questo percorso presuppone che sia stato utilizzato il percorso di installazione predefinito di NetWorker. Se è stata utilizzata un'altra unità o percorso di installazione, è necessario creare la cartella restapi sotto il dominio .. \nsr\posizione logs. 

Sui server Linux, è necessario effettuare le seguenti operazioni:

NOTA: Vedere il campo Additional Info se il server NetWorker è installato su un cluster pacemaker (pcs).

1. Ricreare la cartella dei registri dell'API REST:
sudo mkdir /nsr/logs/restapi

2. Impostare le autorizzazioni per la cartella:
sudo chmod 755 /nsr/logs/restapi

3. Modificare la proprietà della cartella in nsrtomcat:
sudo chown -R nsrtomcat:nsrtomcat /nsr/logs/restapi
 
4. Riavviare NetWorker:
systemctl riavvia NetWorker
 

5. Il log dell'API REST dovrebbe essere ricreato e mostrare un avvio del servizio nwrestapi.

immagine

Informazioni aggiuntive

Prodotti interessati

NetWorker

Prodotti

NetWorker Family, NetWorker Series
Proprietà dell'articolo
Numero articolo: 000221945
Tipo di articolo: Solution
Ultima modifica: 30 apr 2025
Versione:  3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.