NVP vProxy : Le processus de réactivation du saveset de machine virtuelle ne progresse pas

Riepilogo: Un saveset de machines virtuelles qui réside sur un périphérique non DDboost (AFTD, bande, CloudBoost) est ressuscité (cloné) vers un périphérique Data Domain pour être restauré. Le processus de réactivation n’est pas en cours et aucune donnée n’est clonée sur le périphérique dd intermédiaire. ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Une restauration de réactivation de machine virtuelle (VM) a été lancée à partir de NetWorker Management Console (NMC) ou NetWorker Web User Interface (NWUI).

Remarque : Une restauration de réactivation est un processus automatique qui se produit lorsque le saveset sélectionné pour la restauration réside sur un périphérique autre que Data Domain (AFTD, Tape, CloudBoost). Lors de la sélection du saveset source, une option est fournie pour sélectionner un pool « intermédiaire », dans lequel un périphérique de clonage Data Domain est configuré. Le processus de réactivation clone le saveset dans le pool intermédiaire DD, puis lance la restauration.

Le processus de réactivation a démarré, mais aucun transfert de données n’est visible :

Session de restauration

La fenêtre NMC Alerts affiche « waiting for writable volume » sur le pool intermédiaire sélectionné. 

Alertes NMC

Le pool intermédiaire dispose d’un appareil monté :

image.png

Causa

Une copie du même saveset est déjà présente sur le volume du périphérique intermédiaire.

1. Confirmez le SSID à partir de la session de restauration :

Session de restauration

3. Utilisez mminfo pour vérifier si le saveset s’affiche sur le périphérique intermédiaire :
 

mminfo -kot -q ssid=SSID

Exemple :

nve:~ # mminfo -kot -q ssid=2891939064
 volume        type   vm_name         date     time         size ssid      fl backup_size
AFTDVMClone.001 adv_file lnx-client01  06/04/24 16:45:43  104 GB 2891939064 cr 104 GB
ddvestaging.001 Data Domain lnx-client01 06/04/24 16:45:43 104 GB 2891939064 cr 104 GB

Cela est normal. Vous ne pouvez pas créer plusieurs copies du même saveset dans le même emplacement cible. Voici ce qu’indique le Guide d’intégration de NetWorker VMware : Assurez-vous que le pool sélectionné ne contient pas déjà de copies pour cette sauvegarde. Si la source principale est présente et que vous sélectionnez un clone à partir duquel effectuer une restauration à l’aide du même pool intermédiaire qui contient la copie existante, la restauration peut cesser de répondre.

Risoluzione

Vérifiez la balise de saveset de la copie sur le volume intermédiaire :

nve:~ # mminfo -kot -q volume=ddvestaging.001
 volume        type   vm_name         date     time         size ssid      fl backup_size
ddvestaging.001 Data Domain lnx-client01 06/04/24 16:45:43 104 GB 2891939064 cr 104 GB

Dans certains cas, la résurrection précédente peut s’être terminée, mais un échec nsrclone peut avoir provoqué le marquage du saveset comme abandonné (ca) ou suspect(s). Cela entraînerait l’échec de la restauration et le saveset ne serait pas éligible à la restauration. Il existe deux options selon que la copie est valide ou non.

Saveset valide sur le périphérique intermédiaire.

1. Sous l’onglet Recover , cliquez avec le bouton droit de la souris sur la session de restauration, puis cliquez sur Stop.
2. Redémarrez la restauration et sélectionnez le saveset qui a été cloné sur DD. Il doit afficher une copie dans les colonnes « Data Domain Copies » et « Other Media Copies » :

Savesets disponibles

3. Une fois sur la page Select Alternate Recovery Sources, sélectionnez la copie à partir du périphérique de clonage Data Domain :
Périphérique clone Data Domain

4. Effectuez la restauration.

Le saveset n’est pas valide

Si le saveset n’est pas valide ; soit avortée (CA) soit suspecte (s). Vous devez supprimer le saveset et redémarrer la résurrection.

1. Obtenez le SSID et l’ID de clone du saveset qui réside sur le périphérique intermédiaire.
mminfo -kot -q volume=VOLUME_NAME -r vmname,savetime,sumflags,ssid,cloneid
Exemple :
nve:~ # mminfo -kot -q volume=ddvestaging.001 -r vmname,savetime,sumflags,ssid,cloneid
 vm_name    date   fl ssid          clone id
lnx-client01 06/04/24 ca 2891939064 1718033764
 
2. À l’aide du ssid/cloneid. Supprimez le saveset :
nsrmm -d -S SSID/CLONEID
Exemple :
nve:~ # nsrmm -d -S 2891939064/1718033764

The following clones will be deleted:
2891939064/1718033764

Continue? y
Processing the clone list.
Deleting clones.
ATTENTION : Il est important de spécifier le SSID/CLONEID. Si vous spécifiez uniquement le SSID, toutes les copies de ce saveset peuvent être supprimées du module de gestion, y compris la source.

3. Redémarrez la restauration de réactivation en sélectionnant le saveset avec uniquement « Other Media Copy ». Sélectionnez le pool intermédiaire et commencez la restauration. Le saveset sera cloné dans le pool intermédiaire et le processus de restauration commencera une fois le clone terminé.

Informazioni aggiuntive

Si vous observez un problème dans lequel le clone ne se termine pas ou se termine, mais ne semble pas être valide. Supprimez le saveset non valide abandonné (ca) ou suspect(s) comme indiqué ci-dessus. Clonez manuellement le saveset à l’aide de la commande nsrclone et consultez la sortie nsrclone pour plus d’informations :
nsrclone -vvv [{optional} -D[1-7]] -b STAGING_POOL_NAME -S SSID/CLONEID

Où SSID/CLONEID correspond au SSID et au CloneId du saveset résidant sur le périphérique non DD. La sortie peut être redirigée vers un fichier ; en option, le débogage peut être ajouté avec -D niveaux 1 à 7. 

Voir : NVP vProxy : Comment cloner manuellement un saveset de machines virtuelles à partir d’un périphérique autre que Data Domain vers un périphérique clone Data Domain ?

Une analyse du vidage sfs et du log ddfs.info du Data Domain cible peut être nécessaire.

Prodotti interessati

NetWorker

Prodotti

NetWorker Family, NetWorker Series
Proprietà dell'articolo
Numero articolo: 000225923
Tipo di articolo: Solution
Ultima modifica: 22 mag 2025
Versione:  2
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.