Il provisioning di PowerScale SupportAssist si blocca in INVIO
Riepilogo: Un problema in cui si avvia il provisioning di SupportAssist in PowerScale OneFS e si seleziona "# isi supportassist provision view" e sembra essere bloccato in COMING.
Sintomi
Quando si abilita SupportAssist, leggere l'articolo della KB PowerScale: Impossibile eseguire il provisioning di Dell SupportAssist OneFS codice 9.5x e versioni successive per ulteriori informazioni.
# isi supportassist provision start --access-key=<key> --pin=<pin>
# isi supportassist provision view
Provision Status:
Current State: INCOMING
Sub-state: INCOMING
Success or Fail: -
Percent Complete: -
Error: -
E sembra che smetta di rispondere in questo stato.
Causa
Verificare all'indirizzo /var/log/isi_crispies_d.log Per errori simili a:
2024-10-04T11:28:34.667359-04:00 <3.3> powerscale-1(id10) isi_crispies_d[2406]: MainThread(isi_crispies_d:387) ERROR: Exception(main):400 Client Error: Bad Request for url: https://localhost:9443/ese/security/certificate/webserver
2024-10-04T11:23:58.143464-04:00 <3.7> powerscale-1(id10) isi_crispies_d[2406]: MainThread(ese_request.py:132) DEBUG: Response[400 /ese/security/certificate/webserver] Body: {"status_Code": 400, "message": "Provided certificate has expired."}
Risoluzione
Un problema in cui un cluster in un fuso orario non GMT causa una falsa scadenza di un certificato. Dopo aver atteso diverse ore (preferibilmente durante la notte), quando viene raggiunta l'ora desiderata, esegue automaticamente il provisioning.
Se sono trascorse 24 ore ed è ancora bloccato in ENTRATA, avviare una nuova raccolta del logset e aprire una Service Request con il supporto Dell Technologies per la revisione.
Versioni di OneFS interessate: 9.7.1.0 e versioni successive, 9.5.1.1 e versioni successive
Il problema è stato risolto in OneFS 9.8.x.x e versioni successive.