Connectrix MDS upgrade retourneert bericht "Pre-upgrade check failed "Return code -1"
요약: Bij het uitvoeren van een Connectrix MDS upgrade geeft de opdracht "install all" het bericht "Pre-upgrade check failed. "Retourcode -1."
이 문서는 다음에 적용됩니다.
이 문서는 다음에 적용되지 않습니다.
이 문서는 특정 제품과 관련이 없습니다.
모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.
증상
Bij een poging om de opdracht 'install all' uit te voeren, geeft de switch het bericht 'Pre-upgrade check failed. "Retourcode -1."
Geen indicaties van wat er mis is, md5sum van de firmwarebestanden zijn goed. Voldoende ruimte op de bootflash: en ook op de stand-by supervisor, maar de opdracht 'install all' mislukt met 'Return code -1'.
Geen indicaties van wat er mis is, md5sum van de firmwarebestanden zijn goed. Voldoende ruimte op de bootflash: en ook op de stand-by supervisor, maar de opdracht 'install all' mislukt met 'Return code -1'.
원인
De opdracht
werkt prima.
De opdracht
(Dit is hetzelfde bericht als de opdracht 'install all'.)
"show incompatibility-all system bootflash:m9700-sf2ek9-xxxx.bin"
werkt prima.
De opdracht
"show install all impact kickstart bootflash:m9700-sf2ek9-kickstart-mz.xxxx.bin system bootflash:m9700-sf2ek9-mz.xxxx.bin" fails with "Return code -1."
(Dit is hetzelfde bericht als de opdracht 'install all'.)
해결
Tijdelijke oplossing:
- Voer een opdracht 'system switchover' uit om failover uit te voeren naar de tweede supervisor. Wacht tot de opdracht is voltooid. Gebruik de opdracht "show system redundancy status" om te bevestigen dat de actie is voltooid.
- Voer een tweede opdracht "system switchover" uit om terug te gaan naar de eerder actieve supervisor waar de upgradecode zich momenteel bevindt.
- Voer de opdracht 'install all' opnieuw uit en de upgrade moet worden voltooid.
해당 제품
Connectrix MDS-9710-V2, Connectrix MDS-Series Firmware 8.X제품
Connectrix MDS-9506, Connectrix MDS-9509, Connectrix MDS-9513, Connectrix MDS-9706, Connectrix MDS-9706-V2, Connectrix MDS-9710, Connectrix MDS-9718, Connectrix MDS-9718-V3문서 속성
문서 번호: 000197811
문서 유형: Solution
마지막 수정 시간: 10 9월 2025
버전: 6
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.