Connectrix MDS-uppgraderingen returnerar meddelandet "Pre-upgrade check failed "Return code -1."
요약: När du utför connectrix MDS-uppgraderingen returnerar kommandot "install all" meddelandet "Pre-upgrade check failed. "Returkod -1."
이 문서는 다음에 적용됩니다.
이 문서는 다음에 적용되지 않습니다.
이 문서는 특정 제품과 관련이 없습니다.
모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.
증상
Vid försök att köra kommandot "install all" returnerar switchen meddelandet "Pre-upgrade check failed. "Returkod -1."
Inga indikationer på vad som är fel, md5sum av filerna för fast programvara är bra. Tillräckligt med utrymme på bootflash: och även i standby supervisor, men kommandot "install all" misslyckas ändå med "Return code -1".
Inga indikationer på vad som är fel, md5sum av filerna för fast programvara är bra. Tillräckligt med utrymme på bootflash: och även i standby supervisor, men kommandot "install all" misslyckas ändå med "Return code -1".
원인
Kommandot
fungerar bra.
Kommandot
(Det här är samma meddelande som kommandot "Install all".)
"show incompatibility-all system bootflash:m9700-sf2ek9-xxxx.bin"
fungerar bra.
Kommandot
"show install all impact kickstart bootflash:m9700-sf2ek9-kickstart-mz.xxxx.bin system bootflash:m9700-sf2ek9-mz.xxxx.bin" fails with "Return code -1."
(Det här är samma meddelande som kommandot "Install all".)
해결
Alternativ lösning:
- Kör ett "systemväxlingskommando" för failover till den andra supervisorn. Vänta tills kommandot har slutförts. Använd kommandot "show system redundancy status" för att bekräfta att åtgärden har slutförts.
- Kör ett andra "systemväxlingskommando" för att återgå till den tidigare aktiva supervisor där uppgraderingskoden för närvarande finns.
- Kör kommandot "install all" igen så slutförs uppgraderingen.
해당 제품
Connectrix MDS-9710-V2, Connectrix MDS-Series Firmware 8.X제품
Connectrix MDS-9506, Connectrix MDS-9509, Connectrix MDS-9513, Connectrix MDS-9706, Connectrix MDS-9706-V2, Connectrix MDS-9710, Connectrix MDS-9718, Connectrix MDS-9718-V3문서 속성
문서 번호: 000197811
문서 유형: Solution
마지막 수정 시간: 10 9월 2025
버전: 6
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.