CloudLink: Poista käytöstä AWS-konsolin yhteys CloudLink-käyttöjärjestelmään

요약: AWS:llä on esiasennettu SSM-agentti kaikissa tuetuissa käyttöjärjestelmissä. Tämä SSM-agentti antaa myös pääsyn suoraan CloudLink-käyttöjärjestelmän konsoliin.

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Dell suosittelee, että SSM-agentti poistetaan CloudLink-esiintymistä, koska se aiheuttaa tietoturvahaavoittuvuuksia.

원인

AWS:ssä SSM-agentti on esiasennettuna kaikissa tuetuissa käyttöjärjestelmissä, jotta käyttöjärjestelmäkonsoli voidaan avata suoraan.

Tuotteet ja versiot, joita ongelma koskee: Kaikki CloudLink-versiot versioon 7.1.3 saakka, kun ne otetaan käyttöön AWS:ssä.

해결

Jotta kirjautuminen voidaan poistaa käytöstä Session Managerin kautta CloudLink-käyttöjärjestelmään, järjestelmänvalvojan on poistettava SSM-agentti CloudLink-esiintymästä.

Kiertotapoja on kaksi:
Remediation workflow 1:   Kun käyttäjä voi käyttää CloudLink-konsolia Session Managerin kautta,
Korjaustyönkulku 2:   Kun käyttäjä ei voi käyttää CloudLink-konsolia Session Managerin kautta,


Korjaustyönkulku 1:

1.    CloudLink-esiintymä.
image.png

2.    Valitse Session Manager -välilehdessä -> Connect (Yhdistä) -painike
image.png

3.    Kun olet CloudLink-konsolissa Session Managerilla, kirjoita sudo su
image.png

4.    Tarkista CloudLink-konsolissa käynnissä olevan SSM-agentin tila komennolla
systemctl status snap.amazon-ssm-agent.amazon-ssm-agent.service"

image.png
5.    Voit näyttää käynnissä olevan SSM-agentin CloudLink-konsolissa komennolla
snap list amazon-ssm-agent"
image.png

6.    Poista SSM-agentti CloudLink-konsolista komennolla
snap remove amazon-ssm-agent Validate

image.png SSM agent is removed from CloudLink instance.

7.    Kun SSM-agentin CloudLink-esiintymän asennus poistetaan, Connect-painike poistetaan käytöstä
image.png
8.    Kun käyttäjä yrittää SSH:n ja CloudLinkin IP-osoitetta, käyttäjä siirtyy CloudLink-kirjautumiskehotteeseen
image.png

9.    Tarkista SSM-agentin tila.  Varmista, että agentti on "Pysähtynyt"
image.png

10.    Tarkista SSM-agenttien luettelo.  Tilailmoitus No matching snaps installed.
image.png

Korjaustyönkulku 2:
Session Manager ei ole käytössä, kun IAM-roolia ei ole valittu. Ilman Istunnon hallintaa käyttäjä ei voi käyttää CloudLink-konsolia.
Voit tarkistaa IAM-profiilin kirjautumalla AWS-> Launch EC2 -instance -> Advanced details -> IAM Instance profile
image.png
Recommended not select any profile under "IAM Instance profile", mikä estää Session Manageria muodostamasta yhteyttä CloudLink-konsoliin.
image.png

HUOMAUTUS: Jos Session Manager ei voi muodostaa yhteyttä CloudLink-konsoliin, käyttäjän on otettava yhteys tekniseen tukeen , jotta SSM-agentin asennus voidaan poistaa CloudLink-esiintymistä.

해당 제품

CloudLink SecureVM, CloudLink
문서 속성
문서 번호: 000200819
문서 유형: Solution
마지막 수정 시간: 14 5월 2026
버전:  6
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.