AppSync: Uploading .xml license file in UI receives error: Adding the license failed due to "Invalid license file"
Samenvatting: Uploading .xml license file in UI receives error: Adding the license failed due to "Invalid license file".
Dit artikel is van toepassing op
Dit artikel is niet van toepassing op
Dit artikel is niet gebonden aan een specifiek product.
Niet alle productversies worden in dit artikel vermeld.
Symptomen
In AppSync UI, when uploading .xml license in Settings > License > Upload, receive an error:
Adding the license failed due to "Invalid license file"

Oorzaak
The first scenario seen was the entire <lockingID> section was missing from the license file.
There should be a lockingID section like the following:
<LockingIds> <LockingId> <LockingIdCode>HOSTID</LockingIdCode> <LockingIdValue>value</LockingIdValue> </LockingId> </LockingIds>
The second scenario seen was the LockingIdCode being inappropriately found to be XIOD like so:
<LockingId> <LockingIdCode>XIOID</LockingIdCode>
When it should be HOSTID
<LockingId> <LockingIdCode>HOSTID</LockingIdCode>
Oplossing
The internal licensing generation mechanism is updated to ensure the Locking ID section is populated.
A new license is needed. Obtain a new license from the licensing team.
Extra informatie
AppSync 4.2 and later supports XML type licenses.
Getroffen producten
AppSyncArtikeleigenschappen
Artikelnummer: 000193800
Artikeltype: Solution
Laatst aangepast: 10 sep. 2025
Versie: 4
Vind antwoorden op uw vragen via andere Dell gebruikers
Support Services
Controleer of uw apparaat wordt gedekt door Support Services.