PowerStore: Oppgradering fra PowerStoreOS 3.0/3.2 til 4.0.0.x kan mislykkes og tilbakerulles hvis nye SCSI-reservasjoner oppstår under prosessen

Sammendrag: En oppgradering fra PowerStoreOS 3.0.x eller 3.2.x direkte til 4.0.0.x kan mislykkes og tilbakerulles hvis det oppstår nye SCSI-reservasjonsforespørsler under oppgraderingsfremdriften.

Denne artikkelen gjelder for Denne artikkelen gjelder ikke for Denne artikkelen er ikke knyttet til noe bestemt produkt. Det er ikke produktversjonene som identifiseres i denne artikkelen.

Symptomer

Følgende PowerStoreOS-programvareversjoner kan være utsatt for dette problemet:
  • PowerStoreOS 3.0.x
  • PowerStoreOS 3.2.x

Følgende endringer i et PowerStore-miljø kan utgjøre dette problemet:
  • Direkte programvareoppgradering fra PowerStoreOS 3.0.x til PowerStoreOS 4.0.0.x
  • Direkte programvareoppgradering fra PowerStoreOS 3.2.x til PowerStoreOS 4.0.0.x

Følgende vertsmekanisme kan bidra til å avdekke dette problemet:
  • Bruk av SCSI-reservasjoner for å kontrollere tilgangen til volumer.
  • SCSI-reservasjoner vises i vertsmiljøer i klynger, verter som er konfigurert for høy tilgjengelighet, virtualiserte miljøer og når du bruker sikkerhetskopierings-/gjenopprettingsbaserte applikasjoner.

Årsak

SCSI-reservasjonsforespørsler som sendes til et PowerStore-verktøy under en programvareoppgradering, kan ikke behandles på riktig måte.

I sjeldne tilfeller kan interne tjenester bli midlertidig påvirket i en kort periode.

Oppløsning

Løsning

Hvis SCSI-reservasjoner er i bruk, er følgende alternativer tilgjengelige:
  • Oppgrader til den nyeste versjonen av PowerStoreOS 3.6.1.x, og forbli på denne programvareversjonen til en reparasjon leveres i en fremtidig PowerStoreOS-utgivelse.
  • Hvis PowerStoreOS 4.0.0.x-funksjoner kreves, utfører du en midlertidig oppgradering til den nyeste PowerStoreOS 3.6.1.x-utgivelsen før du oppgraderer til den nyeste PowerStoreOS 4.0.0.x-utgivelsen.
  • Hvis du trenger hjelp med å avgjøre om SCSI-reservasjoner er aktive på et tilpasset verktøy for PowerStore før en oppgradering, kan du kontakte Dells tekniske kundestøtte. Se denne KB-artikkelen i serviceforespørselen for rask håndtering.
Se PowerStoreOS-matrisen for de nyeste programvaretilbudene for PowerStoreOS 3.6.1.x og PowerStoreOS 4.0.0.x.

Berørte produkter

PowerStore, PowerStore 1000T, PowerStore 1200T, PowerStore 3000T, PowerStore 3200T, PowerStore 5000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000T, PowerStore 9000T

Produkter

PowerStore 9200T, PowerStoreOS
Artikkelegenskaper
Artikkelnummer: 000228564
Artikkeltype: Solution
Sist endret: 14 feb. 2025
Versjon:  3
Få svar på spørsmålene dine fra andre Dell-brukere
Støttetjenester
Sjekk om enheten din er dekket av støttetjenestene.