NetWorker: Rozwiązywanie problemów z kopiami zapasowymi z powodu problemów z usługą VSS

Podsumowanie: Tworzenie kopii zapasowych klienta systemu Windows kończy się niepowodzeniem z powodu problemów z usługą kopiowania woluminów w tle firmy Microsoft (VSS). Istnieje kilka różnych przyczyn, które mogą spowodować, że usługa VSS nie przetworzy migawki w systemie operacyjnym klienta; Przykład: Niestabilny składnik zapisywania usługi VSS lub niewystarczająca ilość miejsca do utworzenia migawki. Usługa VSS jest wymagana do STANU SYSTEMU lub ODZYSKIWANIA PO AWARII: zestawów zapisów lub podczas tworzenia kopii zapasowych opartych na blokach (BBB). Usługa VSS musi być stabilna i działać prawidłowo w systemie operacyjnym hosta, aby można było jej używać z kopiami zapasowymi NetWorker. ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Tworzenie kopii zapasowych klienta systemu Windows kończy się niepowodzeniem z powodu problemów z usługą VSS. Istnieje kilka różnych przyczyn, które mogą spowodować, że usługa VSS nie przetworzy migawki w systemie operacyjnym klienta; Na przykład: Niestabilny składnik zapisywania usługi VSS lub niewystarczająca ilość miejsca do utworzenia migawki.
UWAGA: W tej bazie wiedzy opisano kroki dla administratorów systemu Windows lub NetWorker, ale uporczywe problemy z usługą VSS należy zgłaszać do pomocy technicznej firmy Microsoft w celu dalszego zbadania.

Problemy te są zazwyczaj sygnalizowane w dziennikach kopii zapasowych, które można zaobserwować w NMC.
VSS OTHER: ERROR: VSS failed to process snapshot: 
90108:save: Unable to save the SYSTEM STATE save sets: cannot create the snapshot. 
7259:save: VSS reports adding volume [C:\] <file:///C:/]> to snapshot set failed for both hardware/software provider.VSS OTHER: ERROR: VSS failed to process snapshot: Unexpected VSS provider error.
VSS OTHER: ERROR: VSS failed to process snapshot: Insufficient storage available to create either the shadow copy storage file or other shadow copy data. (VSS error 0x8004231f)
90108:save: Unable to save the SYSTEM STATE save sets: cannot create the snapshot.
Zdarzenia związane z usługą VSS są również widoczne w Podglądzie zdarzeń systemu Windows na kliencie.

Przyczyna

VSS to funkcja systemu operacyjnego Windows. Usługa VSS jest wymagana dla STANU SYSTEMU lub ODZYSKIWANIA PO AWARII:\ zestawów zapisów lub podczas tworzenia kopii zapasowych opartych na blokach (BBB). Usługa VSS musi być stabilna i działać prawidłowo w systemie operacyjnym hosta, aby można było jej używać z kopiami zapasowymi NetWorker.

Rozwiązanie

Najpierw należy wykluczyć potencjalny problem z pojemnością. Firma Microsoft zaleca pozostawienie 10–15% całkowitej pojemności dysków dostępnych do wykonania migawek VSS. Jeśli pojemność przekracza 90%, migawki VSS mogą zakończyć się niepowodzeniem.

Aby sprawdzić, czy usługa VSS działa poprawnie w klienckim systemie operacyjnym, uruchom następujące polecenia z wiersza poleceń administratora:
1. Sprawdź stan modułów zapisujących VSS: vssadmin list writers
Przykład:

c:\>vssadmin list writers
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

Writer name: 'System Writer'
Writer Id: {e8132975-6f93-4464-a53e-1050253ae220}
Writer Instance Id: {34a07e16-fcdb-4ab0-b603-d58c0f741c9a}
State: [1] Stable
Last error: No error
...
...
UWAGA: Powyższy wynik jest przykładem jednego z pisarzy; jednak WSZYSTKIE zapisy powinny być stabilne, bez błędów.


2. Jeśli składniki zapisywania są stabilne w celu sprawdzenia istniejących wcześniej migawek, nie powinno być żadnych: vssadmin list shadows
Przykład:

c:\>vssadmin list shadows
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

No items found that satisfy the query.

3. Jeśli na liście znajdują się migawki, usuń je: vssadmin delete shadows /all
Przykład:
c:\>vssadmin delete shadows /all
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

Do you really want to delete 1 shadow copies (Y/N): [N]? y

Successfully deleted 1 shadow copies.
4. Jeśli liczba migawek dysku jest zajęta poniżej 90%, spróbuj utworzyć migawkę: vssadmin create shadow /for=DRIVE_LETTER:\ 
Przykład: 
c:\>vssadmin create shadow /for=C:\
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

Successfully created shadow copy for 'C:\'
    Shadow Copy ID: {1f6a1448-daad-4e68-a334-31dd40a64dd9}
    Shadow Copy Volume Name: \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy2
UWAGA: Należy to zrobić dla każdego woluminu krytycznego wymaganego dla STAN SYSTEMU lub DISASTER_RECOVERY:\ zestawy zapisu.


5. Jeśli migawka została pomyślnie utworzona, usuń ją za pomocą polecenia z kroku 3 i uruchom kopię zapasową tego klienta. Jeśli tworzenie kopii zapasowej nie powiedzie się z powodu problemu z usługą VSS, skontaktuj się z pomocą techniczną Dell NetWorker, aby uzyskać pomoc. Zaleca się również skontaktowanie się z pomocą techniczną firmy Microsoft w przypadku konieczności współpracy między pomocą techniczną NetWorker a pomocą techniczną Microsoft. 

Dodatkowe informacje

Wymagania dotyczące miejsca w usłudze VSS: https://technet.microsoft.com/en-us/library/cc161409.aspxKliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.
Informacje o usłudze VSS: https://msdn.microsoft.com/en-us/library/windows/desktop/aa384625(v=vs.85).aspxKliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.
Bardziej zaawansowane kroki rozwiązywania problemów z usługą VSS są udokumentowane w: Opcje śledzenia i rozwiązywania problemów z usługą VSS

Obejście problemu:

Poniższe obejście może służyć do uzyskiwania pomyślnych kopii zapasowych bez VSS.

OSTRZEŻENIE: Nie jest to rozwiązanie problemu. Jest to tymczasowe obejście do użycia do momentu rozwiązania problemów z usługą VSS. Bez usługi VSS nie można wykonywać kopii zapasowych DISASTER_RECOVERY:\ ani SYSTEM_STATE. Chronione są tylko dane systemu plików. To obejście nie jest możliwe w przypadku tworzenia kopii zapasowych opartych na blokach (BBB).
  1. Zaloguj się do konsoli NetWorker Management Console (NMC).
  2. Upewnij się, że w NMC jest włączony tryb diagnostyki >widoku.
  3. Uzyskaj dostęp do właściwości klienta systemu Windows z karty Protection-Clients>.
  4. Na karcie Ogólne właściwości klienta zmień pole Zapisz zestawy , aby uwzględniało tylko nazwy woluminów, folderów lub plików (na przykład: C:\).
UWAGA: Nie można użyć opcji Save set All . Nie można określić DISASTER_RECOVERY:\.
  1. Na karcie Apps & Modules ustaw vss:*=off w obszarze Operacje zapisywania.
  2. Wykonaj kopię zapasową klienta.
  3. Po rozwiązaniu problemów z usługą VSS usuń plik vss:*=off i ustaw pole zestawu zapisu klienta na Wszystkie lub dołącz DISASTER_RECOVERY:\ zestaw zapisu, aby uzyskać stan systemu.

Produkty, których dotyczy problem

NetWorker

Produkty

NetWorker
Właściwości artykułu
Numer artykułu: 000031318
Typ artykułu: Solution
Ostatnia modyfikacja: 13 mar 2026
Wersja:  6
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.