Konto administratora NetWorker utraciło uprawnienia zabezpieczeń

Podsumowanie: Grupy użytkowników są puste, we właściwościach serwera NetWorker "Administrator" po zalogowaniu się jako administrator NetWorker zgłasza komunikat "Brak uprawnień do wyświetlania listy administratorów". Konto administratora NetWorker powinno mieć pełną kontrolę nad przeglądaniem i zmienianiem wszystkich uprawnień serwera. ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Konto administratora NetWorker nie może już wyświetlać "Grup użytkowników" w konsoli NetWorker Management Console (NMC) lub sieciowym interfejsie użytkownika NetWorker (NWUI)

NMC:

Grupa użytkowników NMC NSR nie pokazuje żadnych grup użytkowników po zalogowaniu się jako administrator NetWorker 

NWUI:
NWUI nie wyświetla żadnych grup użytkowników po zalogowaniu się jako konto administratora 

Właściwości serwera NetWorker zgłaszają również problem z uprawnieniami:

NMC:
Raporty o właściwościach serwera NMC Brak uprawnień do przeglądania listy administratorów 

NWUI:
Karta serwera NWUI zgłasza Brak uprawnień do przeglądania listy administratorów 

Inne zasoby, takie jak klienci, urządzenia itd., mogą być nadal widoczne.

UWAGA: Jeśli inne zasoby serwera NetWorker również nie są widoczne w interfejsach użytkownika, ustawienia administratorów aplikacji również mogły zostać usunięte. Czynności opisane w polu Rozwiązywanie dodają również domyślną grupę Administratorzy z powrotem do grupy użytkowników Administratorzyaplikacji, jeśli została usunięta.

Przyczyna

Nazwa wyróżniająca (DN) grupy administratorów lokalnych została usunięta z pola ról zewnętrznych grupy użytkowników "Security Administrators" serwera NetWorker.

[root@nsr ~]# nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> show name; external roles
nsradmin> print type: nsr usergroup; name: "Security Administrators"
                        name: Security Administrators;
              external roles: ;
nsradmin>
UWAGA: Pole Role zewnętrzne administratora zabezpieczeń powinno zawierać domyślny wpis dla lokalnej grupy administratorów serwera NetWorker. Na przykład: ”cn=Administrators,cn=Groups,cn=NETWORKER_SERVER_NAME,dc=DOMAIN_COMPONENT1,dc=DOMAIN_COMPONENT2”. / nsr/logs/rap.log serwera NetWorker może pokazywać, który użytkownik zmodyfikował to pole, aby usunąć ustawienia domyślne.

Rozwiązanie

1. Potwierdź, który host jest serwerem AUTHC.

Serwer NMC:
Linux: /opt/lgtonmc/etc/gstd.conf
Windows: <INSTALL_DRIVE>:\Program Files\EMC NetWorker\Management\GST\etc\gstd.conf

Ten plik zawiera ciąg znaków authsvc_hostname. Wartość tego pola to host AUTHC używany przez NMC.

Serwer NWUI:
Linux: /opt/nwui/logs/install.log
Windows: %LOCALAPPDATA%\Temp\NetWorker_DATE_MCUI.log  

Pakiet install.log zawiera wiersze pokazujące, co AUTH_HOSTNAME został ustawiony jako "Serwer uwierzytelniania" podczas wstępnej konfiguracji NWUI.
 

2. Otwórz wiersz poleceń administratora lub powłokę roota na serwerze NetWorker.
3. Wprowadź: nsraddadmin -H AUTHC_SERVER_NAME -p 9090

UWAGA: Zastąp AUTHC_SERVER_NAME nazwą hosta/adresem serwera AUTHC określonym w kroku 1.

Przykład:

[root@nsr ~]# nsraddadmin -H nsr.amer.lan -P 9090
134751:nsraddadmin: Added role 'cn=Administrators,cn=Groups,dc=nsr,dc=amer,dc=lan' to the 'Security Administrators' user group.
134749:nsraddadmin: 'cn=Administrators,cn=Groups,dc=nsr,dc=amer,dc=lan' is already on the 'external roles' list of 'Application Administrators' user group.
134749:nsraddadmin: 'cn=Users,cn=Groups,dc=nsr,dc=amer,dc=lan' is already on the 'external roles' list of 'Users' user group.

Jeśli pole zostało zaktualizowane poprawnie, powinny być teraz widoczne opcje "User Groups" i właściwości serwera NetWorker z NMC i NWUI.

Dodatkowe informacje

Produkty, których dotyczy problem

NetWorker

Produkty

NetWorker, NetWorker Management Console
Właściwości artykułu
Numer artykułu: 000037228
Typ artykułu: Solution
Ostatnia modyfikacja: 18 lut 2026
Wersja:  8
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.