ECS: Dial Home - EKMServerConnectionStatus - Codice sintomo: 1369 e 1370
Podsumowanie: È stata introdotta una dial home per rilevare l'avviso EKMServerConnectionStatus.
Ten artykuł dotyczy
Ten artykuł nie dotyczy
Ten artykuł nie jest powiązany z żadnym konkretnym produktem.
Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.
Objawy
ECS ha chiamato casa con il seguente avviso:
| Codice sintomo | Gravità |
| 1369 | WARNING |
| 1370 | ERROR |
<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<TransType>10</TransType>
<TransTypeDesc>EventXML</TransTypeDesc>
<TransID>0</TransID>
<Node Status="Unknown" State="Unknown" ID="ECSQE00079">
<Identifier>
<DeviceState>1</DeviceState>
<DeviceStatus>1</DeviceStatus>
<ClarifyID>ECSQE00079</ClarifyID>
<SiteName>UNKNOWN</SiteName>
<Vendor>EMC</Vendor>
<DeviceType>ElasticCloudStorageApp</DeviceType>
<Model>ElasticCloudStorage</Model>
<SerialNumber>ECSQE00079</SerialNumber>
<WWN>ECSQE00079</WWN>
<Platform>platform</Platform>
<OS>SLES</OS>
<OS_VER>12.3</OS_VER>
<UcodeVer>3.3.0.0-4349.d0de882</UcodeVer>
<EmbedLevel>2</EmbedLevel>
<InternalMaxSize>512800</InternalMaxSize>
<Comment>Object Alert</Comment>
</Identifier>
<Connection>
<ConnectType>ESRS</ConnectType>
<IPName>xxxxx-yyyyyy.ecs.lab.fqdn.com</IPName>
<ConnectNum>xx.xxx.xxx.xx</ConnectNum>
<Port>22</Port>
</Connection>
<HeartBeat>
<HBStatus></HBStatus>
<HBState></HBState>
</HeartBeat>
<InternalData>
<FileList/>
<EventList>
<Event>
<SymptomCode>1370</SymptomCode>
<Category>Configuration</Category>
<Severity>Error</Severity>
<Status>Unknown</Status>
<Component>Object</Component>
<ComponentID></ComponentID>
<SubComponent>EKM Server Connection Status</SubComponent>
<SubComponentID></SubComponentID>
<CallHome>true</CallHome>
<FirstTime>2022-01-29T07:32:09.718Z</FirstTime>
<LastTime>2022-01-29T07:32:09.718Z</LastTime>
<Count>0</Count>
<EventData><![CDATA[]]></EventData>
<Description><![CDATA[The EKM Server: ecs-test-keysecure-xx.xxx.xxx.xxx is not responding. Please ensure that the server is connected. [Ref_ID : EKMServerConnectionStatus]]]></Description>
</Event>
</EventList>
</InternalData>
<ExternalFiles/>
</Node>
</ConnectHome>
Przyczyna
Il server EKM (Extensible Key Management) non risponde. Verificare che il server sia connesso.
Rozwiązanie
Verifica dello stato
Comando:
svc_rest_cmd -i `hostname -i` /vdc/sensor/status/EKMServerConnectionStatusEsempio:
# svc_rest_cmd -i `hostname -i` /vdc/sensor/status/EKMServerConnectionStatus
svc_rest_cmd 1.0.10
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
<SensorId>KMServerConnectionStatus</SensorId>
<ListSensorStatus>
<SensorStatusRestRep>
<ContextId>EKMServerConnectionStatus</ContextId>
<CurrentState>OK</CurrentState>
<NodeId>1f4368c3-37cd-467f-9efc-289264806ea0</NodeId>
<PreviousState>OK</PreviousState>
<Time>1551118064264</Time>
</SensorStatusRestRep>
</ListSensorStatus> Cercare CurrentState come sopra, se impostato su OK l'errore può essere ignorato. Se il problema non è corretto (avvertenza o errore), procedere con la procedura di risoluzione dei problemi riportata di seguito.
Risoluzione dei problemi
Individuare il server indicato nel messaggio di avviso ricevuto e provare a eseguirne il ping:Description><![CDATA[The EKM Server: ecs-dev-keysecure-xx.xxx.xx.xxx is not responding. Please ensure that the server is connected. [Ref_ID : EKMServerConnectionStatus]]]></Description>Controllare resourcesvc.log per i messaggi relativi al problema Server EKM:
Comando:
grep /opt/emc/caspian/fabric/agent/services/object/main/log/<EKM Server Name> resourcesvc.log
Esempio:
The command will return output in the following format:
There was some error verifying connection to EKMServer {will have failed server name} in cluster. {will have failure detail}
Gli errori indicano un possibile problema di rete nell'ambiente. La comunicazione tra ECS e il server EKM potrebbe essere bloccata o il server EKM stesso potrebbe non essere disponibile. Verificare che ECS sia in grado di eseguire il ping del server EKM e consigliare all'utente di verificare che il server EKM funzioni.
Se non è possibile risolvere il problema, aprire una Service Request con il supporto ECS per ricevere assistenza con le informazioni raccolte in precedenza.
Se non è possibile risolvere il problema, aprire una Service Request con il supporto ECS per ricevere assistenza con le informazioni raccolte in precedenza.
Produkty, których dotyczy problem
ECS, ECS Appliance, ECS Software, Elastic Cloud StorageWłaściwości artykułu
Numer artykułu: 000038620
Typ artykułu: Solution
Ostatnia modyfikacja: 17 gru 2025
Wersja: 7
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.