NVP vProxy: Wyłączenie maszyny wirtualnej następuje podczas odzyskiwania dysku wirtualnego
Podsumowanie: Przywracanie vProxy VMDK (dysku) NetWorker VMware Protection (NVP) wyłącza maszynę wirtualną (VM) w ramach przywracania.
Objawy
Integracja NetWorker VMware Protection jest skonfigurowana z urządzeniem vProxy. Odzyskiwanie dysku wirtualnego jest konfigurowane w konsoli NetWorker Management Console (NMC) na istniejącej maszynie wirtualnej (VM). Odzyskiwanie dysku wirtualnego do włączonej maszyny wirtualnej powoduje zamknięcie systemu operacyjnego gościa. Klient internetowy vSphere wyświetla zdarzenie "Zainicjowanie zamknięcia systemu operacyjnego gościa" żądane przez konto używane w konfiguracji NetWorker VMware View (NSR Hypervisor). Nie można włączyć maszyny wirtualnej do momentu zakończenia przywracania.
Przyczyna
Wyłączenie systemu operacyjnego gościa jest zgodne z projektem w przepływie pracy odzyskiwania dysku wirtualnego. Zachowanie jest opisane w sekcji "Virtual disk recovery" w podręczniku integracji Dell NetWorker VMware. Wsparcie dla NetWorker | Instrukcje obsługi i dokumenty
![]()
Kreator odzyskiwania NetWorker Management Console (NMC) wyświetla następujący monit ostrzegawczy przed kontynuowaniem przywracania:
Rozwiązanie
Konfiguracja odzyskiwania dysku wirtualnego ma opcję "Włącz maszynę wirtualną", która automatycznie włączy maszynę wirtualną po odzyskaniu dysku wirtualnego.
Jeśli ta opcja nie zostanie zaznaczona, maszyna wirtualna pozostanie wyłączona i musi zostać włączona z VMware.
Obejście problemu:
Odzyskiwanie dysku wirtualnego można wykonać na innej "tymczasowej" maszynie wirtualnej, jeśli oryginalnej maszyny wirtualnej nie można zamknąć podczas przywracania. Po zakończeniu przywracania odłącz dysk od "tymczasowej" maszyny wirtualnej i zamontuj go na żądanej maszynie wirtualnej, korzystając z opcji VMware "Add Existing Hard Disk".
Dodatkowe informacje
Sieciowy interfejs użytkownika NetWorker (NWUI) nie ostrzega o wyłączeniu maszyny wirtualnej podczas przywracania. Wniosek o ulepszenie NW-I-2426 został otwarty z tym żądaniem. Aby śledzić ten RFE, skontaktuj się z działem obsługi klienta lub sprzedaży firmy Dell w sprawie RFE NW-I-2426.