ECS: Napęd GeoDrive: Stan błędu zwracany po odrzuceniu żądania oplock

Podsumowanie: GeoDrive wyświetla komunikat o błędach "Stan błędu zwrócony po odrzuceniu żądania oplock" podczas przesyłania niektórych plików.

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

GeoDrive generuje komunikaty takie jak poniżej:

Site=hostname  File=atmos.cpp  Line=16612  Revision=-v1.2.3.1
  Severity=WARNING  Category=0  Process=Server  Error=3221225698:3221225698 - Error status returned when oplock request is denied.
  Time=9/19/2018 2:11:27 PM 913 ms   Thread=480
File open error: d:\programdata\cifs-ecs data\e_drive\temp\123\l_b094.tmp.png

Przyczyna

Jest to problem związany z klientem.

Rozwiązanie

Oznacza to, że GeoDrive przesyła plik i próbuje go otworzyć i otrzymuje ten błąd. Nie oznacza to problemu z GeoDrive, ale problem z klientem.
 
Ten błąd oznacza, że jakiś inny proces ma blokadę oplock w pliku. GeoDrive chce przesłać plik, więc próbuje go otworzyć. Spowoduje to wysłanie do klienta przerwy oplock. Klient powinien opróżnić dane rezydenta pamięci na dysk i potwierdzić, że oplock zniknął, ale nie odpowiada na żądanie przerwania oplock. GeoDrive czeka chwilę i nigdy nie dostaje przerwy oplock, więc jego otwarcie kończy się niepowodzeniem.
 
Problem najprawdopodobniej tkwi w kliencie, który trzyma oplock. Rozważam ponowne uruchomienie tego klienta.

Dodatkowe informacje

Produkty, których dotyczy problem

GeoDrive for Windows

Produkty

GeoDrive for Windows, ECS Appliance, ECS Appliance Hardware Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, Elastic Cloud Storage
Właściwości artykułu
Numer artykułu: 000039852
Typ artykułu: Solution
Ostatnia modyfikacja: 26 maj 2025
Wersja:  5
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.