Data Protection Advisor: Zbieranie danych DPA dla MS SQL nie działa

Podsumowanie: Data Protection Advisor: Zbieranie danych DPA dla MS SQL nie działa

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Po zmianie usługi agenta DPA na uruchamianą jako nazwany użytkownik i dodaniu MSSQL do DPA historia żądań monitora zadań jest pusta. Uruchom modtest w graficznym interfejsie użytkownika. Znajdujący się w nim plik xml zawiera poniższy komunikat.
Unable to run request mssqldb:jobmonitor as there was an error opening the required pstore <DPA_Install_dir>\EMC\DPA\agent\data\mssqldb_jobmonitor_<MSSQL_server_name>_<Instance_name>.db.</MESSAGE><REPORT>

Under folder <DPA_Install_dir>\EMC\DPA\agent\data, one cannot find the file mssqldb_jobmonitor_<MSSQL_server_name>_<Instance_name>.db.
Ponownie uruchomiłem agenta DPA, ale plik nie został wygenerowany. Ponadto w dpagent.log nie ma żadnego wpisu dotyczącego ponownego uruchomienia agenta. Nawet jeśli zmieni się poziom dziennika w dpagent_config.xml pliku na Debug low, a następnie ponownie uruchomi się agent, dpaagent.log nie ma 

Przyczyna

Produkt działa zgodnie z założeniami.
W jednym przypadku, w którym to zaobserwowano, nazwane konto, z którym działają usługi agenta DPA, nie ma wystarczających uprawnień.

Rozwiązanie

W jednym przypadku, w którym zaobserwowano tę problem, problem został rozwiązany po zmianie usługi agenta DPA na działanie jako inne konto domeny. 

Produkty, których dotyczy problem

Data Protection Advisor

Produkty

Data Protection Advisor
Właściwości artykułu
Numer artykułu: 000055127
Typ artykułu: Solution
Ostatnia modyfikacja: 22 sty 2026
Wersja:  6
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.