NMDA: Kopie zapasowe migawek IBM DB2 nie odpowiadają

Podsumowanie: Moduł NetWorker dla baz danych i aplikacji (NMDA) Kopie zapasowe migawek IBM DB2 nie odpowiadają.

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Kopie zapasowe migawek NMDA IBM DB2 nie odpowiadają.
Baza danych DB2 jest w trybie wstrzymania zapisu.
Błąd w db2diag.log

Warning:
----------------------------------------
2016-05-20-15.05.16.771114+000 E7423877A808       LEVEL: Warning
PID     : 7733668              TID  : 47390       PROC : db2sysc 0
INSTANCE: <instance_name>      NODE : 000         DB   :
APPHDL  : 0-57647              APPID: <app_id>
AUTHID  :  
EDUID   : 47390                EDUNAME: db2agent (instance) 0
FUNCTION: DB2 UDB, database monitor, sqm___sqlmonssagnt, probe:1234
DATA #1 : <preformatted>
 
This occurs when any snapshot other than list applications is attempted
on a database that is write suspended. This is necessary due to latching
conflicts. This database is skipped in the snapshot, but other databases
should still be processed. Skipping database '<db_name>'.
For more information on write suspend, please see the
'db2 set write suspend for database' command.
------------------------------------------

Przyczyna

Proces roboczy DB2 działa jako:

Wywołania DB2 db2ACSPrepare() w bibliotece NMDA DB2, aby wykonać wstępne przygotowanie do migawki sprzętu. Po wykonaniu tej czynności Menedżer bazy danych DB2 zawiesza bazę danych i wywołuje funkcję NMDA DB2 db2ACSSnapshot(). W takim przypadku baza danych DB2 nie wywołuje db2ACSSnapshot(). Przepływ pracy przestaje reagować, aby silnik DB2 mógł kontynuować tworzenie kopii zapasowej. IBM wspiera PMR: 29538 004 000 jest otwartych. Inżynierowie IBM DB2 wymagają więcej debugowania, aby określić główną przyczynę tego zawieszenia.

Rozwiązanie

Obejście problemu:
 

  1. Anuluj bieżącą kopię zapasową
  2. Wyprowadź bazę danych z trybu wstrzymania zapisu

Aby odkryć pierwotną przyczynę, IBM DB2 Support prosi o następujące informacje w celu dalszego zbadania:
 

  1. Usuń lub przenieś wszystkie stosy lub zrzuty w katalogu db2dump. Tworzy nowe stosy lub zrzuty bez mieszania starych. (Ścieżka UNIX/Linux: /$INSTHOME/sqllib/db2dump)
  2. DB2 śledź przez krótką chwilę:
    db2trc on -f trace.dmp
    wait about 30 seconds
    db2trc off
    db2trc fmt trace.dmp trace.fmt
    db2trc flw trace.dmp trace.flw
  3. Zbieraj stosy:
    db2pd -stack all -rep 5 5
  4. Po wykonaniu powyższego kroku uruchom polecenie
    procstack <PID> > db2vend.pstack.out
    <PID> to identyfikator procesu db2vend procesu dla bazy danych.
  5. Następnie pobierz sesję kopii zapasowej migawki,
    db2 get snapshot for applications on <dbname> > db2snap.out
  6. Teraz możesz ustawić wznawianie zapisu, a następnie spróbować ponownie wykonać kopię zapasową migawki i sprawdzić, czy zakończy się.
  7. Zbierz db2support.zip w następujący sposób:
    db2support . -d <dbname> -c -s
  8. Skompresuj i wyślij do IBM PMR:
  • trace.dmp
  • trace.fmt
  • trace.flw
  • db2vend.pstack.out
  • db2snap.out
  • db2support.zip

Produkty, których dotyczy problem

NetWorker Module for Databases and Applications

Produkty

NetWorker Family, NetWorker, NetWorker Module
Właściwości artykułu
Numer artykułu: 000056670
Typ artykułu: Solution
Ostatnia modyfikacja: 27 maj 2026
Wersja:  6
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.