VxRail: Błąd "503 Service Unavailable" podczas uzyskiwania dostępu do VMware vCenter

Podsumowanie: Kroki rozwiązywania problemów w celu rozwiązania błędu "503 Service Unavailable Failed to connect to endpoint" z VMware vCenter.

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Administratorzy mogą nie mieć dostępu do vCenter. Podczas logowania do interfejsu użytkownika zostanie opublikowany następujący komunikat:

503 Service Unavailable Failed to connect to endpoint: [N7Vmacore4Http20NamedPipeServiceSpecE:0x00007f975808ee30] _serverNamespace = / action = Allow _pipeName =/var/run/vmware/vpxd-webserver-pipe)

Przyczyna

Przyczyny tego błędu mogą być różne. Poniżej przedstawiono kilka możliwych scenariuszy:

1. Usługi nie zostały prawidłowo uruchomione, a niektóre usługi nie działają:

# service-control --status
Running:
 lwsmd vmafdd vmcad vmdird
Stopped:
 applmgmt lookupsvc observability observability-vapi pschealth vlcm vmcam vmonapi vmware-analytics vmware-certificateauthority vmware-certificatemanagement vmware-cis-license vmware-content-library vmware-eam vmware-envoy vmware-hvc vmware-imagebuilder vmware-infraprofile vmware-netdumper vmware-perfcharts vmware-pod vmware-postgres-archiver vmware-rbd-watchdog vmware-rhttpproxy vmware-sca vmware-sps vmware-statsmonitor vmware-stsd vmware-topologysvc vmware-trustmanagement vmware-updatemgr vmware-vapi-endpoint vmware-vcha vmware-vdtc vmware-vmon vmware-vpostgres vmware-vpxd vmware-vpxd-svcs vmware-vsan-health vmware-vsm vsphere-ui vstats vtsdb wcp

 

2. Certyfikaty wygasły. Aby sprawdzić datę wygaśnięcia, podłącz vCenter i uruchom następujące polecenie:

for store in $(/usr/lib/vmware-vmafd/bin/vecs-cli store list | grep -v TRUSTED_ROOT_CRLS); do echo "[*] Store :" $store; /usr/lib/vmware-vmafd/bin/vecs-cli entry list --store $store --text | grep -ie "Alias" -ie "Not After";done;

Rozwiązanie

Poniżej przedstawiono różne rozwiązania dla scenariuszy 1 i 2 powyżej:

1. Potwierdź stan usług VMware vCenter Services. Sprawdzenie, czy wszystkie wymagane usługi są uruchomione i sprawne.
Jeśli usługi nie zostały uruchomione prawidłowo, uruchom je ponownie, korzystając z następującej bazy wiedzy:

Zatrzymywanie, uruchamianie i ponowne uruchamianie usług urządzeniaKliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.
 

2. Sprawdź, czy certyfikaty wygasły:

VxRail: Nie można zalogować się do vCenter z powodu wygaśnięcia certyfikatów
 

3. Przejrzyj dzienniki pod kątem możliwych przyczyn głównych:

/var/log/vmware/vsphere-client/logs/

/var/log/vmware/vpxd 

 

Aby uzyskać więcej informacji na temat rozwiązywania problemów, zapoznaj się z oficjalnym artykułem bazy wiedzy firmy Broadcom:

https://knowledge.broadcom.com/external/article?legacyId=67818 Kliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.

Kliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.

Dodatkowe informacje

W VxRail 4.7 (vSphere 6.7) występował historyczny problem związany z obrazem ISO z długą nazwą zamontowaną na dowolnej liczbie maszyn wirtualnych:

To sprawiło, że nazwa była zbyt długa dla bazy danych, zgodnie z następującym artykułem bazy wiedzy:

Nie można połączyć hosta z vCenter z powodu błędu: ciąg znaków zbyt duży dla bazy danych (55610)Kliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.

 

Produkty, których dotyczy problem

VxRail, VxRail Appliance Family, VxRail Software
Właściwości artykułu
Numer artykułu: 000078068
Typ artykułu: Solution
Ostatnia modyfikacja: 18 kwi 2026
Wersja:  20
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.